drag-and-drop sources into collections w/o opening collection

I have a large collection of sources and am going through and re-filing each source into different collections. As I drag and drop each source into a new collection, sometimes the collection that I am dropping it into opens up. This is incredibly frustrating because it means that I have to click back on the large collection that I am working through and scroll down to find the source I had just finished moving. It seems to happen randomly and not because I held the source over the new collection tab too long. Is there any way to fix zotero so that when someone is dragging and dropping it won't open up the collection that it is being dropped into?
  • Could you produce a Debug ID from Zotero for a drop that changes collections? You can enable debug logging and log until you reproduce the drop that caused the collections to switch? Are you using a mouse or a touchpad?
  • I just performed the action and here's the debug ID: D1897239516
    I am using a touchpad. Thanks so much for your help!
  • Unless you can reproduce this with a mouse it's likely that you are accidentally clicking/tapping the touchpad when you drop the items which is what's causing the collection to switch.
  • unfortunately, I don't own a mouse to use to test. The problem only began occurring after the new zotero version was updated, and I have been careful to not click or tap the touchpad when dropping, but with no luck.
  • I have created a video showing the problem and uploaded it to my google drive account and made it accessible to anyone who clicks on this link:


    I can't stress enough how frustrating this problem is, and how much time and troubleshooting I have devoted to trying to fix it. And you can see in the video, I am doing nothing different each time I drag and drop a citation into a separate folder and yet it randomly opens up the new folder sometimes (while, as you see in the video, sometimes it does not). If I can't resolve this problem, I will sadly need to end my zotero membership (I pay the maximum amount for this account) and migrate my massive library to a different research assistant software.

    If it is a problem with my laptop (which it might be) I would appreciate any recommendations for how to fix it there. I use a MacBook Pro ver. 12.3.1, running on Monterey. But I should mention that I don't experience any similar problem with any other programs or software I use, just zotero.
  • If I can't resolve this problem, I will sadly need to end my zotero membership (I pay the maximum amount for this account) and migrate my massive library to a different research assistant software.
    You can stop saying this in all your threads. We're helping you like we help everyone who posts here. Just report your problem.

    Can you provide a screen recording with mouse clicks enabled that shows this happening? ("Show Mouse Clicks" in the Options menu of the built-in Screenshot tool.)
  • Here is a link to a video of me doing it with the "Show Mouse Clicks" on:
  • edited June 11, 2022
    OK, thanks — we'll investigate.

    Note that, in the meantime, you can also add items to collections by right-clicking on the item(s) and using the Add to Collection menu.
  • Problem Solved
    The issue is specific to MacBook Pro, ver. 12.3.1 and the new features on the trackpad. To prevent this from happening, do the following:
    Go into System Preferences
    Click on Trackpad
    Un-check the boxes for "Secondary Click" and "Tap to click" and "Force click and haptic feedback"
    (I'm not sure which one of these features was causing problem, but un-checking these boxes solved it.)
  • No, don't turn those all off. Those are standard macOS features that greatly improve trackpad usability. It looks like what's happening is that you're triggering a Force Click — pressing the trackpad to a second level of pressure — on the collection at the end of the drag, which counts as separate click that selects the collection. If you avoid doing that, this won't happen. Or you could turn off just that setting, but that will disable haptic feedback (what makes it feel like these non-moving trackpads are being physically clicked) for the base "click" as well, so I wouldn't recommend it.

    We'll see if we're able to ignore a Force Click specifically during a drag. Thanks for debugging.
  • This is fixed in Zotero 6.0.9, available now.
  • I still experience this problem on Zotero 6.0.9 with my iMac + Magic Touchpad.
  • I still find it uncontrollable which of the two events is triggered, can we add an option to disable this behaviour completely? I just want to drag-drop without changing collection
  • This is still happening for me, in Zotero 6.0.27, with a Magic Mouse rather than a trackpad.

    I tried turning off all the Settings for Force Click and such, but it still persists in switching me over to the collection that I've dragged-and-dropped an item into, from whatever collection or saved search I might have been in prior.
  • This happens on Zotero 6.0.30 on MacOS 14.3 (23D56).
    Disabling Force Click and haptic feedback resolved the problem.
  • edited 24 days ago
    Still happening with Zotero 6.0.37 under MacOS 12.7/Magic Mouse. Very annoying. Any idea? Thanks in advance for any help!
Sign In or Register to comment.