iOS Zotero App not syncing PDFs-No Error ID

I have added three pdfs to ZOTERO on my IPad. My iPad is running iOS16 Public Beta 8. My Zotero installation is version 1.0.4 Build 19. These PDFs are accessible only on my iPad. They have not synced to my library or to my laptop installation. When I pull down on the item list to force a sync in the bottom left Sync Failed () comes up. Clicking that just pulls up a dialogue box that reads "Error"

Thanks for your help.
  • Can you provide a Debug ID for a sync attempt?
  • Hopefully, I did this right.

  • That seems to show a large sync in progress, not an error.
  • But Sync Failed () is popping up on the bottom left and the sync never goes through.
  • Try again, and make sure you’re not submitting the output until the error occurs.
  • I submitted the output when I got the Sync Failed () message.
  • I just ran it again (D1172766919). I watched the app closer this time. Every couple of minutes Sync Failed () would pop up on the bottom left, and then disappear after a few seconds. This happened repeatedly.
  • OK, we'll investigate, but from a quick look, if you empty the trash on the desktop — and failing that, the iPad — there's a chance this might go away.
  • Thanks for investigating...

    I emptied both trashes. (Only three items in either one.) And tried to sync again. It still appears to have not gone through.

    Just sitting here with Zotero open on my iPad shows that about every 2 minutes "Sync Failed()" pops up on the bottom left of the screen for about 10/15 seconds and then disappears again.
  • The iPad app just crashed and when I reloaded it a message popped up "Crash Log Sent" the ID number is 1569110928.
  • Can you provide another Debug ID for a sync attempt?
  • Yep. Here ya go. D1997650476
  • @mdsimants we may have a fix for your sync issue. If you want to test it out, you can download a beta build from TestFlight and try to sync with it.

    If you don't want to try the beta version, you'll have to wait until we release another update to AppStore.
  • This issue seemed to resolve for a few days, and over the last 10 or so has resurfaced. Unfortunately, I'm just now finding time to get it logged back with you all.

    I force-synced the iPad App and after a bit received an error reading: "Remote sync in progress. Please try again in a few minutes." I have seen this error a few times in the last

    The Debug ID is: D1192511608

    My Zotero iOS installation is 1.0.7 Build 5 (from Testflight).

    My iOS is 16.2 Public Beta (20C5032e), but it doesn't seem to matter since I just updated to that yesterday and the issue predates that update.

    Thanks for your help.
  • Apologies for the redundant post, but I wasn't sure the latest comment had been seen since it was on a bumped post.

    Nevertheless, the issue persists, and my confidence in not losing data is dwindling.
  • To add a bit to this.... I just added several items into my laptop installation of Zotero. They synced perfectly to the iOS app. It's just things done on the iOS App are not syncing back to the laptop or web application.
  • I am apparently still having the issue where pdfs on my iOS Zotero are not syncing to my Laptop installation.

    I just tried to access a pdf on my Laptop instance that I annotated on my iOS instance a couple of weeks ago. I haven't needed it before now. When I try to access it on the laptop I receive:

    The attached file could not be found at the following path:


    It may have been moved or deleted outside of Zotero, or, if the file was added on another computer, it may not yet have been synced to

    In the WebLibrary the entry shows, yet when I go to the attachments tab, the attachment is listed, but greyed out.

    I force synced on the iOS, and received no error messages.

    Any ideas?
  • @mdsimants sorry for the long wait! Can you please open Settings and go to "Debug Output Logging", tap "Export Database File" and send those files to with mention of this post? If those files are too big (> 10mb) please upload them somewhere (dropbox or google drive for example) and send us the link. Thanks!
  • I have just emails support@zotero with a link to the files on G-Drive.
  • Thanks @mdsimants, you can delete it from GDrive now, since it's taking a lot of your space.
  • @mdsimants can you please check an item called "Calling All Years Good: Christian Vocation throughout Life's Seasons" (key "AN9DTUG2") and item "Introduction: Finding Life’s Purposes in God’s Purposes" (key "3J38M5WA"). You should see that you have identical notes in these items?

    Can you delete one or both of those notes (long press the note -> Move to Trash -> on left side select Trash -> Empty Trash)? Then start debugging, pull down on items list and send me the Debug ID. It should fix your sync issues, but I'd like to confirm and see whether there are other issues.
  • Thanks… I did as instructed… Here’s the Debug ID: D85990446.

    The sync completed. A message at the bottom left indicated as such, but did say (1 Issue). The error reads: "Child Items cannot be assigned to collections." It's repeated three times.

    Thanks for your help!
  • Thanks @mdsimants. You encountered a different issue now. Looks like you tried to duplicate some standalone attachments/notes or items with multiple attachments/notes. This had some bugs, which are now resolved, but it created some issues for you.

    There are 26 "wrong" items in your database due to this bug. I think the simplest thing for you would be to log out and log back in. You'll see your app in the same state as you see it on your desktop app.

    If you want to manually resolve this you'll have to remove these items: "BUIL5R7Q, HAG3CGA7, 7GB4Q2N5, J87HHQTA, WK8WRX9F, H9SUASKK, K3SX78X8, HL75VCBT, GKS37YGT, KPDHQRL2, NW238S4A, F2TC96HW, ANLFJ8RJ, 6DV5XHKJ, RXN8SPMG, RZE2HNSI, 7PKYM2FJ, XWQAVJ4Q, 8T6NZ64E, HZ7TMPIM, I74FJ4KZ, ZJZFU3SX, 8Y92GFCC, 7LHDF6UD, WK4TQWDU, AEGPNVSZ".

    I'm creating a new build in TestFlight which should have all fixes for duplication. So if you want to duplicate more items I'd recommend you update to the latest TestFlight build.
  • edited December 1, 2022
    To be sure I am clear...

    If I sign out and back in, will I lose the items on my iOS installation that have not synced to my MacOS installation? If so, that's a considerable (about two months' worth) amount of lost annotations and such, as I do all my reading/annotating of journal items on my iPad.

    I've searched the item codes you listed on my Mac and don't see them in the various Zotero folders. I'm assuming they only exist on my iPad, and I'm not sure how to find them there to remove them.

    I don't use the duplicate function save for items with a number of the field the same. For example, a chapter in an edited volume. So, I'm not sure what's been duplicated else-wise as it's not part of my workflow.

    Will the new build resolve the issue and save me from losing many hours of work?
  • @mdsimants you don't need to use the duplicate function regularly, if you duplicated something with child items (attachments or notes) it's probably creating these issues now.

    On iOS you can enter the key into search bar on top of items list and it should show you the item there. Let me know if you can find them on your iPad. If you can't resolve this locally yourself I'll figure something out.
  • Thanks.

    I searched each of the item IDs on the Zotero Items list and was only able to locate two of the items. The remainder returned no items when searched.

    I'm not sure how the two that I was able to find were duplicated, as neither were things I would have manually duplicated. In both cases, it would have meant that I added the duplicate pdf to the record manually. My normal workflow is downloading the item as a pdf to a "research docs" folder on my iCloud account. From there, I drag and drop them into the folder in Zotero where I need them stored. Since the iOS app doesn't grab the parent item automatically, I then click "Create Parent Item" and enter the relevant information.

    Here's the list that I cannot seem to locate through the Search Items function:


    As always, your help is much appreciated.
  • @mdsimants the Debug ID that you sent previously doesn't seem to contain the whole sync process. Can you please open the app, check whether the sync is running (just pull down the item list and wait for it to finish), then start debug logging, pull down in item list again and when it finishes stop the logging and send me the ID again. Thanks!
  • I made sure Zotero was closed. Opened it fresh. Appears that 1.0.8(6) had installed from TestFlight.

    Here's the Debug ID: D1231118330 from the sync attempt. The bottom left showed "Finished Sync (1 Issue)." Clicking on that showed the "Child Items" error that I've seen before, but only listed one time as opposed to several like before.

  • @mdsimants and how does your library look like on desktop? Did your documents and annotations sync to desktop this time?
  • Just randomly looked at about 10 items that I've annotated in the last couple of months and 20/25 items that I'd added via my iPad app. Appears that everything is now in tack in both places.

    Thanks for your help!!
Sign In or Register to comment.