APA citation error: adding first initial

When adding an APA citation, some of my references have their first initial included which is not proper APA style.

What I want: (Smith, 2017)
What I'm getting instead: (M. Smith, 2017)

Any suggestions would be appreciated.
  • edited February 11, 2017
    Thank you, dstillman. However, I had already read that information and it does not apply to my question. This is happening with single citations too (I mean 1 paper by 1 author). I did, try to edit the author information (if there were multiple citations by same author) so they would match - with just the same first initial. The in-line citations still showed the authors first initial.
  • If you insert the same item that appears with initial as the only citation in the new document, does it still have initials? If not, it's definitely the issue dstillman links to. If it does, then the problem is how the name is entered in Zotero (it needs to be lastname, firstname in separate fields)
  • Hi Adam, I have tried editing the author information in my library. I have entered last name in the first box, first name/initial in the second box - or double checked to make sure it is right. Problem persists. Thank you for your suggestion!
  • But how about the first part -- does the citation look right if you enter it as the only citation in a new document.
    I wrote large chunks of the APA style implementation and I've used it extensively (as have many others). It definitely works correctly and name entry or disambiguation are the only two reasons you'd see initials in in-text citations.
  • I cannot attach a picture to show you. I'll guess I have to take your word for it that it works.
  • You still haven't answered the first part of my question, which would be the basis of any further troubleshooting -- do you still get the initial in a fresh document with one single citation?
    (You can upload screenshots to any image hosting site (imgur.com, e.g.) and link to them here, though it's not like I don't believe that you're seeing initials, so I'm not sure how much that'd help here)
  • I am seeing similar issues here with APA6. In one document I have the following items in my bibliography:

    * Freeman, C. (1987). Technology policy and economic performance: lessons from Japan. London ; New York: Continuum International Publishing.
    * Freeman, C. (1995). The ‘National System of Innovation’ in historical perspective. Cambridge Journal of Economics, 19(1), 5–24.
    * Freeman, C., & Soete, L. (1997). The economics of industrial innovation. Psychology Press.

    One of the in-text citations reads: (Chris Freeman, 1995). The years are different so I don't see why the given name is necessary.

    If I cite them in a new document I get:
    (Chris Freeman, 1995) (Christopher Freeman, 1987) (Christopher Freeman & Soete, 1997)

    Again, no need for disambiguation as the year is different.

    Also, I don't see how showing 'Christopher' in the text helps you tell which of the 'C. Freeman' instances in the bibliography it corresponds to. The reader doesn't have access to your Zotero database to see what that 'C.' stands for.
  • APA requires disambiguation for all primary authors, not just for the same year, so mostly this is working add intended. Arguably it should add full first names in the bibliography, too, but in your case, it looks like it just the same author added differently to zotero, so you'd just want to clean that up in you database.
  • edited February 26, 2017
    If Chris and Christopher are the same person, you can almost certainly resolve this by editing every Chris Freeman to become Christopher. Zotero cannot know there are the same C. Freeman. The same name should be used (in the most complete form available) each time that author is in your database. [Yes, even if the less-complete name form is printed above some of the author's works.] This is necessary to conform to: APA6 §6.27 and CMoS §14.72 I'm sure that other citation standards have similar requirements but I only know those two from memory. I know because I need to know this when I argue with students, authors, and editors.
  • This may be solved with ORCID at some point, but I don't think I have the right to change the first name of an author in my database for consistency. Authors and publishers chose to register a book with a certain name for their own reasons, and that name is printed all over the book and store in the ISBN database. At some point in their lives authors sometimes change the spelling of their surname too.

    If this form of disambiguation is an APA feature, I can't do very much other than change to another style. In this examples it looks odd, others thought it was a mistake and corrected it, and it doesn't help unless you know that that 'C.' in the bibliography stands for.

    It remains a mystery why in-text citations of the same works look different when I insert them in a new document. Shouldn't the algorithm produce the same citations?
  • edited February 26, 2017
    The disambiguation only occurs when there are multiple cited authors with the same surname. You really should change the formatting of authors' names to be consistent in your database. Chances are that most of the differences (e.g., Chris versus C. versus Christopher) are not author choices but quirks in how databases stored the information (and thus how Zotero imported them); for example, many publishers only send author initials, not full given names, to CrossRef, so imports via DOI have only initials (similar with ISBN). Even printed differences in author given names are often oversights on the author's part or publisher policies, not conscious choices. In any event, if you do want to insist that, for example, Chris versus Christopher spellings for the same author's given name were intentional, then technically correct APA style is to list them spelled out in the in-text citations and references list. Zotero is correctly formatting them according to APA style.
  • Up to you, of course, but authors are frequently listed differently in various places even within the same book (e.g. title and LoC listing if present) as well as on the publisher's website and with the metadata they provide, so I wouldn't be that picky about unifying them across your database.

    My guess for the different displays is that they'd unify once you hit the Refresh button in the add-on. It's quite time consuming to troubleshoot this, so I'm not really going to go there unless there's indication of a relevant bug.
  • I can't know if the name was intentional or not, so I will stick with what is printed in the book. Otherwise, I will start having dilemmas with slight spelling changes in surnames, or quotes with obvious errors. After all, surname + year make this form of disambiguation redundant most of the times anyway, and when it isn't redundant, the reader won't know what the 'C' in the bibliography stands for, so it's pointless. What happened to 2006a, 2006b when disambiguation is required? Anyway, it's an APA convention, so fair enough.

    I created another new document, hit refresh etc. The inconsistent display persists. I can live with it (and edit things in the final version) but I thought I should report it in case it is a bug.
  • most styles that aren't Chicago or APA only use initials for same year _and_ author, so you have a lot of choice. Some never use initials, but those are a bit harder to find
  • Thanks, I will stick with APA for now because I like other aspects. For example, it handles "{:original-date: xxxx}" in Extra well.

  • Not related to the issue, but you can now also write that (optionally) as ...
    original-date: 2017-02-27

    ... which is a little easier on the eye.
  • It doesn't work here, possibly because Zotero Scholar Citations uses the field as well. "{:original-date: xxxx}" works fine though except that the US date format is used and you can't change it. So, '1-4-2000' becomes '4 January 2000', which can lead to mistakes.
  • edited May 21, 2019
    Sorry to resurrect an old thread, but I assume that's preferable to starting a new one on an old issue.

    Anyways, I'm having a very similar problem with Chicago (Author-Date) and I just can't figure out why. When I first noticed it I found this thread and promptly made sure that all the authors I am citing have the same spelling & format for all of their entries in Zotero. That fixed most of them, but I'm still getting one that stubbornly won't change. I have checked and rechecked to make sure the name is the same across citations. I also tried it in a fresh document and it came out properly. However, no amount of tinkering seems to get it to revert in my current document.

    The only thing I can think of is that the author is also an editor on two of my citations. So in total I have one book authored by him, one chapter by him in a volume he also edited, and a few chapters in that volume from other authors. I also wonder if it's getting tripped up because he is both author and editor in one citation? I can't imagine why. Again, I have checked that the entry is set to two fields and the name right across all citations.

    Any help would be appreciated!

    EDIT: I also just tried deleting the bibliography and the specific inline citation, and then redoing the citation. Still a first name initial there...
  • A few options:

    (1) You likely have a duplicate citation to different versions of the item, likely one of them is disconnected from your library and has outdated data. Is there a duplicate item in the bibliography list?

    (2) The name is entered in First Last mode in Zotero instead of Last, First mode.
  • I have the same problem with the initials or first name of some authors listed in in-line citations when using APA format. I currently use Google Docs.

    It is a real pain, I have tried the above. What I note is that deleting the citation and re-entering it in the document at first shows it correctly (i.e., without initial), but when I "refresh" the document (through the Zotero menu option "Refresh"), the initials are included again (only for certain citations).

    I look at my library, but the papers are definitely correctly entered. This seems to me a bug in Zotero.

    My only solution is to manually fix that before finishing off the paper. Very frustrating.
  • We're almost 100% certain this is not a bug -- every single case we looked into more closely was either due to incorrectly/inconsistently entered data or to APA style working as it was supposed to.

    How exactly do those citations appear in the text? How in the bibliography?
  • This would not be a bug in Zotero. There are a few options.

    If the items are by different authors (e.g., J. Smith and O. Smith):
    1. Adding initials in this case is correct APA style. This rule is often something authors don’t realize. You should leave these initials in place.

    If these are the same author (e.g., J Smith), then:
    2. You have author names entered inconsistently across items in Zotero (e.g., James Smith vs J Smith), so Zotero is treating these as different authors and disambiguating per APA’s rule.
    3. You have the name for one of the items entered incorrectly in your Zotero library data (e.g., you have “J. Smith” in the Last Name field).

    For either of those, check the items in Zotero that have the initials being added and correct. To select the items in your library, place your cursor in the citation in your document, click the Add/Edit Citation button, click the blue bubble for the item, then click the Show in My Library button.

    Another possibility:
    4. You have a citation that is disconnected from your library, such as if you deleted a duplicate item rather than merging the duplicates. Then that orphaned item might have incorrect data even if the items left in your library don’t. You will be able to see this when you try to click the blue bubble in the Add/Edit Citation window and there is no “View in My Library” button. In that case, delete the citation and re-insert from your library.
  • Thanks Bwiernik,
    You solved the problem for me.
    Turns out I had two papers by the same author, but one included their middle name and the other didn't. Something like: J. Smith and J. W. Smith
  • Hello, resurrecting this thread in case there are other possible solutions. although, right now, i've manually removed the initials inside the parentheses.

    Context. I have two authors with last name LEE. One article is sole author by Se Woong LEE. Other article is multiple authors with first author as Hwee Hoon LEE. different years too. Both Lees are cited in-text with their initials: (S.W. Lee, 2018) and (H.H. Lee et al., 2015).

    I tried out all the suggestions here from previous years. New document with nothing in it will show initials. Deleted and reencoded their names in Zotero to ensure last name & first name are in correct boxes.

    I'm wondering where the bug is. and if it is a bug. because in the entire paper, it's only with this LEE authors that's showing initials. I have other authors with multiple years but none of them show initials.
  • This isn't a bug. What you are seeing is correct APA style
  • (S.W. Lee, 2018) and (H.H. Lee et al., 2015) is correct APA style for these two authors. You should leave it as shown
  • edited October 15, 2022
    I just stumbled into this bug too. It took me ages to fix it in my document because everything appeared right, I even checked the field code contents of all offending citations to see if citations were using the same citationID (they were)!

    The reason this thread is still active is because the issue is impossible to fix even after correcting the zotero database. The only way to solve this is to remove the offending citation from your document and re-adding it. Figuring out the one that caused the offence is a challenge.

    Here are the steps to reproduce this bug:
    1. Prepare two zotero entries:
    A: An entry with an author named Bar, Foo
    B: Another citation with an author named Bar, Foo F

    2. In a new docx document, cite A.
    3. Cite B. Refresh from the word Zotero tab. Notice the changes in citation (as it should). You will see a F. Bar and a F. F. Bar citation.
    4. In Zotero, rename the author in Item B to Bar, Foo by changing its first name.
    5. Refresh Word. Both citations will now read (F. Bar) instead of just (Bar)

    This is the bug!
    Now, to fix it:

    6. Removing B and readding it will not work. You need to remove B
    7. Refresh the document from the Zotero tab.
    8. Re-add B in your document. Now, both citations will read (Bar), like they should!

    Or, restart Zotero as dstillman pointed out!

    I am running Zotero 6.0.16-beta.3+29dd0cf5d
  • edited October 15, 2022
    I am not sure where to look in the code to get this bug fixed!
  • That does appear to be a bug. We'll fix. Thanks for the clear report.

    Note, though, that the fix is just to restart Zotero — you don't need to change anything in the document.
Sign In or Register to comment.