Cannot convert document to a different citation style

I have a Word document in which the citations are footnotes. The journal I'm submitting to requires me to use in-line citations in the (author, date) format, with a full list of references at the end of the document.

This should be a simple matter of clicking 'document preferences' and switching to a citation style which uses the (author, date) format. However, when I try selecting a different citation style, nothing happens in the document (the citations do not change). There is no error message from Zotero, it's just that nothing changes.

This is a similar problem to the one posted here:

Zotero version: 6.0.11
Word for Mac version: 16.63.1

I have tried:
1. The troubleshooting steps in this article
2. Downloading earlier draft versions of the document from Google Docs (I began writing in Docs and switched to Word only for the final edits) as Word .docx documents and attempting to change the citation style.
3. Uploading the Word document to Google Docs and trying to update it in Google Docs (this gives me an error message saying the document cannot be updated, and a link to the troubleshooting article above).

I *am* able to change the citation style in the earlier drafts which are in Google Docs. Unfortunately this is not useful to me since significant edits and changes were made after I switched to Word.

Given that the feature works in Google Docs but not Word (for the same document), I suspect the problem lies with the Word plugin.

I'd be grateful for any help.
  • How many citations are in the document, and how long have you waited? Mac Word integration is unfortunately quite slow, so if it's a large document, it might just take a while.

    You can see if anything is happening by going to Help → Debug Output Logging → View Output.

    If it's getting stuck, we'd want to see a Debug ID for trying this after restarting Zotero and Word.
  • 1. The troubleshooting steps in this article
    Also, you don't say exactly what you did here, but the last step on that page by definition would identify the issue, unless you can cut the document down to a single citation and still reproduce the problem.
  • Hello,

    Thanks for responding.

    There are 120 citations in the document, and I have waited varying lengths of time, but I should mention that there is nothing happening on the screen to indicate Zotero is doing anything. Normally I would see the red citation input bar appear flash up on the screen until the operation is complete, for example. Instead, the Zotero window is briefly brought into the foreground before disappearing again after less than a second, and nothing else changes.

    On the debugging steps: I have tried halving the document and halving again as it suggests, I have also tried isolating random paragraphs of text (with 1-3 citations in each) and found the same issue. I could not find a part of the text in which switching citations styles *does* work.

    The debugging output ID is D590697385.

  • (3)(+0000023): Integration: MacWord16-setDocPrefs:'/Applications/Microsoft' complete in 5.98s
    The operation is succeeding immediately. There are just no citations in the document. Most likely the citations in the document were just flattened.

    You say that you started this document in Google Docs. Are you actually following the transfer steps?
Sign In or Register to comment.