MS Word freezes when using Zotero plug-in


Since a number of weeks now, when I try to include a citation or a bibliographical note in my MS Word, using the Zotero plug-in, all freezes and I have to force closure of both programs.
I am on MacOS Monterey.

FYI I tried different things :

- uninstalled and reinstalled Zotero
- uninstalled and reinstalled the MS Word plugin
- registered on Zotero with another username and created a new account
None of those measures solved the problem.

What is strange, is that Zotero had worked well for weeks, and suddenly has bugged.
Here is the last report ID : 1018822051 (Zotero messaged that all seems normal).

Zotero program works well by itself. It is the use of the plugin which doesn't seem to work anymore.

One possible problem is that I use the special style sheet of the school where I teach.
Choosing among other provided style sheets sometimes works and sometimes not - depending the style chosen.

I also have Zotero installed on two other computers (Windows 10 OS) : it bugs on one and not on the other one...

Thanks in advance for your answers.
  • What exact Word version?

    I'm guessing this only happens for footnote styles?
  • edited August 4, 2022
    Basically, you're seeing a Word bug that was supposed to be fixed in 16.63, though we just had another report of it happening with 16.63.1.

    Assuming you're running 16.31.1, see that second thread — you can run that same script in Script Editor to confirm that it's failing, and then you can try the same things I suggest there. This is entirely a Word bug that's out of our control, but in our own testing and others' it's fixed in 16.63 and 16.31.1, so fiddling with Word reinstallation should in theory fix it.
  • Thanks for the answer.

    My Word version is indeed 16.63.1 (22071301).

    I tried to do the Scip Editor process you wrote about, but it bugged.

    As I am at work and my MS Word is installed by my employer, I won't try to uninstall/reinstall it without the support of the IT colleague.

    Best regards
  • Hi,

    My MS word updated to 16.64 and Zotero works again on it.

    Best regards
Sign In or Register to comment.