Zotero hangs when trying to add a footnote citation in Word for Mac

edited June 30, 2022
Report ID: 1417463234

When I try to use Zotero in Word for a Mac to add a citation with the Chicago 17th (note), (full note), (full note, short title) style, Zotero and Word freeze. Force quitting does not solve the problem. The issue occurs whether the Automatically update citations box is checked or not checked. The issue occurs whether trying to insert a citation or note in a new Word document or a document with other citations. Attempting to edit a citation results in the same wheel of death. The only way the issue does not occur is by using the Chicago 17th (author-date) style.

Steps taken to reproduce:
1. Open Zotero and new Word document
2. Choose the citation style in Word (Chicago, 17th edition (full note, short title subsequent) ---> **(full note) and (note) also produce the same wheel of death
3. Press Add/Edit Citation
4. Force quit Zotero and Word

Steps taken to fix:
1. Open Zotero and new Word document
2. Choose the citation style in Word (Chicago, 17th edition (author-date)
3. Press Add/Edit Citation
4. Add citation correctly

I have uninstalled Zotero and reinstalled it and restarted my computer, but the issue continues. Do I need to uninstall/reinstall Word? Both Zotero and Word are running the most up-to-date versions. Any help is appreciated.
  • I am also experiencing this problem with Zotero on a MacBook Pro running macOS Monterey (version 12.3.1) with an Intel 2.9Gz Quad-Core Intel Core i7 processor, and Microsoft Word version 16.62. When trying to add a citation from the Zotero button in MS Word, it hangs, and I eventually have to force quit word. I then et an error in Zotero stating "Zotero Integration Error - Zotero experienced an error updating your document."

    I have also tried all the options explained by epietsch554 (Report ID: 1417463234).
  • @epietsch554 Are you also running Word 16.62? That is the Insider Beta version of Word for Mac and may just have a bug in it at the moment. You would have to report that to Microsoft.
  • MS Word and Zotero both hang, when I try to insert a citation. I am running Zotero 6.0.8, and MS Word for Mac 16.63. I tried reinstalling, restarting. Not working. what do I do?
  • Same as above - you will have to switch to the stable version of Word
  • To everyone experiencing this, we have confirmed it's a bug in the preview version of Word and have submitted feedback to Microsoft. If you also encounter this issue, please report it to Microsoft so they notice and fix it, since it's possible they are not aware of the issue at all. In Word go to Help -> Feedback, say that you don't like something and describe the issue. You can include a link to my forum post in the feedback form which includes steps to reproduce:

  • edited July 7, 2022
    Unfortunately Microsoft appears to have released Word 16.62 without fixing this bug, so this will now affect anybody running the release version of Word and using a footnote style.

    For now, you have two options:

    1) Work in an author-date style for now, and plan to switch to a footnote style later (after this is fixed in Word, after installing an older version, or on a Windows computer).

    2) Reinstall Word 16.61 by deleting Microsoft Word from Applications, clicking the "Word" link under "Update Packages" on the 16.61 line on this page, and running the downloaded update package. This is trivial to do, so if you want to work using footnotes now, this is the best option. You'll just need to avoid updating Word until this is fixed.

    This is 100% a Word bug, reproducible entirely without Zotero, so there's just nothing we can do to fix this.
  • I had the same issue and reverted to 16.61. Thank you for the tip here. I hope Zotero could inform/request Microsoft to patch up Word as soon as possible.
  • We're in touch with them, yes.
  • This is now fixed in the latest Word beta (16.64.22070100). Hopefully they'll release it to the preview channel and the main release channel soon.
  • This is now fixed in Word 16.63, the current release version.
  • Unfortunately error continues on 16.63. Don't know what you did, but I'm still facing it 16.63 update installed yesterday.
  • I'm using 16.63 and still experiencing this issue.
  • (update: I changed to the beta track and 16.64 fixes it, but at least for me 16.63 still had this error)
  • edited July 13, 2022
    @davidohne: What exact version of 16.63, and what channel are you on (if you click Advanced in Microsoft AutoUpdate)?

    Microsoft's versioning scheme is confusing, but it's working for me and others with 16.63 (22070801), which is the current release version. If you're on "Current Channel (Preview)", you'll (counterintuitively) have an older 16.63 (22070500) from before this fix. If that's the case, you can delete Microsoft Word from Applications and reinstall 16.63 (22070801) from the Word install package on the release page linked above.
  • It's really confusing. I'm in the "actual channel (preview) channel. It said that Word is up to date (16.63, updated date July, 12).

    Had to revert to 16.61, now it's working again.
  • edited July 13, 2022
    That's not the full version, though — the update date shown there is just when you updated, but if you're on "Current Channel (Preview)" you'd have 16.63 (22070500) from July 5, not 16.63 (22070801) from July 12. (No idea why Microsoft hasn't put out a "Current Channel (Preview)" with this fix — obviously a preview build should always have fixes that are in the release build.)

    If you change it to "Current Channel" and update from anything before 16.63, or if you reinstall 16.63 manually from the page linked above, you'll get 16.63 (22070801) and it will work.
Sign In or Register to comment.