Zotero Zitierstil ändern im fertigen Dokument

Hallo,
wie kann ich in der fertigen Word Datei den Zitierstil noch mal ändern, wenn man Dr. Vater einen anderen haben möchte?

Verzweifelte Grüße
Michaela
  • Tut mir leid, ich habe diese Seiten alle zig mal durchgelesen.
    Da wird beschrieben wie ich es bei einem neuen Dokument machen muss.
    Aber ich hab eine Arbeit die hat 90 Seiten zig Zitate und die Literaturliste unten. Und nun muss es eine andere Optik sein.
    WAs kann ich tun??? Die ganzen 90 Seiten irgendwie markieren?
    Wie kann ich den Zitationsstil ändern?
  • Hmm -- da steht ganz open, neben dem Symbol fuer "Document Preferences"
    "Open the Document Preferences window, e.g. to change the citation style. "

    Also einfach den Knopf mit dem entsprechenden Symbol klicken und neuen Zitierstil auswaehlen. Wenn das nicht klappt muesstest Du etwas genauer beschreiben warum nicht.
  • Ahhhh ich glaube es klappt jetzt. Moment... er sagt es dauert lange und ich muss danach noch irgendwie das Werkzeug und Syn klicken....
  • Also es hat geklappt und meine Word Datei ist geändert. Aber dieser Befehl der auftauchte, ich müsse danach noch in Zotero bei Werkzeug auf Synchronisieren gehen das ging dann wieder nicht.
    Aber egal. Ich speichere jetzt schnell das Dokument und die Änderungen kann ich manuell akzeptieren.
  • Hallo Zusammen,

    ich habe ungefähr das gleiche Problem. Ich bin noch nicht komplett fertig mit der Dr.Arbeit, aber ich muss den Zitierstil ändern, der der ca. passen würde ist der Stil "Springer", bisher waren meine Quellen mit Fußnote immer am Seitenende der jeweiligen Seite.
    Es muss aber ein fortlaufendes nummeriertes Literaturverzeichnis am Ende des Dokuments sein und es darf kein "et. all" in der jeweiligen Quelle verwendet werden.

    Wenn ich das Dokument in Word geöffnet habe und nun über Document Preferences versuche diesen zu ändern, formatiert Zotero in Word auch, allerdings ist dann auf fast jeder Seite wo vorher am Ende der Seite die Quelle stand, nur Wirrwarr wie " mnmbnmnjgfnhmnmmn0000000"...

    Könnte mir da jemand weiterhelfen, ich weiss nicht mehr weiter?!

    Vielen Dank schonmal.

    Beste Grüße
  • Könnten wir einen screenshot sehen? Irgendwo (imgur.com, dropbox, google, owncloud) hochladen und link hier posten
  • Hi, ich habe eine ähnliche Frage..
    Ich habe zwar den Zitiertstil eingestellt, aber wenn ich mehrer Autoren zitiere soll et al. kommen und nicht u.a. ...
    Weiß jemand wie ich das ändern kann? Wenn ich auf Zitier-Editor gehe weiß ich leider nicht wo ich da was umstellen muss :/

    Beste Grüße und vielen Dank schonmal
  • Nein, du hast ein komplett anderes Problem. Bitte neue Threads aufmachen, wenn du nicht genau das gleiche Problem hast.

    Das musst du nach der Info Sektion einfügen:
    <locale xml:lang="de">
    <terms>
    <term name="et-al">et al.</term>
    </terms>
    </locale>


    Wenn bereits eine Locale Sektion für deutsch (de) besteht, dann einfach nur die term name.... Zeile reinkopieren.

    https://www.zotero.org/support/dev/citation_styles/style_editing_step-by-step
  • edited May 24, 2022
    Ah ok. Ja ich habe schon eine Locale Sektion glaube ich.
    Muss ich das überall bei term name ändern? Wenn ich den Term kopiere wird er leider nicht richtig eingesetzt... Ich habe en Stil Gesellschaft für Bildung und Forschung in Europa - Harvard (Deutsch).

    Vielen Dank im Voraus!
  • Bei dem Stil kannst du dann einfach <term name="et-al">et al.</term> vor den ersten Term packen. Also Zeile 27.

  • edited June 7, 2022
    Super, das hat geklappt.
    Kannst du mir auch noch sagen, wie ich ein Leerzeichen hinter den Doppelpunkt und vor die Seitenzahl bekomme? Wenn ich eine Seitenzahl von bis eingebe kommt zwischen den Zahlen immer ein Gedankenstrich anstatt ein einfacher Bindestrich. Wissen Sie wie ich das ändern kann?
    Und bei zwei Autoren verwende ich ja noch nicht et al.. Aktuell steht da ein &-Zeichen zwischen den zwei Autoren. Wie könnte ich diese mit einem / trennen?

    Danke im Voraus!!!
  • Das kommt etwas auf den Stil drauf an, den du benutzt. Aber recht weit unten im Code, in dem Teil, der mit <citation... anfängt kannst du das ändern.
  • edited June 8, 2022
    Ich benutze den Stil Gesellschaft für Bildung und Forschung in Europa unter der kleinen Änderung, bei der du mir netterweise bereits ausgeholfen hast (ich habe ihn unten rein kopiert).
    Könntest du mir ggf. wieder sagen, in welcher Zeile ich was anpassen soll, damit ich die folgenden Änderungen umgesetzt bekomme:
    1. Zwei Autoren mit einem "/" statt "&"-Zeichen trennen
    2. Leerzeichen vor der Seitenzahl
    3. Bindestrich anstatt Gedankenstrich

    Vielen Dank!!!

  • Deinen Code musst du per pastebin.com mit uns teilen.
  • Ok, hab den folgenden paste kreiert: https://pastebin.com/mhuhJY87
  • - Dem Stil musst du einen anderen Namen geben und auch ID und self link abändern.
    - Generell mehr mit Gruppendelimitern machen, als pre/suffix verwenden.

    <macro name="author-short">
    <names variable="author">
    <name form="short" delimiter="/" delimiter-precedes-last="never" initialize-with=". "/>
    <substitute>
    <names variable="editor"/>
    <names variable="translator"/>
    <text macro="anon"/>
    </substitute>
    </names>
    </macro>


    und
    <citation et-al-min="3" et-al-use-first="1" disambiguate-add-year-suffix="true" disambiguate-add-names="true" disambiguate-add-givenname="true">
    <layout prefix="(" suffix=")" delimiter="; ">
    <group delimiter=", ">
    <group delimiter=" ">
    <text macro="author-short"/>
    <text macro="year-date"/>
    </group>
    <text variable="locator"/>
    </group>
    </layout>
    </citation>


    (bitte keinen Text (siehe die ersten Zeilen) in den Code reinmachen, oder zumindest auskommentieren. ;) )
  • edited June 8, 2022
    Ok, danke!
    Irgendwie kann ich den Stil nicht abspeichern? Bzw. er lässt sich nicht in die Liste hochladen...
    ich bekomme die folgende Fehlermeldung
    "C:\Users\ajessat\OneDrive - XXX\Desktop\Annika_Zitationsstil.csl" is not a valid CSL 1.0.2 style file, and may not work properly with Zotero.

    Are you sure you want to continue?

    Ich habe es schon in verschiedenen Ordnern versucht abzulegen
  • edited June 8, 2022
    Damit überprüfen: https://validator.citationstyles.org/

    Das hat nichts mit dem Ordner zu tun und lässt sich von überall installieren.
    Irgendwas hast du halt entweder falsch reinkopiert oder verändert. ;)
  • Dankeschön!
    Ich habe jetzt nur noch das Problem, dass wenn ich eine Seitenrange angebe, dass dazwischen eine Gedankenstrich statt ein Bindestrich ist. Können Sie mir sagen wie ich das ändern kann?
  • Ohne den Stil zu sehen ist es schwer konkret zu helfen.
  • Es geht um den Stil, den ich bei pastebin eingefügt habe :)
    https://pastebin.com/mhuhJY87
  • Zeile 169 das Präfix umändern.
  • Ok, also den Dopplepunkt möchte ich ja behalten, nur zwischen den Seitenzahlen das Zeichen ändern. Aktuell steht bei mir in Zeile 169 nur ein Doppelpunkt, muss ich dann noch "page-page" ergänzen?
    Vielen Dank im Voraus!
  • Der Halbgeviertssstrich ist da aber wirklich typographisch angebracht, ich würde den lassen.
    Ansonsten müsstest Du den page-range-delimiter in den terms neu definieren. American Medical Association macht das z.B., könnte also als Vorlage dienen
  • edited 23 days ago
    Moin,
    ich habe quasi das gleiche Problem wie Michaela. Ich habe bereits am Anfang meiner Masterabeit den Zitierstil ändern können (von Fußnoten auf innerhalb des Textes). Nun wollte ich den Zitierstil bei der fast fertigen Arbeit wieder ändern über "Document Preferences", aber es funktioniert nicht. Ehrlicherweise weiß ich nicht mehr, wie ich das letztes Jahr gemacht habe. Ich wähle den neuen Stil an, kann ihn aber nirgends bestätigen.
    Zur Info, ich arbeite mit einem MacOS High Sierra Version 10.13.6 und dem Word Version 16 (Ja, der Rechner ist alt, funktioniert aber bisher gut).
    Ich weiß nicht, ob es daran liegen könnte, dass ich keine neuen Updates mehr für Word ziehen kann?! Habt ihr sonst noch eine Idee, was ich machen könnte?
    Hatte schon überlegt die Zurücksetzen-Funktion zu nutzen, traue mich aber ehrlicherweise nicht...

    Wäre für Hilfe echt dankbar, Merci
  • Sieht wohl danach aus: https://www.zotero.org/support/kb/existing_citations_not_detected

    Probier Mal ein neues Dokument aus zum Testen. Damit kannst du ausschließen, dass es an der Word Version liegt (unwahrscheinlich).
  • Hey, Danke für deine Hilfestellung.
    Konnte das Problem tatsächlich durch komplettes Runterfahren des Laptops (NICHT Neustart - das hat nicht gereicht) beheben. Danach war auch der "Bestätigen"- Button wieder da.
This discussion has been closed.