Citation - Chicago Manual of Style

I am in the midst of writing a project for my doctorate and am finding Zotero a joy to use.
I am using Chicago Manual of Style (Full Note with Bibliography) and am finding Zotero is leaving out the final period. When I go back and edit, and then click OK, it puts in the final period.
Am I doing something wrong?

Thanks for your help.

  • edited January 13, 2008
    Ticket created, thanks!
  • When will this be corrected?
  • For what it's worth, this doesn't happen if you're inserting multiple sources - the bug seems only to be with a single source. (A work-around would be to insert a "." in the "suffix" field).

    But I also would like to see this one fixed :-)

    Thank you!
  • category in ticket is "word integration." FYI, its a problem in as well.
  • I have Zotero version 1.0.6 and the same error that originated this topic is still occurring. When I look at the ticket created back in January, I believe it said that this current version of Zotero should take care of this.
    Any idea when the error will be corrected?
  • Dear All,

    This is NOT an error, please do not correct it. Below is why:

    I think Zotero is NOT supposed to put in that final period. If you want to add text after the citation and use a comma, then the period would get in the way. So, putting the period in on your own let's you add your own punctuation, which is absolutely key to footnotes that go beyond merely citing a page number.

    I used Endnote for a while and I had to manipulate the styles in order to NOT put in a period, one of the great things about Zotero is that the end punctuation of a footnote is NOT decided for you.

    I would find Zotero much less useful if I had to have a period at the end of a citation. What if you want to add more text? Example: "Carlson, _Dynamics of Hamlet_, p. 45 argues that . . . " if there was a period after "45" you couldn't continue your note! The above is just one example, but there many situations where you don't want a period, but a comma, or a semi-colon, or nothing at all.

    So, I think it is best that it remain the way it is.

    Dan Michon
  • Doing a refresh of your citations usually resolves missing periods. If you want a Chicago style note that is open ended, you should make a footnote and then press the citation button--the developers had the foresight to differentiate between straight-up citations and discursive footnotes that also contain a citation.
  • Dan,

    I see your point, and I had never thought about this in the way you describe. I rarely add comments after the citation.

  • Interesting. When I want to add text to a zotero cite, I use the prefix/suffix fields. So to create a citation like:
    See Robert W Winter, “The Arts and Crafts as a Social Movement,” Record of the Art Museum, Princeton University 34, no. 2, Aspects of the Arts and Crafts Movement in America (1975): 36-40, especially page 36, for a detailed description of the decline of the movement.
    I enter "See" in the prefix field, and the rest of the text in the suffix field.

    Thank you for pointing out that a simple Zotero refresh would add the missing periods - I hadn't noticed that, but am very very happy that it's so easy to take care of that problem.
  • Marisa--the other advantage of adding the "especially see p. 36 for..." to the footnote text (rather than as a suffix) is that long suffixes can slow things down or cause errors. A simple "See" prefix probably is okay, but adding too much text to these fields, in my experience can cause problems. To do this, as I said, you create an actual footnote in the word processor, and then press the citation button to call Zotero (rather than using the citation button to create the footnote).
  • Dear All,

    Samuelas gives a great solution that I didn't think of. Using Word footnote then just using citation for discursive footnotes. I have been inserting a footnote with Zotero, but I guess I should start using Word to insert then put in a citation because if the next version of Zotero does put in periods, I will have to go back and do that all over again.

    I would be interested to know what the Zotero developers are planning to do -- if they are going to put the period in, then I need to stop inserting from the Zotero toolbar asap and start inserting Word footnote.

    Anyone know what they are planning to do?

  • edited June 24, 2008
    One thing to keep in mind is that one goal of CSL—one which Zotero has followed—is that one can switch between note and other styles without modifying your document. So as you add your citations and associated text, think to yourself: what would happen if I switched to an author-date style?

    For that reason, I'd say I'd tend to prefer marisabrandt's approach of using prefix and suffix for short comments. For longer one, I'd create the footnote, and embed the citation(s) within it.

    I also think that Zotero should add a period to the first case; what I call "footnoted citations" (as opposed to just citations in footnotes).
  • @dmichon, does refreshing your document as samuelas suggested bring back the periods?
  • Hey you all,

    I see that this thread is a year old and misses a proper ending. What have the developer decided? Is it going to be left the way it is? I started using Zotero just a few month ago and have experienced the same problem.

    I think, if the refresh function does add periods to the end, it should add those periods right away. Else it could mess up your citations if you hit the refresh button at the end (e.g. to correct some minor mistakes in the titles).

    From all I have read in this discussion, however, I would argue that periods at the end should be left away alltogether. Still, then it should also not ADD periods after hitting refresh.

    Finally, thank so much to all Zotero developers! You have made my academic life so much easier! I love you guys!

    Take care,
  • I was surprised that this still had not been fixed in the most recent iteration of Zotero. I'd like to see the period added when the citation is first created, instead of after editing the citation. I find that I need the period at the end of nearly all citations and only rarely do not.
    And thanks for Zotero. The best citation management program I have ever used.

  • I can't agree with dmichan, if only because any comment added after a citation would itself require a period to close it. Isn't the point of the "show editor" button that people can format a footnote in any weird way they like? So why inconvenience the vast majority of users on every citation they make? A final period is proper in every citation style I know, as it is in every grammatically correct sentence. This should be fixed.

    As of 7/24/09, the ticket for this known issue says it's closed and that it can't be reproduced, but it happens to me every time I add a citation. I'm using the latest plugin on Word 2002 for Windows XP. I don't know how to reopen a ticket.

    Thank you!
  • this is weird. Zotero does put the periods in there for me - and apparently most other people - which Zotero are you using? Can you give some examples?
    What happens if you refresh your document? Is this true for multiple citations as well?
    I don't think there can be any question that the period belongs there - the solutions suggested above sound more like hacks than solutions.
    Tickets can only be re-opened by people with trac access (i.e. people who are part of the dev team broadly speaking).
  • edited September 16, 2009
    Simon (or someone else who tries it out) will need to provide details of the change, but this is addressed in the new Windows plugin that accompanies 2.0b7. (I don't think it was an issue any longer in the other plugins.)
  • I've been writing my dissertation in Word 2007 with Zotero all year. The periods have not been added automatically after after citation.

    Last night I updated to 2.0b7 and 3.0a1. Zotero refreshed all the past notations and added a period after every one! This means that there are hundreds (perhaps thousands) of periods that now must be deleted manually. The extraneous periods occur before other periods, commas, and semi-colons.

    Is this a bug that can be fixed, or do I have to go back and manually delete hundreds of periods via the editor?

    I would strongly prefer that Zotero NOT automatically add periods after citations.
  • why manually delete?
    this seems like something that search and replace can take care of in 5mins.

    And the behavior that does add periods is in line with standard Zotero behavior and should have been there all along. The crucial argument here is switching between different styles.
  • Periods should not be inserted in the footnotes. Using Word footnotes and Zotero combined is not a serious solution because it's two unassociated databases. Using suffix and prefix is not a viable solution. Yes, you must manually delete every period.

    Bottom line: the periods need to come out unless Zotero offers the option to suppress it without orphaning the citation from the database.

    The main point here is that the period is *inside the footnote field*!

    For one thing it can only be deleted by opening the editor inside the edit citation window otherwise the period will revert during a refresh. So I'm afraid yes, adamsmith, manually edit in every case and it's not even as simple as just deleting the period! Poor anaselli--I hope it's a short document.

    However, albeit a big problem, it's only a one time problem. So if it were the right thing to do, then of course Zotero should still insert the periods. But it's not the right thing to do!

    The far more important problem is that once you edit the footnote you orphan it from the database. But what if there is an error in the database that you go back and correct? Then all of the footnotes are updated during a refresh except the orphaned footnote. Uhhh, where was that footnote again?

    It cannot be acceptable that Zotero force a citation to be orphaned from the database in the normal course of writing! It defeats the whole purpose of having bibliographic software and makes EndNote look like a great deal.

    marisabrandt's is not a viable solution. In the books I read and in the papers I write I often find footnotes with multiple cited sources that may, for example, be listed with commas separating the sources--no periods following. Every one of these creates an orphaned citation.

    By the way, this is the same problem that results from the fact that Zotero does not recognize the beginning of a new chapter (where some styles require a repeat of the full reference to the source information). The only workaround for that bug is also to insert a citation which is no longer associated with same source data (either manually or via a new Zotero entry).
  • edited November 12, 2013
    No need to get so intense.

    If it's important to you, just modify the style
    all you have to do is to
    <layout prefix="" suffix="." delimiter="; ">

    <layout prefix="" suffix="" delimiter="; ">

    - less work than writing your post.

    btw. that should also take care of anaselli's problem, hadn't thought of that before.
    Let me know if you have problems with that modification.

    As the standard style, however, I continue to maintain that the period should be in there. If I insert a simple citation using Zotero it should be correct without me going into the footnote and modifying it. Without the period it's not.
    Also, if I want to switch from Chicago style to e.g. APSA style I should be able to do that with one click (well, OK, it's three clicks, but you get the point) - one of the important stated goals of csl - with the period added manually that is not the case.
  • The above link by adamsmith is no longer working, and I personally don't know how to edit a CSL file. Could you please let us know how to do it, and where these files are located? I am on a Mac. By trying to upload ChicagoMS from the repository I just get asked whether I want to replace the existing style sheet.

    Thank you.
  • Is there any reason the above CSL change (i.e., suffix="") shouldn't work for MLZ? I made the change in the CSL, but it's not working.
  • should work in MLZ - what item type? Are you sure you're working on the right suffix? There is one for the bibliography and one for the citation.
  • edited February 18, 2013
    I wanted the change to take effect across the board, so I emptied the "suffix" field in both Inline Citations-Layout and Bibliography-Layout. But Zotero word-plugin still adds periods at the end of footnote citations.

    Edit: My bad.. It works now. Thanks.
Sign In or Register to comment.