Annotations not found after Mendeley import

This discussion was created from comments split from: Available for beta testing: Online Mendeley importer.
  • I'm on the latest beta build and have the PDF viewer enabled, but import of my Mendeley library does not show any annotations. Any tips for what I can do to fix it?
  • edited January 21, 2022
    How did you import your Mendeley library?

    Do you see the annotations if you view the PDFs in your Mendeley library online?
  • File -> Import -> Mendeley Reference Manager (online import) in the Zotero desktop app.

    I see the annotations when I view the PDFs in my Mendeley library online. I see my notes in Zotero, but no highlighting appears. I have the PDF viewer enabled in my settings.

    I'm on an 2021 M1 MacBook (Monterey), for what it's worth.
  • I see my notes in Zotero, but no highlighting appears.
    What kind of notes? Child notes beneath Zotero items, or note annotations on the PDF page?

    Can you provide a Debug ID for a Mendeley import? (Don't delete anything. You can make a backup of your Zotero data directory first for good measure, but a repeated import should just ignore existing data.)
  • Thanks for the quick response! ID: D1284396978

    Good question, sorry, I didn't know the difference. Note annotations on the PDF page.

    Actually, it looks like my highlights appear on some other PDFs! It was just the one I was looking at in particular didn't import. If the majority worked, I can live with that
  • It does look like there are a few (~10) failures in there. We'll see if we can figure out why.
  • @lllaur: This should be fixed in the latest beta, available now via Help → Check for Updates.
  • I have a similar problem after importing my Mendeley database: on several papers, the highlights in the pdfs are missing
  • @chharig: If you're sure you're running the latest beta, we'd want to see a Debug ID for an import attempt that doesn't import them.
  • It's D1262825030
  • That just shows an ongoing sync — it doesn't show a Mendeley import. Restart Zotero, make sure you're fully in sync, and then provide a Debug ID specifically for a Mendeley import. It may help to temporarily disable auto-sync from the Sync pane of the preferences (but don't forget to turn it on again after).
  • Have tried to provide a Debug ID several times now - the Debug ID pop-up never works, every time I try to to create Output, Zotero crashes. Have deleted and re-installed the programme, never works. Would you suggest to wait for the next update and try to install it again then?
  • every time I try to to create Output, Zotero crashes
    Submit Output, you mean? What do you mean by "Zotero crashes"?
  • When I try to submit output, the Debug-ID doesn't pop up. When I try the alternative way of returning to the Debug Output Logging menu and selecting View Output, the Windows "Not responding" error occurs
  • How long have you waited for the Debug ID to show up? It could take a little while if this is a large library and/or a slow internet connection.
  • 5 mins or so
  • You can try going to the Config Editor in the Advanced pane of the preferences and lowering to 8000000 or 5000000.
  • Okay, will try again with these settings
  • Didn't work - waited one hour in vain for the Debug ID to show up. Same story again with the "View Output" and the Windows "not responding" error
  • You should reduce it until it submits. You don't need to regenerate — the setting is just for submitting it.
Sign In or Register to comment.