"Zotero experienced an error updating your document."

edited December 12, 2021
I am used to every once in a while receiving the infamous message "Zotero experienced an error updating your document." while calling up a Zotero window from Word. My Word plugin was otherwise working well, and my workaround so far was restarting Word, Zotero and Chrome (only the first two wasn't enough). However, lately this error appears often enough (soon after I've opened a doc and attempted the first Zotero operation) that it interferes with workflow.

This possibly relates to my recent upgrade of MS Office, from v2019 to v2021.

I don't yet know if the error is triggered only by one document (the one I'm working on nowadays) or by any doc, but once it appears the first time there, creating a new blank doc and trying to insert a Z citation will be met with the same error.

I have tried all suggestions in the troubleshooter (https://www.zotero.org/support/kb/debugging_broken_documents). I would add that my doc has no unaccepted tracked changes, only comments.

Unlike others reporting this error (https://forums.zotero.org/discussion/91440), in my case it's not from a non-English OS language.

Thanks in advance for any assistance.

Word LTSC MSO (16.0.14332.20143) 64-bit
Windows 10
  • See the last step and final paragraph of the debugging page.
  • The error happens at various citations so I suspect it's about some random event that triggers the error in general (at which point Zotero becomes unstable) rather than a particular citation in a particular doc. But yes I will generate a Report ID next time this happens.
  • The error happened again, and I now generated a Report ID: 354089598
  • We need a Debug ID, not a Report ID. We don't really see anything like the bug you're experiencing so it's hard to say what's causing it from the Report ID. It would be best if you figured out the steps to reproduce the error consistently. This could be security software interfering with Zotero.
  • edited December 15, 2021
    The last paragraph of the debugging page (which dstillman referred to) mentions how to generate a Report ID, this is why I linked to that as opposed to a debug ID. In any case, I will now try to obtain the latter also (might take a while for this to occur again after my last restart, so might be quite a big log).

    The error I report seems in fact, sadly, to be reported on this forum commonly, and is certainly common in my 10+ years of using Zotero. I used to get it once in a blue moon however, and now it's daily.

    I did try to notice any steps that consistently trigger the error, but as I mentioned, it seems to appear out of the blue. All I can say is that it happens once I open the document and work on it for a while (during which time Zotero works fine).

    Also, I've had the same security software installed for years, so I doubt it's from that.
  • The last paragraph of the debugging page (which dstillman referred to) mentions how to generate a Report ID, this is why I linked to that as opposed to a debug ID
    Sorry, I misremembered it linking to the Debug ID page.

    Zotero shows a generic error message (that is often reported in this forum) when something goes wrong, but your Report ID contains a more specific error message that we don't ever see. Security software is not a "static" thing, it always updates and may start blocking something that it didn't used to block before, so this is something worth investigating.
  • Ok, I will bear this in mind. I will post back the debug ID once the error appears again
  • OK, this took one whole day of work until the error happened again, and it in fact happened while I was working on a different document, which suggests this is not a document-specific error.

    Debug ID: D1140086181

    Thanks again for your help, I will be relieved to (try and) have this fixed!!
  • I'm sorry to say that this does not offer any more insight. It's a very generic error from Word and there may be ways for us to trace it further, but first you should update Windows, Word, restart your computer, temporarily disable any proprietary security software and try seeing if you still get this error.
  • Ok - thanks anyway for looking into this. Word tells me it's at its latest version, Windows updates are always ongoing so I assume likewise there; and have restarted my PC countless times. My security software (Comodo) is the last suspect though, so I can try to have a few days of work with that disabled. But as I said, I'd much more strngly suspect my recent update from Office 2019 to 2021, although that leaves me with little by way of debugging this error.
  • If it's an Office/Word thing it will likely get addressed eventually. We occasionally see weird Windows Word errors like this that seem to appear and go away on their own.
  • Indeed, that was my experience so far as well, it's only after the 2021 upgrade that the error keeps coming back rather than happening once in a blue moon and then going away.
  • In light of your other post, the error you reported here occurs in the phase where Zotero tries to get the Word document to interact with. I wonder if this is somehow related to multiple documents being open. Have you ever encountered this with only one document open? Do any of the documents you work on are stored on OneDrive? Have you tried naming your documents and moving to folders that only contain letters numbers and spaces?
  • Thanks a lot for still helping with this, the problem is still ongoing, although it seems for some reason to happen somewhat less frequently (once every other day or so). To your questions:
    - I'm pretty sure this happens also when only a single document or instance of Word is open, so having multiple docs/instances open isn't necessary
    - none of my docs are on OneDrive, they are all local on my PC
    - some of my folder names do contain periods (.) and hastags (#).. but again, this wasn;t different back in Word 2019, when this Zotero error was only a one-in-a-blue-moon occurrence. If you suspect this might play a role, I can certainly try to rename some folders and see if this makes a difference in the long run?
  • Just had the error again with a single document open, so can confirm that having multiple docs/instances open isn't a necessary condition for this to occurr.
  • edited December 30, 2021
    Right now, I am restarting my PC (and reopening multiple windows, programs, etc.) several times in a day, to get around this problem. If there's anything else you can suggest me to try, I'd happily do it, as I do little these days other than try and humour Zotero and/or Word into letting me get on with my work.
  • I am now also getting this other error, which is probably another facet of the same problem: "You must insert a citation before performing this operation"

    Screenshot at https://ibb.co/NLQMnMr
  • Restarting doesn't even help any more, so my documents are stuck, references-wise. Went through all 10 steps of the troubleshooter (https://www.zotero.org/support/kb/debugging_broken_documents), they don't help.
  • @adomasven: error also occurs when doc is moved to root folder (no unsavoury characters in folder name). Any more ideas what else we can do here?
  • edited January 3, 2022
    Sorry for taking a while to respond. I'm afraid I don't have much to say here. You are the only person reporting this issue and there are thousands of daily Zotero users with Word so this would be reported more widely if it was a bug on our part or even an issue introduced in Word that affects all users. The sporadic nature of the errors also means that they are impossible to troubleshoot in the ordinary way by us developers reproducing the bug locally and digging into the code. These errors are most likely related to something on your computer: either configuration or some software that you run. Your best bet is to tweak parts of your system: try closing programs that could interfere, reinstall software, perhaps even reinstall Windows itself.
  • No worries, I realise it is impossible to help every single user, especially when theirs is more of a unique/hard-to-replicate bug. If I find a solution I will post back here in case it helps others. Thanks again.
  • edited January 26, 2022
    Dear Zotero devs,
    I am now getting this error ALL of the time, in every document, even after I restart my PC, and after having reinstalled the Word addin from the Z options, and also Office and Zotero themselves.
    Perhaps there's something else that can be tried before I consider reinstalling Windows itself, which needless to say would be very time-consuming?
    Thank you!
  • You should try creating a new user account on your current install of Windows and see if you get the error there, which would indicate that it might have something to do with some config options inf your current account. Otherwise a reinstall of Windows in such cases might be what it takes to fix it.
  • Thanks adomasven! Creating a new Windows account on one's PC, and configuring it so one can work on it as normal seems to be about as much trouble as reinstalling Windows, so I did some more searching for the "unhandled exception occured" error that Zotero Integration throws, as per the logs.

    As per this old thread, it seems problems can emerge if either Word or Z are launched with admin privileges:
    https://forums.zotero.org/discussion/86066/zotero-doesnt-start-with-word . This is easy to check: https://superuser.com/a/1213106/512216

    For some reason, it seems Word 2021 on my PC is indeed launched as admin when opened via double-clicking on a document in Windows Explorer, though not when opening Word from the Start menu. And in the latter case, the error (reliably, at least in my last 10min of testing) does NOT appear, whereas it does in the former case.

    So, after 2 months in which this thing stole hours from every one of my work weeks, we seem to've finally solved it. I very much hope this will save someone else going through the same trouble.

    Disconcertingly, the error is still not 100% reproducible. If I open a doc via doubleclick and another via Start (one process admin, the other one not), it still does not appear. However, this may happen after some time, and would explain why initially this error was bothering me when I had 2 or more docs open, with some leaks of reference from one doc to another, as per my older thread: https://forums.zotero.org/discussion/93609/

    This all also explains why rebooting sometimes (but not always) worked around the error for me, since it presumably meant in some cases I would subsequently reopen Word in the `right` way (no admin).
  • The same bug here. Opening a new Word document did not help. This error started to occur suddenly in all Word files.
  • @yokokumano: We'll need a Report ID and the exact Word version.
Sign In or Register to comment.