Collections empty after Mendeley import

This discussion was created from comments split from: Error Using Mendeley Web Importer.
  • Hi! I'm having the same problem, I used the mendeley online importer (upgraded the mendeley storage which i exceeded, and bought the zotero one, since i have about 9000 entries and 8000 files).
    The import apparently worked, no error message, the collections (the folders) of the files were where they should have been... but all the folders were empty!
    the mendeley version i used the first time when i did it was the last one (but not sure it's relevant. then i tried again after having overwritten the newest release with the 1.18 version, it went worse, since the bar that shows import progress got stuck in the middle. still as before, all the folders where in the right places, but empty. i suspect the program version is just correlation, but if not, here you have the information)

    i previously synced the mendeley library as well. my laptop is a macbook air 2020 (intel), and the OC is monterey.

    i tried the local import method, but mendeley 1.18 crushes, and it's another thread as well..

    thanks in advance for your help!
  • edited January 20, 2022
    (Always better to start new threads unless you're positive the issue is the same. The thread you posted to was about an unrelated, long-since-fixed issue from last seven months ago.)

    You only have a few hundred items in your online library, so it's not clear what the state of your library is.

    Can you provide a Debug ID for an import that doesn't work properly?

    Also, you seem to have deleted a huge number (tens of thousands) of items recently, I assume from successive import attempts. Don't do that. The import is designed to run on the same database and simply add any new items. There's no need to keep deleting things, and you'll just make it harder to debug your issue as well as create a huge delete log in your library for no reason.
  • edited January 20, 2022
    Thank you for your answer!

    I'm very new to Zotero and honestly, as of now, poorly literate in software, I didn't get the importance of the Debug-ID here. The one I see now is: D1893594533 - but I'll do it again after I try the sync again.

    My library isn't empty because I successfully imported two folders via local export/BibEx.
    I tried this way because the online import imported only empty folders (they're inside the first folder in my library). But after every Mendeley export, Mendeley gets stuck, so stuck I can't even close the program or turn off the Mac, I have to press manually the on/off button which doesn't seem a sensitive thing to do every time, considering I have a lot of folders. So I upgraded the Mendeley library subscription for this month - before I forever and happily say goodbye to them - thinking this could have been an issue in the problem of the online import, and tried again. But it went bad again.

    Regarding the tens of thousands of items... What?! I'm very surprised, because I did erase some locally imported folders (it's too many items that have been structured in a system over the years, I need a clean import). But it was definitely not tens of thousands! If you see all these deleted items, it sounds like the two (or three?) online imports I tried did work, but for some reason I didn't see any entry in the library, only the organized folders on the left.
    I searched around, but I haven't found this issue has been solved (for that matter I'm not sure I've found the same issue described).

    Any suggestions how I should proceed? Surely I'll try another online import and provide the Debug-ID. Should I then post it here, in another thread or contact the support?

    I'm so happy I'm with Zotero now, even if this transition is taking a lot of time and is not yet working.
  • All you need to do now is run the online import again with debug output logging enabled and provide the Debug ID here. (This is where support happens.)
Sign In or Register to comment.