PDF not downloaded on ScienceDirect

This discussion was created from comments split from: Cannot saved PDF. "Is Zotero Running?" Yes it is.
  • same here: red cross. But waiting does not do the trick: no download at all.
    I tried to import with the connector. First attempt red cross, second attempt all goes smooth & normal. This happens really often lately. I cannot predict when.
    The above should be captured in debug ID D958012444.

  • just tried again with same file: red cross, failed to download, but no message about Zotero running or not. Just red cross + "sciencedirectfull text pdf".
    And within a few seconds, not 15 secs.
    Only a connector debug ID this time: D1939438536 and D1879523823 (2nd attempt)

    direct manual download pdf from website is never an issue, so I do have access

    closed tab & tried again:
    Zotero ID D134655954 & connector ID D501203769
  • Please start new threads for new issues — saving issues in particular are almost never related. I've moved this to a new thread.
    Downloaded PDF was not a PDF
    ScienceDirect isn't serving a PDF file here, likely due to some sort of bot prevention. We'll see if we can reproduce this, but the best thing you can do is reload the page and try again. Trying to load the PDF yourself first might also help. If you're saving multiple pages at once, it could easily be because of that. (A bit less likely when it's the second attempt that's working, but that could be due to waiting longer before trying again or due to loading the PDF manually in the browser first.)
  • thank you. Retrying without relaoding always gives an immediate red cross.
    Closing tab & reload is what I typically do to avoid that. Sometimes with success. Interestingly, hitting the manual pdf-download (and interrupting) seems to help. Next try with the connector (without reloading) induced a regular import + pdf

    This issue happens quite random at several publishers.
    I never try to import multiple pages at once.
    I'll try and log more examples these days.
  • Retrying without relaoding always gives an immediate red cross.
    No, that's a misunderstanding — clicking the save button without reloading always just reopens the popup without trying again, so that you can change the target collection. It's just showing you the previous status.
  • ok. and thanks for the workaround (..load the PDF yourself first might also help..)
  • I met this problems too. It works when I reset and update my translators in zotero.exe and browser.
  • Saving PDF from ScienceDirect via the Safari share extension doesn’t work in the iOS beta app either.
  • Let me clarify. ‘Sending over’ the already loaded PDF works. Automatic PDF fetching when saving a paper via the share extension fails.
    Perhaps there’s some tweaking going on, but right now I can’t even save the article due to no progress in PDF fetching. It used to give a red exclamation mark at one of the corners of the PDF section, and the entry could be saved without the attachment. https://u.pcloud.link/publink/show?code=XZ9bSAXZNgJ2qMvwbxL0SqCehUmAVQ6tYy5V
Sign In or Register to comment.