Available for beta testing: Online Mendeley importer

In the latest Zotero beta we've added a new Mendeley importer that imports data directly from an online Mendeley library rather than a local database. This avoids the need to install an old version of Mendeley Desktop to work around the database encryption Mendeley added several years ago. Since that time, Mendeley has introduced Mendeley Reference Manager, which is essentially a wrapper around the web library without a real local database, further making any sort of local import infeasible.

If you use Mendeley Desktop, you'll need to make sure that all data and files have been synced to Mendeley servers before importing. (This was already necessary in order to sync with and import from the pre-encryption version of Mendeley Desktop.)

If you use Mendeley Reference Manager, your data and files are already all online.

To begin an import, go to File → Import within Zotero and choose the "Mendeley Reference Manager (online import)" option. You'll be asked to log in to Mendeley to allow Zotero to perform the import. Your Mendeley password is never seen or stored.

The importer is compatible with the existing local importer, so if you've added items to Mendeley since a previous import, you can import again using either tool and new items will be imported without duplicating existing items. The new importer also imports PDF annotations for use with Zotero's new PDF reader.
  • Worked perfectly -- incredible. Thank you so much!
  • Mine is unfortunately very slow, and crashes before completion with a bunch of 401 errors. My library is 1809 files big. I assume the Mendeley API has a bunch of unreasonable limitations to discourage this sort of thing, and thus hard for you to do anything about. Thanks for all your efforts, regardless!
  • @asmusod: We'll have a fix for the 401 errors (which happen if the import takes longer than ~8.5 minutes) later today.
  • @asmusod: Please update to the latest beta via Help → Check for Updates and try again, and let us know how it goes.
  • @dstillman Thanks a bunch, the import now completed successfully!
  • Hi there, I'm new to Zotero.

    I've just successfully imported my Mendeley library. When I open one of the PDF's that came from Mendeley in Zotero I can see my old highlighted text and annotations, however Zotero is unable to extract annotations from any of these imported PDF's. I have ZotFile and Mdnotes for Zotero active and have not had issues doing this with PDF'sI've edited in other software.

  • @philip.s.ericsson: You add Zotero annotations — including imported Mendeley annotations — to notes using Zotero's own annotation functionality. If you're trying to use ZotFile, that won't work — ZotFile doesn't know anything about Zotero annotations and is no longer necessary if you're using the Zotero PDF reader.
  • Does this way of importing from Mendeley to Zotero keep the tree folder structure of all entries that exist in Mendeley?
  • This would wonderfully simplify my life. Is there an ETA on when this will be available in a non-beta version?
  • edited September 12, 2021
    Zotero seems to have merged "Tags" (the ones I created in Mendeley) with "Author Tags," and somehow added some new tags that are basically random phrases from the article itself. Is there a way of importing my Mendeley library so that I have just the tags that I created and organized in Mendeley into Zotero?

    Also, my Mendeley online import to Zotero has been going on for over 6 hours (Mendeley library is quite large--7.52 Gigabytes..!). Is it possible to stop the import for now and come back to it after rebooting my computer, redo the online import without duplicating items?
  • The Mendeley Importer was great, but it also imported all of the random tags assigned by the authors / library databases. I can see that many people over the years have requested a bulk tag editing feature. It took me a very long time just to delete the tags from A - E. Please when will this functionality be available? My Zotero library is suffering from it. Thanks.
  • Hi,
    I downloaded the latest beta for Ubuntu but the option "Mendeley Reference Manager (online import)" doesn't show up when I select import. The only options are "file" and "Mendeley" (which then asks for a local Mendeley database).
    Could anyone help me please and tell me what I am doing wrong?
  • It sounds like you're not running a recent beta release of Zotero, you can check by selecting "Help"->"About Zotero", version is mentioned underneath the logo, it should say something like "5.0.97-beta".

    You can download latest beta build from here.

  • edited October 17, 2021
    I'm wondering if Zotero is working towards enabling group folders from Mendeley? If yes, I'd wait until it's ready.
  • @yaoyaoirhr: The Mendeley importer has always supported Mendeley folders.
  • Hi, thanks for the updates. The Mendeley importer worked great and I was able to migrate my library and folders to Zotero. However, for some reason the highlights and other pdf annotations aren't visible. Any troubleshooting advice? I should be running the latest beta version.
  • @saarih: Have you enabled the built-in PDF reader from the General pane of the preferences? Imported annotations won't appear if you just open the PDF in an external reader.
  • Perfect, thank you!
  • This feature is great! However, it seems that the "arxivid" seems not be be carried...? I found discussion on this https://forums.zotero.org/discussion/85274/zotero-needs-a-preprint-category . So it seems that the arxivid field does not yet exists (which is greatly disappointing in our battle against pay-walls!!). In this worst case scenario it should still be carried to the "Extra" field, such that it can ported to the new field as soon as it is added.
  • A minor amendment to my request of yesterday: it seems that BBT already supports having "arXiv: XXX" in the "Extra" field (see https://github.com/retorquere/zotero-better-bibtex/issues/1611), so, at least for now, the only thing that is needed is that the importer module reads the "arxivid" Mendeley field and writes it in to the "Extra" field.
  • @tdegeus: arXiv ID import should be fixed in the latest Zotero beta. You can upgrade to that and reimport to overwrite the previously imported items.
  • I just installed the latest Windows beta (5.0.97-beta.53) and ran the Mendeley importer. My folder structure, ~2200 references, tags, notes, highlighting, and PDFs seemed to have all come across cleanly. The import even consolidated data from duplicates in Mendeley I didn't know I had into one document -- well done and thank you!!!

    Highlight Colors
    I used highlighting extensively in Mendeley while working on my dissertation. Each color means something specifc: strong/weak evidence for my thesis; strong/weak evidence against; text cited; text quoted). It and Zotero both support five colors (yellow, red, green, blue, purple), but Mendeley also supports orange, pink and gray. Five colors is not enough to meet my needs.

    Fortunately, I was surprised to see that the importer preserved my orange highlights! Maybe it preserved pink and gray, I'm still looking. It would be great if an upcoming version of Zotero supported highlighting in these (or other) additional colors. If not, maybe there is a different way in Zotero to accomplish the same thing?
  • gotta agree with cbell4444, 5 colours is rather limiting. Not to flog this too hard, but a few more colours, or the ability to set some favourites, would be lovely.
  • I did use the favorite feature in Mendeley but only as a rough sorting mechanism. My overall impression after 10 months is that Zotero is easier to use helps me stay more organized.

    Bump for more colors, though :-)
Sign In or Register to comment.