ID:106086373 Zotero Integration Error, Zotero experienced an error updating your document

Reprot ID:106086373
Dear administrator,
Zotero reported an error when I used it to insert a citation in Word(for mac)—Zotero Integration Error, Zotero experienced an error updating your document.
What has been done:
1. reinstall word process
2. Reinstall zotero and word
3. Change the system user name to English

Exception: I found zotero can be used normally in Google docs, but cannot be used in word(for mac)
Zotero version :, word version :16.52, and the computer :Macos big sur 11.5.2 M1 system
This situation has seriously affected my ability to use zotero, and I am looking forward to solving it. Thank you!
  • Did you try the steps at Troubleshooting Errors in Word Processor Documents? What happened for each?
  • Thank you for your reply!
    I've already tried this steps:
    1.Disabled the Track Changes feature in Word;
    2.I didn't copy a citation to a caption.
    3.Copying text and documents is invalid, in fact, I have not successfully inserted a citation after downloading zotero.
    4.Manually Installed the Zotero Word Processor Plugin.
    All of them are useless,so sad.
  • There are more than 4 steps on that page.
    Copying text and documents is invalid
    I'm not sure what you mean here. Could you elaborate?
  • edited August 28, 2021
    Sorry,I find my my situation fits "If you get an error trying to use Zotero in a new, empty document",so I should not try the steps at, but try the steps at

    Factly, my question is that I never can insert a Zotero citation in a new empty document successfully. The error is "Zotero Integration Error, Zotero experienced an error updating your document". But I didn’t find the solution for my question in My Zotero toolbar can appear in word, the plugin can respond, but when I selected the citation to insert, and then clicked OK, the error reported.

    Thank you again for your reply sincerely!I really want to use Zotero successfully.
  • Hello? Can someone help me?
  • edited August 29, 2021
    Note that you might sometimes not get a response here for a few days, particularly over the weekend, so you should set your expectations accordingly.

    Has the Word plugin ever worked on this computer?
  • edited August 29, 2021
    Thank u!I may be a little anxious to use Zotero.

    Yes, the Endnote plugin can work normally in word in my computer, but Zotero plugin can't.
  • Did you change Word to run under Rosetta? While doing so shouldn't break Zotero integration, Word should be running natively. Select the app in Finder, go to File → Get Info, and make sure it's not set to run under Rosetta.

    You can also try removing the EndNote plugin from Word. Some people have reported problems while that's installed, though I have no idea why that would interfere with the Zotero plugin.

    There are no known issues with Zotero on M1 Macs.
  • edited August 29, 2021
    The Word is not running under Rosetta.
    The EndNote plugin is removed from Word.
    Then I restarted my computer, and the error is also reported.
    I am desperate. I first asked my friends who used it together on the internet, and then came here to ask the administrators. All is useless. It seems that I am doomed to be unable to use Zotero.
    Whatever, thank you finally.
  • @adomasven may have some other suggestions, but you'll need to be a little patient.
  • edited August 29, 2021
    woo!! OK!! I will wait patiently! Thanks!
  • Could you restart your computer, then open Zotero, a new document in Word and confirm that you cannot insert a citation. Does it happen regardless of the item that you try to insert? Do you have any other plugins in Word?
  • I try to restart my computer again, open Zotero and a new document in Word , I can confirm cannot insert a citation. The error "Zotero Integration Error, Zotero experienced an error updating your document" also be reported. It happen regardless of anyone item. There is only Zotero plugin in the Word.
  • Could you submit another Report ID after this?
  • edited August 30, 2021
    OK! The Report ID :354172051

    The note is[JavaScript Error: "The operation couldn't be completed. (OSStatus error -1708.) @[activate:document.m:140]" {file: "file:///Applications/" line: 431}]
  • Does it work if you change your system language to English?
  • You mean the computer system or Zotero system?
  • WOW! I change my system language to English and the error is disappear! Although it is a little inconvenient for me , I can try to get used to it, thanks u so much!!!!
  • Yeah, sorry about that. We had another user report this about half a year ago, but we cannot reproduce it on our systems by changing the system language to Chinese, so we cannot debug or fix it.
  • Get, thank u whatever!
  • Hi @adomasven , I'm having a very similar problem to @lbw7200006 , however my system is already in english and I'm not sure what to do. Do you have any suggestions?
  • [JavaScript Error: "The operation couldn't be completed. (OSStatus error -600.) @[getDocument:application.m:85]" {file: "file:///Applications/" line: 404}]
  • Report ID: 716794236
  • @sattard: What Word version? Have you tried restarting your computer?
  • @dstillman , restarted the computer earlier this afternoon didn't fix the problem, but I just tried it again now and it worked. Thanks so much for your help, even though I don't understand why it worked the second time but not the first lol
Sign In or Register to comment.