Zotero is no longer making footnotes in Google Docs

Hey there! I am writing a research paper and just ran into this problem where Zotero had been making footnotes perfectly - I'm using Chicago Manual 17th Note - and then just now it has changed from creating footnotes to putting the note just into the text. I've tried a bunch of trouble shooting but I just can't get around it for some reason. Let me know if you have any suggestions for resolving this issue!
  • edited March 4, 2021
    I am having the same issue. My citations aren't being added as footnotes but as full text in the body of the content.

    Report ID: 812345745
  • Does this still look right in a new document (that's for testing; obviously won't help you)?
    How about if you switch to the Full Note Chicago style in your existing doc?
  • Tried a new document + using Full Note Chicago (which was the style in the original google doc too FYI) - still the same issue

  • @adomasven will need to look at this. There were some recent updates to google docs integration that may be related, but I'm not sure here. Which browser are you using?
  • edited March 4, 2021
    I am having the same issue. Citations that should be Chicago style footnotes just get slapped into the middle of the text. I have the same result when trying this in a blank document. This is a very recent problem, as I've been using Zotero throughout my project. (At the same time one of my footnotes became unlinked and I can't edit it because of a "Cannot read property 'startsWith' of null" error. Though, this may be an unrelated, separate problem.) I am using Chrome.
  • Same issue over here, using Chicago and Turabian 8th. Was working last night, but with the 5.0.82 update, seems to have broken the creation of a footnote before inserting the citation.

    Using Chrome 89.0.4389.72 (Official Build) (64-bit)
  • I am having the same issue. It was working fine and after I upgraded Zotero it now places the Citation inline in the document instead of creating a footnote. Please help! I use Chrome. I've tried in a brand new blank document and get the same result.
  • edited March 5, 2021
    EDIT: This workaround is no longer working for me and didn't work for others.

    I am having the same issue when using chrome. However, I just tried it in Microsoft Edge. There, I am NOT having the same issue. While this issue needs a full fix, I might suggest to the other commenters in this thread to try a different browser and see if it works there.
  • @noahdiantonio: And that's with the same document? Can you provide a Debug ID for this happening in the Zotero Connector for Chrome?
  • @dstillman: Yes, it is the same document. The Debug ID for my Zotero Connector for Chrome is D2105423684
  • To everyone: if you press Ctrl-Alt-F does a footnote get inserted into your document? Have you tried disabling other extensions you have in the browser and seeing whether it works?
  • I am having the same problems on Chrome, using Google Docs and Zotero not inserting citations into footnotes. I have tried Ctrl-Alt-F and an ordinary footnote inserts fine
  • @dstillman I tried disabling all extensions other than the Zotero Connector, then restarted the browser. Problem remains unchanged.
  • I tried the work-around suggested by @noahdiantonio of using Edge, but this did not fix anything for me, either on the project I had been working on or on new documents.
  • @Mark2k2: Unfortunately, the problem is now happening to me on Microsoft Edge as well. I'm not sure why it worked yesterday, but now I am having the problem across browsers as well.
  • using chrome, in a document with a few sources already. Same problem, debug ID 1986005523

    had this earlier today, at some point zotero would just do nothing. After a reload it again tried to insert the note in text.

    Im using CMS full note, and have been using zotero in google docs happely for quite some time.
  • We are investigating this, but you can work around it temporarily by inserting the footnote manually and then citing there. You can insert footnotes via the Insert menu in Google Docs or by using the keyboard shortcut (Ctrl-Alt-F or Cmd-Option-F).
  • adomasven - Ctrl-Alt-F inserts a blank footnote at the bottom, but when I link to Zotero, it still puts the data inline into the text and not in the footnote area. Thank you for working on this for us all! Much appreciated.
  • Good morning all. I too am experiencing the same issue as others here. Citations have been working perfectly for about 10 months now but have all of a sudden stopped and the citation is simply pasted into the document (instead of as a footnote), the same as @rscheel has explained.
  • edited March 9, 2021
    Me too. Just started today. Using Google Docs in Firefox with the zotero connector add-on and the windows desktop zotero app.

    My workaround right now is to create a footnote manually (ctl-alt-f) and then click and drag the zotero entry from the zotero app into the footnote. It seems to work, though I'm not sure if it will be managed the same way as all the other zotero citations in the document. It also does not use the same formatting I had set, though there may be a way to fix this.

    EDIT: DO NOT FOLLOW THIS ADVICE. Zotero will not keep your citations managed if you do this, and it won't properly handle second references, etc. See my updated post below for an actual workaround.
  • @tfucoloro: Dragging will likely break the citation, but you may be able to cut and paste into the footnote.
  • I am now using Ctrl-Alt-F to create a blank footnote and then I am copying and pasting the citation into the footnote. Seems to be a viable work around. Not sure if this will cause any other problems. Thank you @dstillman for the suggestion.
  • Same Issue - Just noticed it today - this only seems to be a problem on my windows computer - when I switch to my Mac it works fine.
  • edited March 8, 2021
    Same here. I'll be watching this thread to see how everyone else is doing with this in the coming days.
    I'll be using tfucoloro's workaround in the meantime!
  • edited March 8, 2021
    @Alici: No, don't drag — as I say, that will break the citation. For now, cut and paste into the manually created footnote.
  • edited March 8, 2021
    Can someone confirm that you cannot insert citations into footnotes inserted by hand? Could someone make a video recording of inserting a citation with a footnote style in Google Docs, and then attempting to insert a citation in a footnote made by hand? For the second attempt make sure that the cursor is in the footnote, not in the main text of the document. Please upload the video recording somewhere online, like dropbox and post a link to the video here.
  • edited March 8, 2021
    @adomasven @dstillman They *can* be inserted through copy paste, but they're unintelligent. They don't know what other citations you have, so they will give the full citation every time rather than a shorter citation after the first. They are also unable to be edited by Zotero, as it gives the "Cannot read property 'startsWith' of null" error. The one thing that still works correctly is that the bibliography does update to include citations added this way.
  • Checking in to say I have been experiencing this issue as well!
  • edited March 8, 2021
    To debug this further, we'll need the info Adomas requests above.
  • edited March 9, 2021
    @adomasven @dstillman OK, I figured out what you mean. Here's my video: https://www.youtube.com/watch?v=f_Nq1GePIMs

    Steps: Insert the citation like normal (ctl-alt-c or use the zotero drop-down menu). The citation will be wrongly placed in-line rather than in a footnote. Highlight the citation and cut it (ctl-x), then create a footnote (ctl-alt-f) and then paste (ctl-v). This will insert the citation and Zotero will manage it like normal. Refreshing will update the citation and second references should be shortened like normal. It's a bit of extra headache, but not terrible.

    DON'T DRAG THE CITATION LIKE I SUGGESTED EARLIER. Zotero will not manage it correctly.
Sign In or Register to comment.