Zotero is no longer making footnotes in Google Docs

2»
  • Another workaround I've discovered - when adding a citation in Australian Guide to Legal Citation 4th Edition. If (after adding the citation) I change the document preferences to APA, and then change it back to AGLC 4, the footnote is generated correctly.
  • Zotero Connector 5.0.83 for Firefox is now available with a fix for this, and we've submitted updates for Chrome and Edge that will hopefully be available within the next 24–48 hours. Thanks for your patience on this.

    @charlievanallen, @nkhlgeorge, @Mark2k2, @sphilps, @rscheel, @noahdiantonio, @PGreenman, @CedricJ, @andrewwells, @tfucoloro, @PastorRickSGCC, @Alici, @rfriaz, @studentpete
  • Thank you very much. Looking forward to it being back to normal! :)
  • I just gave the Firefox addon a shot (confirmed that it's the version from March 10th) and I can't add citations into footnotes, they're added to the main text right after the footnote instead. If I try to edit an existing citation that I copied and pasted into a footnote (note that it is not showing up as red, i.e. unlinked) a popup reports that "selectedFieldID is null".
  • edited March 11, 2021
    I am looking at the Zotero Connector in Firefox, it seems it is still currently 5.0.82, not 5.0.83.
    Looking forward to it being back to normal too!
  • edited March 11, 2021
    Samuel Lee: You can update manually from the Extensions pane in Firefox — Gear icon → "Check for Updates". Let us know if 5.0.83 works for you.
  • @willismonroe: Just to confirm, you reloaded Google Docs after verifying that you had 5.0.83. Does it work in a new document?
  • I tried a new document, made a footnote and tried to insert a citation into the footnote and here's the result: https://imgur.com/a/dtiMqpt It inserts after the footnote mark in the main text.

    Confirmed I'm on 5.0.83
  • edited March 11, 2021
    @willismonroe: Oh, so you're using an in-text style, not a footnote style? I can reproduce that with Chicago Author-Date with the new version. Most/all of the other reports here are about using a note-based style (e.g., Chicago Note), where Zotero inserts the footnote for you.

    We'll look into the problem with in-text styles in footnotes. In the meantime, as a workaround, you should be able to cut/paste the in-text citation into the footnote.
  • @dstillman Ah ok, yeah I just tried adding a note style citation and it works. However, I can't edit the note style citation after it's added. I get the error: "selectedFieldID is null"

    If you can get to adding in-text in footnotes that'd be great too!
  • Thank you @dstillman and everyone else who worked to fix this! It's working great now.
  • Zotero Connector 5.0.84 for Firefox is available now with the additional fix for citing with the cursor within an existing footnote, as reported by @willismonroe. That will likely be available for Edge today or Monday, and for Chrome sometime next week (after they first approve 5.0.83).
  • @dstillman excellent, I just tried out the Firefox version it editing citations in footnotes works perfectly. Thank you for your speedy work!
  • Thank you ! Its working great for me too!
Sign In or Register to comment.