An error occurred while trying to export the selected file

I'm exporting a library of 5749 items to a disc with 340GB free. The last time I did an export, with 4668 items, it totalled about 33.4GB.

The Error Console looks like this -

The export fails at about 14.5GB, 2793 files.

I have Windows 10 on an Asus desktop, Intel Core i3, DDR3 8GB.

I see someone got round this by exporting to a shorter file path - my path is only E:\Zotero\My Library 210116\My Library

This has happened four times now; the last time I rebooted the machine first.
  • I am now running Check Database Integrity
  • OK, it's 12 minutes now and there's been no message, so I assume all is well.
  • Tried exporting to the main disc instead of a USB backup - failed on 2459 items.

    Debug submitted, No. D1087545208
  • And again this morning: after shutting down the machine overnight, then doing a registry check, failed on 2459 items like last time (but failed on 2793 items before).
  • I had the same problem. Exporting to a shorter path, and then importing from that path to the profile I wanted to transfer the subcollections to worked. It would be good if the error message could flag path length as a potential problem. Until I read this tread my workaround was to export sub-subcollections individually. This made for massive work putting them back in the right place in the hierarchies and also made for many, many duplicates. Which is not how I wanted to spend this Sunday! T

    That said, I love Zotero, and I really appreciate the team's efforts (and successes!).
  • I have now simply copied the Zotero folder elsewhere as a backup — simple but effective. Choosing a different drive, with the shortest path possible, made no difference.

    I read that the developers recognise that Export-Import can be problematical and is not recommended. One doesn't want to be too critical of the developers—I'm delighted to have Zotero and it does everything I want—but if so, why offer it...? And having said that, I have succeeded with Exports in the past!
  • Export is useful for sharing items quickly with other users or exchanging with other software, which is why it's offered. It's definitely not what you want to use for a back-up.

    That said, exporting your library should definitely work. My guess would be that it's actually a memory issue -- Zotero isn't terribly good when writing enormous XML files (which an RDF for 5k items is) and may simply hit the RAM alotment for a 32-bit app on Windows.
  • I have now simply copied the Zotero folder elsewhere as a backup — simple but effective.
    And to be clear, this is exactly how you should be doing a backup.
  • My guess would be that it's actually a memory issue
    Another possible reason might be that you have broken attachments in your library. But I'm not sure about whether they can break the export.

    You could check if you have broken attachments in your library with the Zotero Storage Scanner add-on. It adds '#broken_attachments' tags to broken attachments. (I think selecting "Tools" -> "Storage Scanner" will update these tags.)

    There's also a related script here. I think the script excludes linked files.
  • Thanks guys.
  • If relevant for the future, I had been trying to export a collection in "Better BibTeX" format that constantly failed. By switching to "BibTeX", I exported with no problem: without issue of path length.
  • I'd appreciate it if you could file an issue for that on I can't fix problems I don't know about.
Sign In or Register to comment.