Which WEBDAV service for Zotero?

  • edited April 14, 2009
    You can use box.net as an free but unsecured webdav service (1gb), just define the storage server url as:
  • I also created an account with mydisk.se and am trying to sync my Zotero library with it. I tried typing in mydisk.se/username (where username is my actual username) but Zotero keeps telling me it's not valid. The only difference I can see is the Zotero Preferences has http (no s). Do I need to add the s? If so, how? Or do I need to do something else altogether?
  • Just to follow up, I figured out how to change the http to https, but that still doesn't solve the problem. Any advice would be greatly appreciated.
  • See Sean's message a few posts up from yours.
  • Thanks. I read the way above posts but somehow missed the end section. I'll see if I can get it to work with box.net now.
  • And.. it worked! Thanks Dan, and ktkallio for the advice.
  • mydisk.ch is a free service that works with zotero. there's a 2 Gig limit for the free service and individual files can't be bigger than 2 Gigs. Accounts are easy to set up to work with zotero. Highly recommended.
  • mydisk.ch doesn't seem to work, not for me at least.
  • edited August 8, 2009
    strange, worked perfectly for me. any idea what the problem is? just a thought, but maybe you need to set mydrive.ch to use https rather than http. i think there's

    the server url to use is https://webdav.mydrive.ch .
  • ktkallio, if you're having trouble, please provide a Report ID after syncing.
  • @sauerkraut

    Thanks for the tip!
    mydrive.ch works for me too.
  • hi

    can not use mydrive.ch, when i try to verify the server (fpr both http and https) nothing happens the progressbar spins forever :O/

    what´s my fault?
  • edited August 26, 2009
    zahnwissen, I had the same problem. I double-checked the URL and realized I had a space at the end of the text 'webdav.mydrive.ch'; I had copied the URL from the mydrive.ch site, and the space must have come along without my noticing.

    Make sure there is no space at the end and try again, it should work.
    If there is a space, Zotero is trying to connect to:
    https://webdav.mydrive.ch /zotero
    instead of:
  • Any current recommendations regarding online-storage with WebDAV feature?

    I have been using BingoDisk, but it's being taken over by ExpanDrive and the WebDAV feature is slated to disappear.
  • There will soon be a powerful new storage option designed specifically for Zotero users and groups. We encourage you to remain patient for just a few days.
  • yes? I'm interested!
  • * has trouble remaining patient *
  • It's gotta be getting on for just a few days!? I'm shivering with anticip...
  • any more details?
  • I can sync docs via mydrive.ch to home on mac but not to pc at work. It's a little frustrating as I'm trying to write some important documents. Clicking 'verify server' I get error "-15"

    Any news on the new webdav?

    Also, I noticed that someone from mydrive.ch posted today saying they were willing to work collaboratively to sort this out.
  • There have been a few hints on the forums about the new storage service, eg.
  • DrRog,

    If you're looking for another WebDAV service to try, we (Squeaksoft.com) have at least one customer using our WebDAV service successfully with Zotero. I have tested it on both OS X and Windows using Firefox 3.5.3 and are able to sync files successfully. If you'd like a test account to see if it works for you, feel free to contact us using the form at https://portal.squeaksoft.com/submitticket.php?step=2&deptid=4.

  • Jungledisk is cheap and (for me, after several months of use) trouble-free.
  • Another vote for Jungledisk. Few bucks a month, trouble-free with 3 users on 3 different machines, mixed Mac-Win environment. It also has the advantage of a (primitive) html interface for when you're away from your home machine and need network attached storage.
  • I'm in the initial stages of testing an alternative to BingoDisk. So far I've tried the free/trial accounts on myDisk.se (https://mydisk.se/web/main.php?show=home) and myDrive.ch (http://www.mydrive.ch/).

    To migrate the data from BingoDisk I copied the files via the Windows Explorer 'My Network Places' interface. This intermediate step in transferring files between hosts gaurds against failures during the copy (I had a round 80MB so this was a strong possibility). I then attempted to copy the zotero directory into each of the new WebDAV hosts.

    On myDisk.se there were endless authentication problems but I eventually got all the files copied, however the zotero plugin could not connect to the remote server no matter what I tried. (I suspect they have latency problems propagating updates within their datacenter since changes I had made consistently took a few minutes to become available.) On myDrive.ch transferring files went through on the first attempt, as did authentication from the zotero plugin. Using myDrive.ch the whole process took less than 30mins (for 80MB on an avaerage network connection.)

    In summary: I would recommend using myDrive.ch over myDisk.se for zotero. Hope other zotero+BingoDisk users find this helpful.
  • edited September 15, 2009
    I had a few failed attempts previously at getting the WebDav synchronization to work; but today I finally decided to figure it out. My criteria are simple: I do not want to set up something on my own servers, and I obviously like a free solution.

    After reading all the related Zotero threads and trying various solutions, my final conclusion is to use "mydrive.ch". Here is a quick summary of what's wrong with what:

    - Dropbox: As opposed to what was implied in one of the threads here, Dropbox does not have WebDAV.

    - Box.net: It seemed like a good solution. But I never managed to get it to work. I can login using both HTTP and HTTPS, and it starts syncing fine, but at one point it continuously fails syncing with strange errors. I was not able to finish a full sync on my 400MB library. A potential reason for this (and a big problem with Box.net) is that an individual file cannot be larger than 25MB.

    - MyDisk.se: As mentioned in these forums (and as I learned by experience), they don't let Zotero users to use their WebDAV because of their server limitations -- unless you upgrade to their paid service, and even that does not seem to be 100% granted!

    - Jungle Disk: Didn't really look too much into it as it seemed to require server setup.

    - Foldershare.com: This doesn't seem to be a WebDAV solution, from what I've read here. It's a solution for syncing Zotero libraries in a sense, but "mryckman" mentioned some caveats (e.g. write conflicts, etc.) so I avoided it.

    - Livedrive.com: Similar to Foldershare, it is not a WebDAV solution, and it is not free.

    - BingoDisk.com: Not free.

    - Squeaksoft.com: It's nice that they support Zotero and mention it on their website. The only drawback is that it is 12$/year for 2GB space -- well, I don't want to be cheap. That's really inexpensive. But as I said my objective was to find a free option as there seems to be plenty of WebDAV providers out there.

    - MyDrive.ch: It synced my 400MB in 5 minutes (on a Gigabit campus connection)! Works like a charm! You have 2GB space which is more than enough for my 400+ library, and there is no restriction on file size. This is my recommended solution for a pain-free and cost-free setup. By the way, someone mistakenly referred to this as "mydisk.ch", which does not exist.

    Hope this saves some people the time I wasted figuring it out :)
  • edited September 17, 2009

    Thank you, thank, thank you!

    I wasted a bunch of time getting various accounts and then discovering their limitations (gmx ==> 1000 file limit, idisk.se ==>blocked, boxnet ==> ??)

    MyDrive was simple to sign up for and configuring zotero was simple: just webdav.mydrive.ch and then my username and password.
  • Thanks, alik. I've spent a couple of hours trying to get something to work and another couple on these forums. All set with MyDrive!
  • Thank you so very much, storage sync finally working!

    Big thumbs up to MyDrive.ch!
  • I've tried with Myddrive.ch. It synced only a part of my library attachments and, above all, after this first partial installment it did not make updates anymore. I've asket to their support service, and thi is their answer:
    I think the problem could be that Zotero stores too many files inside a single folder.
    Is it possible to delete some old files, or maybe split it up into multiple folders?
    Best regards
    Markus Koller
    Any hints?
    Thank you
Sign In or Register to comment.