Ubuntu 18.04 - adding a launcher for Zotero

edited May 4, 2019
The official instructions for how to install Zotero for Ubuntu seem pretty minimal and maybe they assume users are experienced with Linux/Ubuntu. I'm new to Linux/Ubuntu and have had difficulty getting good results by following Zotero's installation instructions for Linux.

Step one (downloading, extracting, and putting in a directory) was not a problem, but getting the icon for Zotero into the regular application launcher tray has been a big problem.

1. Download the tarball, extract the contents and run zotero from that directory to start Zotero.

- Okay, done. I put it in my Home directory in its own folder. (I've since gotten the impression that "your life is easier" if Zotero goes in the "opt" sub-directory. Which, okay, but just further confuses me.

2. For Ubuntu, the tarball includes a .desktop file that can be used to add Zotero to the launcher. Move the extracted directory to a location of your choice (e.g., /opt/zotero), run the set_launcher_icon script to update the .desktop file for that location,

--- How do I run the "set_launcher_icon" script? I have no idea...

and symlink zotero.desktop into ~/.local/share/applications/ (e.g., ln -s /opt/zotero/zotero.desktop ~/.local/share/applications/zotero.desktop).

--- How do I "symlink" ?? -- I have tried using the supplied code and substituting the path to the installation on my computer where the "opt" is in the example. No sucess.

Zotero should then appear in your launcher.

If my questions are too basic to warrant specific help, could someone please point me to where I can learn enough to understand the instructions for this as posted on Zotero's Linux installation page?

Or....should I just do this:


sudo add-apt-repository ppa:smathot/cogscinl
sudo apt-get update
sudo apt-get install zotero-standalone

...and skip Zotero's recommendation? It seems this recommendation gets support in the forums, and it handles the installation location and launcher icon without the user needing to know anything beyond this above super user commands. Then again, installing Zotero property for Linux/Ubunto should be pretty basic, and a good opportunity to also learn more about using Ubuntu.

  • edited May 4, 2019
    While smathots ppa is the granddaddy of zotero debian/ubuntu packaging, it usually takes a while to update to the latest version - it's currently still at 5.0.60. https://github.com/retorquere/zotero-deb generally updates a little faster.
  • Yes, was just going to say that - while we can walk you through getting the launcher icon to work, the quickest and most convenient way for you is to use Emiliano's PPA.
  • Thanks, that was so much easier that trying to set up the shortcut. It bugs me that I couldn't figure it out and I hope I can one day.
  • Use the solution here: https://forums.zotero.org/discussion/68453/install-zotero-5-0-on-ubuntu by scorretti.
    Works so well for me.
  • On Ubuntu 18.04 after a "full upgrade" to Zotero 5.0.93 I found that my desktop icon had "gone generic". All of the symlinks were correct, but I had to use "properties" to set some kind of hidden security flag on zotero.desktop before the generic icon was replaced with the zotero icon. After running by double-clicking zotero.desktop, the program ran with a generic icon but this was also resolved after a reboot and the "big Z" is back in my favourites bar.

    This is mostly a message to my future self, as I'm sure my past self has seen this and failed to document the solution.

  • @earcanal, I got the same problem, i.e. a generic launcher icon after update.

    For me the easiest solution was:

    1. remove the launcher symlink (the generic icon will disappear from the launchers):
    `$ rm ~/.local/share/applications/zotero.desktop`

    2. execute the launcher script:
    `$ /opt/zotero/set_launcher_icon`

    3. symlink the new launcher:
    `$ ln -s /opt/zotero/zotero.desktop ~/.local/share/applications/zotero.desktop`

    The launcher icon should appear in the launchers, no need to reboot.
  • For me none of the solutions involving zotero.desktop file worked, I kept getting the following error when trying to run the zotero.desktop file:
    ./zotero.desktop: line 1: [Desktop: command not found
    ./zotero.desktop: line 3: -c: command not found

    What DID work is doing exactly what @fdeboiss described, but replacing "zotero.desktop" with just "zotero". Shows up in the launcher immediately with the icon and all, works like a charm.
  • @kmatic94: To be clear, zotero.desktop isn't something you run from the terminal, and no instructions say to do so. The executable is 'zotero'. The desktop file is for adding Zotero to your launcher with an icon. I don't know what you're saying you did, but the executable isn't a replacement for the desktop file in any way and can't be used to add Zotero to your launcher with an icon.
  • Check capitalization of the directory path in the symlink-creating command.

    The archive download contains a directory named "Zotero_linux-...", and I cut that down to "Zotero" as many people would. But the command given in the instructions uses a lowercase "zotero", and such details are easy to miss.
Sign In or Register to comment.