Word Crashing Consistently

  • I have this problem as well - almost constant crashing, but intermittently it works fine.

    I am considering switching to a different reference manager, any suggestions that make the switch easier would be welcomed, as I have a huge library in my Zotero.
  • edited February 8, 2018
    There similar complaints about Word problems with other reference management software. The newest version(s) of Word broke the connections that worked well in the past. Making a change is not likely to solve the problem. Clearly, this is a high priority issue with Zotero developers. The new Word version broke the processes used by bibliographic management programs. The new version of Zotero didn't cause this.
  • @DWL-SDCA This crashing on Windows is not related to Word upgrade, I'm afraid, and is actually on us. That said, it is high-priority and we might have a fix.

    @Paulbryde please see this thread, install the proposed fix from this comment and report in that thread whether it helps.
  • (I wouldn't switch from Zotero and any change in reference manager is painful, but since you asked: if you do want to get data out of Zotero the standard exchange formats are RIS, BibTeX, and Endnote XML and they work differently well for different tools, so you'd want to test what works best in your target tool; some tools like Mendeley also have dedicated tools for getting in data from Zotero).
  • I had this problem too, but painful (lots of formatting consistency to try and hold on to) copying and pasting into a new document has solved it (for now).
  • I'm having this problem too. Have word 2016. Please let me know what I can do!!
  • @jzarazaga could you try disabling any security software you run temporarily and try again?
  • edited October 24, 2018
    Hi Guys,

    It took me 15 minutes to put one footnote in my book this AM. I have copied the error reporting below.

    I know you love this program, and I love this program. I am so thankful for your help and support. However, since you changed it, I guess converted it to stand alone, it just has not worked! I used it through my entire dissertation and it NEVER crashed one time. Now it crashed 5 or 6 times for one footnote -- I forget how many times.

    Anyway, I will not give up and try to look into the comment above.

    FYI, I THINK it crashes for me when I have multiple docs opened, an outline and my chapter for example.


    [unrelated errors removed — D.S]

    [JavaScript Error: "The RPC server is unavailable.


    [JavaScript Error: "The RPC server is unavailable.


    [JavaScript Error: "Win error 3 during operation open (The system cannot find the path specified.

    )" {file: "(unknown module)" line: 0}]

    version => 5.0.51, platform => Win32, oscpu => Windows NT 6.1; WOW64, locale => en-US, appName => Zotero, appVersion => 5.0.51, extensions => Zotero LibreOffice Integration (5.0.14.SA.5.0.51, extension), Zotero Word for Windows Integration (5.0.8.SA.5.0.51, extension), Shockwave Flash (, plugin)
  • I was having the same problem: would try to insert a Zotero citation using word plug-in and the screen would freeze and word would crash. I looked at my Zotero account and realized I had used up all my free storage. After buying storage for the year, Zotero now works without a glitch. You may be out of memory.
  • Those two things shouldn’t have anything to do with each, so I think this might be a coincidence, but glad you have it working now
  • Dear Colerizki,

    Thanks for the thought. I did check my storage and I have ample. I think the problem may be the laptop I am using. I have been working on my office computer and so far there has not been a WORD crash.

    The issue is that Word crashes when I am trying to enter or edit a citation.

    I wonder, and perhaps bwiernik can comment, that my lack of internet and wifi at home may somehow be affecting my Word operation, and this is actually somehow making Word crash when I use Zotero? I have internet at my office, and it has not crashed yet. I have no internet at home and Word crashes there. I have updated my Word on my laptop.
  • @taylorspencephd No, Zotero's Word integration doesn't use the internet at all, so that wouldn't be the issue. Can you please start a new thread, describe exaclty what is happening, and provide a Debug ID for an attempt to use the Zotero Word functions that causes Word to crash?

    Also, what exactly do you mean by "crash"? And does the problem happen in a new empty document or only an existing one? What specific version numbers for Zotero and Word are you using, and are you on Windows or a Mac (and which version)?
  • (@taylorspencephd started this thread, so this is the right place.)
  • Sorry, long thread and I misread the original poster.
  • Hi dstillman and bwiernik:

    Okay, it has happened again. I purposefully tried to make Word crash, and it did. I opened three Word docs and then tried to insert a citation.

    Dialog Box says "Microsoft Word has stopped working."

    When Word asked me if I wanted to send information to Microsoft, this is the information:

    Files that help describe the problem:
    C:\Users\preferred customer\AppData\Local\Temp\101327501.cvr
    C:\Users\preferred customer\AppData\Local\Temp\CVR5C92.tmp.cvr
    C:\Users\preferred customer\AppData\Local\Temp\WER3A60.tmp.WERInternalMetadata.xml
    C:\Users\preferred customer\AppData\Local\Temp\WER4F0A.tmp.appcompat.txt
    C:\Users\preferred customer\AppData\Local\Temp\WER5B89.tmp.mdmp

    Zotero Error Report ID: 715258827

    This is the Debug Output

    [JavaScript Error: "NS_ERROR_NOT_AVAILABLE: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIXPCComponents_Utils.import]" {file: "resource://services-common/kinto-http-client.js" line: 61}]

    [JavaScript Error: "The RPC server is unavailable.


    [JavaScript Error: "uncaught exception: The RPC server is unavailable.


    version => 5.0.54, platform => Win32, oscpu => Windows NT 6.1; WOW64, locale => en-US, appName => Zotero, appVersion => 5.0.54, extensions => Zotero LibreOffice Integration (5.0.14.SA.5.0.54, extension), Zotero Word for Windows Integration (5.0.8.SA.5.0.54, extension)

    My PC's details:

    Windows 7 Professional
    Service Pack 1
    Processor Intel Core i7 CPU q720 @160 Ghz
    Installed Memory (RAM) 12.0 GB
    64 bit
  • Further, I closed one document (the outline which is almost always open when I am writing) and opened another one, and it crashed again. Then I opened only one document, a new one, without a citation, and added a citation, and it did not crash.
  • edited September 18, 2018
    Hi there,

    I am also having an issue with Word crashing. I have experienced what others are describing with it crashing when multiple Word documents are open but seems to be ok with only a single document. Has there been any confirmation that this is the actual problem and not just a coincidence? Thanks!

    P.S. I previously applied the recommended patch, but it did not seem to make a difference (still crashed).
  • Thank you so much @meichler ! I really appreciate your writing, especially because I feel like at least at first @bwiernik, and @adomasven et alia were not taking my claims that the problem was systemic rather than episodic very seriously. Now, as this thread demonstrates, this Word problem is a "high priority" as it very well should be! Are there any new developments? I posted all the code above that they requested but heard nothing from them. Sigh.

    I am not quite sure where to go from here on this issue, however. I do not want to leave Zotero, but can only have one document open at a time on my laptop. ON my desk top it appears to work better for some reason. I am planning on buying a new computer with upgraded software soon, and will see if it works better. Any new information would be greatly appreciated.
  • @taylorspencephd I'm afraid there are no positive developments on this front. Over the past year I have spent many hours, probably days, trying to reproduce the crashing without success and attempting various fixes with the community with no solution that helped. I've reached out to Microsoft with user logs, but they haven't been any help either. We're reacting to any new information that emerges on this, but the only certain way to get this fix is for someone to find steps to reproduce the crashing consistently.
  • Dear @adomasven thank you for your response, and all your efforts. In a strange way, this all makes me feel a bit better, knowing that what I was experiencing was a serious and as yet insoluble problem.

    I was wondering if the age of the documents might be a factor? I have been working on one project for more than 10 years with zotero. When I (and others) say they have multiple docs open, these can in some cases be of varying ages. They can also have sections of zotero code copied an pasted from extracting sections from older docs into new docs. I wonder if this is a factor?


  • Age of documents is a highly improbable cause. Number of citations could be. But it's weirder than that. The crash reports suggest that it's crashing in a different location of the Word runtime everytime, even for the same users, which suggests that it's some sort of memory leak bug in Word that eventually leads Word to crash on attempting to access parts of the document that it corrupts in memory.
  • @adomasven Thank you for continuing to look into this issue! I thought I would chime in again because I have had Word crash with even a small number of citations. The most consistent crash factor I seem to experience is having the multiple Word files open simultaneously, which in my line of work is very common. Not sure if that helps but I'm really hopeful for a solution soon!
  • @taylorspencephd and others: If you're still experiencing this, can you install the latest Zotero beta and let us know if that makes a difference? (It may not, but since we're unable to reproduce this ourselves, we'll need help debugging this.)

    Your existing data won't be affected by upgrading to the beta. The beta is currently identical to 5.0.57 other than a modified Word plugin.
  • I have just recovered from a very consistent series of Word 365 + Zotero 5 crashes (both up-to-date). It manifested by freezing Word either on saving the document or after a few edits not even related to Zotero fields. I am certain the issue first appeared after updating from Word 2016 to Word 365. I narrowed it down to a particular document that I collaborate on, so it seems that there were many factors that could have affected the Zotero fields, e.g. my colleague could have been using version control, even though he is not using Zotero as I am managing the references.

    Eventually, I have recovered from the problem as follows.

    1) I started Word into a safe mode (press CNTR when starting Word) to determine that it was really the interaction between Word and Zotero that was the culprit. When Zotero plugin was disabled I was able to edit the document without any problems. If you have any active tracked changes, it is best to accept them all while in safe mode (this may or may not corrupt your Zotero fields, if so these fields have to be deleted), then switch off tracking of changes, save the document.

    2) Next I started Word normally, opened the document and did four things without touching the document contents (which caused the freeze): (a) I switched to Word "web view", (b) in Zotero preferences disabled Zotero automatic update of citations, (c) now I deleted the bibliography at the bottom of the document (probably not needed), (d) and ensured that Word tracking of changes is off.

    3) Then I created a new document, set its Zotero preferences and styles as required (I actually used exactly the same as in the previous document. Then I disabled its auto-update, switched to the web view, and tracking of changes to off as well.

    4) I copied the old document into a new document, one section at the time, saving into different versions and testing it by switching into print view and generating the bibliography.

    Interestingly, there were no Word freezes in the process and the new document is editable with Word and Zotero plugin.

    Good luck.
  • I am having this issue today! I will try the posted links... just wanted to log the issue, in case others are still having troubles. I'm taking comprehensive exams this week and it started just in time >D Now I make sure to save my document after each line I type...
  • Hi everyone,

    Has there been any improvement/new solution for this? I have been using Zotero for years but this is happening to me only recently. This is really disappointing. I tried every solution suggested in this string to no avail.

    Zotero Version:
    MS Word Version: 2016 (16.0.5188.1000)
  • @Aiyoub This is not a consistent problem but rather one that comes and goes with Word version changes, and also could be triggered by certain document formatting or element. Please create a new thread and describe in detail the crashing that you are observing and whether you can trigger it in a new document.
  • I have this problem, tested so many different solution at the end to handle it, I open blank word and cite there and then copy with merge formatting to my main article.
Sign In or Register to comment.