Zotero and one drive issues

When I am working on word documents stored in OneDrive, I receive an error message when trying to add citations, update them or refresh the document:

'Zotero experienced an error updating your document.

Would you like to view troubleshooting instructions?'

I have tried all of the troubleshooting steps and none of them have worked. When I create a new document outside of OneDrive the citations work but I need to work on the document within OneDrive as it is across several different devices.

The debug ID is D1900877148
  • @adomasven will need to look at this. People have reported problems with files stored on OneDrive before, but we haven't been able to reproduce the problem ourselves.
  • @zot12345 Does it help if you move the document into a folder on OneDrive that does not have any spaces? Make sure that the full path does not contain spaces.
  • @adomasven Thank you for your response!
    Do you mean that I should change the name of all my folders to have no space in the title?
  • No, this is just debugging. Adomas is just asking whether you can reproduce the problem with a document with no folders in its path (i.e., the containing folder or any folders above it).
  • Sorry, this was indeed a bit vague. I meant, no space symbols (" ") in the path. The filename can have spaces, but the folder path to the file should not have them.
  • edited December 5, 2019
    I am having this issue as well. I moved my .doc file outside of the onedrive folder and zotero appears to have access. One issue is that I have shared links to collaborators. My base onedrive folder has spaces in the name (by default) so changing the name of an early folder in the path may break the link for my collaborators.
  • @Mike_1234 Could you download the RotView software here (the download link is at the bottom of the page), open the document stored in OneDrive where Zotero does not work in Word, find the line in RotView listing the document (it will have a full and take a screenshot of it (you cannot copy in RotView). Then upload the screenshot somewhere online and paste a link here?

    After that could you produce a Debug ID from Zotero for a failed doc operation?

    1. In the Help menu, go to Debug Output Logging and select Enable.
    2. In the Document press the Add/Edit Citation button and click through any error prompts that appear.
    3. Before doing anything else, return to Help → Debug Output Logging and click Submit Output, which will disable logging and submit the output to zotero.org. A window should pop up containing a Debug ID. Click “Copy to Clipboard” and paste the Debug ID into this forum thread.
  • I also had this problem on my first attempt to use Zotero (just now, actually), so I moved my file to a local folder and it opened ok. But, as Mike_1234, I also need to work in OneDrive. Fortunatelly for me, after I opened Zotero in the local copy, closed Word and the local file, openned the OneDrive file and tried Zotero plugin again, it openned. Why? I don't know.

    But sometimes life is a bitch, and, despite Zotero openned, when I tried to insert a generic reference just to test, it located the reference but didn't insert, offering to open the Troubleshooting Instructions again.

    Now, here i am in the row waiting and hoping for a solution.

    I use Win 10 64 Bits and use Office 365 (I don't know if it's also a product line out of Brazil), but I think it is.

    Hope you guys can solve this issue, because OneDrive and similars are more important than ever.

    Congrats for this huge work called Zotero!
  • edited December 9, 2019
    The debug ID is D1268085576.

    You can find the Rotview output screenshot at

    Thanks for working on this.
  • @Мike_1234 Could you test the same file in OneDrive with the following permutations and report which ones work:

    1. Filename has spaces, but folders leading to it do not
    2. Filename has no spaces, but folders leading to it do
    3. Both filename and folders leading to it have spaces

    It does not matter which folder leading to the file has spaces, as long as at least one of them do. By "has spaces" I mean there are spaces in the name of a folder or file.
  • edited December 12, 2019

    Unfortunately, my organization sets the top level directory name in onedrive. I cannot change it so that it does not have spaces. When all deeper directories have no spaces and filename has no spaces, I get same error.

    1. Unable to test
    2. Received "Word could not communicate with Zotero" error.
    3. Received "Word could not communicate with Zotero" error.
  • I've been using the Zotero plugin with OneDrive for ages with no problems, but when I tried changing all the references to a different format today I got an error msg. I read the troubleshooting suggestions (thanks for providing the link to those with the error message!) and saw the OneDrive issue. When I moved a copy of the original file to my desktop and tried converting the references again it worked perfectly. I've moved it back to OneDrive and it seems to work OK - so I'm just leaving this here since the troubleshooting said to please leave a note on the forums to help with debugging!

    Both the folder name and the filename have spaces. I'm on a Mac, the os is 10.15.2, and I'm using the Zotero plugin with Word.
Sign In or Register to comment.