install zotero 5.0 on Ubuntu

I updated the firefox connector and now I need to install the standalone 5.0 on my Ubuntu.
I understand I have to use the tarball; however, I do not fully understand the following instruction:
" Alternatively, on Ubuntu-based distros, move the directory to a location of your choice, run the bundled set_launcher_icon script to update the included “Zotero” desktop file with the full path to the bundled Zotero icon, and then double-click “Zotero” directly or symlink zotero.desktop to ~/.local/share/applications/ to add it to your launcher."

I moved the directory and I tried to run the script with ./set_launcher_icon inside the directory, but nothing happens. I think I am missing something about that "with the full path to the bundled Zotero icon"

Anyone can guide me through this installation?
  • ./set_launcher_icon just updates the desktop file for you with the location of the folder — you don't have to do anything else other than double-click on the Zotero entry (which should now have an icon).
  • that is the point: there is no icon. Where the icon is supposed to be? I use Ubuntu with unity and if I write "zotero" in the dash nothing is found
  • I double clicked the icon inside the folder and worked. I blocked the icon on the launcher so I do not have to search for it every time. Still, I cannot find it with the dash. Fortunately, we are going back to Gnome soon!
  • One more question: now I can start zotero standalone from my Unity launcher. But what if I want to use it in a dwm or wmii session? I do not have the launcher there, and I do not have icons either! How can I start it from the terminal?
  • Here is how I did (Ubuntu 16.04 LTS, Gnome version).
    Assume you downloaded and unpacked the directory Zotero_linux-x86_64 in your home directory. First, move it to /opt (that's my personal choice, but you can put elsewhere as well):

    >> sudo mv Zotero_linux-x86_64 /opt

    Then create a symbolic link in /usr/bin:

    >> sudo ln -s /opt/Zotero_linux-x86_64/zotero /usr/bin/zotero

    Check that everything was OK:

    >> which zotero

    Finally, just start Zotero from command line:

    >> zotero

    This will start the stand-alone program, which you must configure. Good luck

  • the problem with this is that you need to run Zotero as sudo to update it, which isn't ideal if you can avoid it. For single-user computers, installing Zotero somewhere in ~/ makes your life easier.
  • edited January 17, 2018
    and can one add a link to the start menu? I am using xubuntu...

    I want to do that because I typically launch stuff with synaptic (a launcher) that scans the start menu...
  • This script will download and install zotero. It includes a launcher shortcut with icon:
  • @scorretti Thank you. It worked perfectly!
  • In Ubuntu 16.04, if you'd like to have a nice Zotero icon in Unity's Applications tab, you can do just what @scorretti says (thank you, once more!) and THEN go with

    ~$ sudo ln -s /your_zotero_dir/zotero.desktop /usr/share/applications/zotero.desktop
  • There's no need to sudo should you be on a single user system, linking it to ~/.local/share/applications will then do the same.
  • edited May 29, 2019
    I don't have strong feelings about where the Zotero program files should be placed, but one small note concerning @adamsmith's comment above:
    the problem with this is that you need to run Zotero as sudo to update it, which isn't ideal if you can avoid it. For single-user computers, installing Zotero somewhere in ~/ makes your life easier.
    Under Ubuntu, at least, in the steps outlined by @scorretti (i.e. unpacking in the home directory, and moving the program directory to /opt with sudo mv Zotero_linux-x86_64 /opt), the owner of the home directory will also own Zotero_linux-x86_64 and the files under it, even after the move. Auto-updates should work fine so long as Zotero is run from that account.
  • I followed the installation instructions as suggested by the zotero crew under installation for linux/ubuntu. I have the icon in the App menu i.e. the symlink ~/.local/share/applications but it won't launch the program. If I open file under /opt/zotero (thats where I put files) it runs.

    Then, I tried the suggestion by aewillsf and placed the symlink to zotero.desktop in /usr/share/applications.The icon is there, the program doesn't start though.

    What can be wrong?
  • I am running Zotero on Ubuntu 16.04.


    [Desktop Entry]
    Comment=Open-source reference manager (standalone version)

    If I go to Ubuntu topbar left ... right click on small Ubuntu icon ..
    I see Edit Menus in drop down.

    My Zotero launcher is in category Other.

    I right click Other and navigate to Zotero and select Properties.

    This launcher shows ...

    Name: Zotero
    Command: /opt/zotero/zotero

    Click on the icon frame .. it might be empty .. and navigate to where you have the zotero icon.
    You can now launch Zotero from Other category.
  • Hi to all,

    I changed the command from the icon (something like "bash path dir zotero %U") to "/opt/zotero/zotero" and it works now.

    thx @drangonfly

Sign In or Register to comment.