No PDF downloading on Wiley


I'm trying to download this open access paper including the PDF

but the PDF will just not download. Trying it with any other paper its always the same.

Debug-ID: D273405513

Any advice would be helpful!

  • Further details:

    I tried with Safari and Firefox.
    I tried downloading Open Access papers, no log in.
    I tried using university proxy and VPN.
    I tried through Shibboleth.

    Following papers I tried downloading:


    Open Access > NO

    Free Access > NO

    Full Access > NO

    Biological Review

    Open Access > YES > YES > YES

    Full Access > NO
    and any other > NO

    NO = no PDF was downloaded
    YES = PDF was downloaded

  • I'm also having trouble with Zotero getting the PDF from Wiley journals
  • Thanks; we're looking into this, the ticket is here:
  • Any updates? I'm continuing to experience this problem
  • edited September 30, 2019
    Is their any chance this problem can be solved in the nearer future?

    Since four weeks it's a tedious work to get Wiley papers into Zotero. Wiley is one of the major science publisher and I find it hard to understand that not more people encounter this problem. I'm working for an research group and when it took before some hours a week to check and download our needed Wiley journals it takes nowadays nearly one day.
  • OK, this should now be fixed. Your Zotero Connector should auto-update within 24 hours, or you can update manually by clicking Update Translators in the Advanced pane of the Zotero Connector preferences.
  • It's working again.

    Many thanks, that's really better now!
  • Hi,

    I'm having a similar issue: I cannot retrieve PDF from the Zotero connector on Wiley journals, even though I have access through my institution (proxy).
    For example on this page:
    or on that page:

    But when I login into the Wiley online system (personal account because I am member of a society that edits Wiley journals, and membership grants me access to those journals), then I can get the pdf from the Zotero connector.

    Debug ID is D512119758
  • An example like this:
    redirects to
    but should go instead to

    Because it doesn't go to the epdf directly, the bulk downloader for Zotero doesn't find an article like that.
  • Not sure what you mean here -- I get the PDF attached from just fine through a proxy, so this isn't a general problem. Zotero also doesn't do any redirecting beyond inserting the proxy.

    If this doesn't work for you, could you tell us exactly which steps you're running through and where you're saving from, plus a debug ID from Zotero (not the connector)?
  • If I go through a proxy manually, the download works perfectly, but when trying to download many articles at once, the proxy redirects to the abstract, not to the .pdf file, meaning that I have to download each article one by one. When you are writing a textbook with several thousand references, that just is a royal pain.
  • OK, so when you're looking at whole issue pages like PDFs aren't attached for multi-downloads.

    That's a less obvious problem than just redirecting to the wrong item page (which wouldn't matter -- Zotero has specific code for identifying the PDF from the abstract page), possibly active measures by Wiley to prevent this, but we can take a look.
  • Yes, it is a less obvious problem, but one that Zotero ought to correct if it wants to create value for its customers.

    Wiley and all the publishers have active measures to prevent downloading of many articles simultaneously. This makes Zotero's usefulness far less than it ought to be.
  • actually, having tested again, the above works fine for me for multiple PDFs (I just had a default setting in the preferences turned off), so we'd need exact steps to reproduce _not_ getting PDFs either from the above issue or from another multi-download pages, together with a debug ID from Zotero (not the connector)
  • I am now also unable to download PDfs from Wiley journals. I followed your instructions and got this debugging ID D868335983

    Would be very grateful for some help here.
  • What URL (exactly as you see it in the browser)?
  • edited October 30, 2021
    @qtnvbud: You seem to be using Find Available PDF manually in that debug output. That's not what this thread is about. For non–open access files, Find Available PDF won't work unless you're on a direct or VPN-based connection with access to the file (and if it was going to work, it would've worked when you originally saved the item — there's no point in running it manually later if your access hasn't changed). If you use a web-based proxy in your browser, that doesn't help with Find Available PDF in any way. If you're getting a red X for the PDF during the initial save using the Zotero Connector, we'd need to see a Debug ID from Zotero for the original save attempt, not for trying to use Find Available PDF.
  • Hi Sorry I'm really not knowledgeable on this at all. I have full access via my institution. When I do as I normally do and click on PDF link on the site where the paper is, then it comes up and then I go to Zotero connector and it downloads it. Then I can read it and highlight and extract annotations. Can you explain why I suddenly can't do this for WIley papers? It's been fine for a year? Imagine you're explaining it to a kid and I might have a hope of understanding it. Needless to say my PhD is not in computer science. Thanks so much
  • edited October 30, 2021
    You're using a web-based proxy that you log into in your browser. The Zotero application itself has no access to that, so showing us debug output where you used Find Available PDF in Zotero is totally irrelevant — and that process is run automatically when you save from the Zotero Connector if no PDF was available, so running it again is redundant anyway. See the original blog post for that functionality for more details.

    As I say, if you're not getting a PDF when you save from the Connector, we need a Debug ID from Zotero for that process, not for running Find Available PDF manually. You also should say whether you're seeing a red X for the PDF in the save popup or it just isn't trying to save a PDF at all.
  • I also just tried it again and yes, I'm getting a red X for the PDF during the initial save using the Zotero Connector, this is the ID dug D808488741

    Does that help - sorry but I don't really know entirely what you mean.
  • edited October 30, 2021
    That doesn't show a save attempt. You need to start debug output logging, reload the page in your browser, click Save to Zotero, and trigger the error again. If you just clicked the save button without reloading the page, it would've just reopened the save popup without trying to save again.
  • Ok I did that

    this the ID I got D798880504
  • <title>Just a moment...</title>
    You're getting some sort of intermediate page instead of the PDF, though it's hard to say where it's from. If you've saved a bunch of items, it's possible you're just being rate-limited by Wiley and will need to wait.
  • I normally do it this way and as it happened on the first Wiley paper I don't think it's a wait limit, UCL have no limits. I did the debug again if that helps? ID: D1474445129
  • I have just looked at this discussion as this is happening for me, I add an article to zotero through the URL or the DOI and then instead of getting a pdf i get a link icon with no way to add a pdf, as I annotate pdfs on zotero this is causing a problem with any articles on wiley. Is there a way i can get around this?
  • @LauraP81 is this just happening on Wiley or more generally? If more generally, we'd want some sample URLs. Also make sure you're adding the article from the browser, not using add by identifyer
  • I can confirm that this is an issue similar to what was reported for ScienceDirect, at least in the Zotero beta app for iOS. On e.g. this page saving stalls due to not being able to fetch the PDF. In fact, I tried it without even having access to the PDF, but the article cannot be saved by Zotero even without the PDF.
  • I've not been using the function for long so have just noticed that it's not bringing through the pdfs. Here is some of the urls -

    I have tried only inserting the URL and then the DOI and each time it does not bring in the pdf, I've made sure I'm logged in through my uni so that I can access the full article too. Thanks.
  • The same paper can be saved via PubMed, although the PDF has to be added separately.
    Example: Zotero iPad saves via this link
    But nothing happens via
    Conclusion: currently saving from Wiley is dysfunctional in the iOS beta app. (Similarly to ScienceDirect)
Sign In or Register to comment.