Anyone else getting constant hanging w/ Zotero 5.0.61 on MacOS Mojave?

Did the 5.0.61 update cause any issues w/ the standalone Zotero on MacOS Mojave for anyone else? Since updating my software, Zotero been functionally unusable on my machine – anytime I click on any menu, or any record, I get a beachball hang of 1-3 seconds (moving through records seems to make it worse).

My library is fairly large (9k items), but that's produced some slowness before on startup, but nothing like this.

I think it may have something to do with syncing, as when I unlink my account, or turn off wifi, the problem doesn't seem *as* bad, though still present. Changing sync options - to download files only "as needed" – doesn't seem to help. My next move, I think, will be to try and break my records into separate databases/profiles, and see if lowering the item count helps.

Any thoughts on how I might address this would be much appreciated!
  • What you are experiencing is not usual and possibly unique to your machine. There are many Mac users who do not have this problem. A beachball hang of several seconds when taking any action is so annoying that this forum would be filled with comments. If this problem continues after you restart your Mac, you should provide a debug number and report it here.
  • I think this shouldn't be the case anymore, but see if collapsing the tag selector on the left has an effect?
  • @adamsmith An open tag selector has little impact even on our older under-powered MacBooks and hasn't for several beta updates.
  • @DN: Let's debug this further before you do anything drastic. Can you provide a Debug ID for an operation that's slow?
  • Yes, I have the same problem. It recently got slower and slower, and has now become unusable. I can start Zotero, but if I try to add a book (or anything) it hangs up before I finish - which is to say it stops responding to any key or mouse clicks at all. That means I also cannot get a report ID after the problem occurs. The only way to exit is force quit. I have tried a complete system reboot several times, but that does not fix the problem.

    I have a ReportID of 1899247114, produced immediately after a restart, so there are no error messages in it. Does that help?

    I am running Zotero 5.0.61 on OSX Mojave 10.14.3. It is an iMac with 32 Gb memory and a 1.2Tb Fusion drive. I have been using Zotero for about 5 years with very few problems and have come to depend on it for my PhD thesis! I have about 6600 records.
  • We'd need a Debug ID — not a Report ID — for an operation that's slow. If Zotero is freezing and preventing you from submitting debug output, on macOS or Linux you can log to a terminal window instead, save the contents, and email a ZIP of the text file to with a link to this thread.
  • edited March 11, 2019
    OK. I am running the command-line debug now. It seems to be running indefinitely and repeating the similar output over and over, like it is in a loop, or perhaps spending a minute on each item in the library? Unless I break it off, I will have to leave it running overnight!
    Will it give me a DebugID eventually, or do I not need one by this method?
  • Sure, you can send what's there.
  • And I'm actually curious about the answer to the tag selector question, not because it necessarily still causes performance problems in general but because one of the biggest changes in 5.0.61 is a rewrite of the tag selector code.

    If you are seeing this, does it go away if you revert to 5.0.60?

    Download link: Zotero 5.0.60 for Mac
  • @AndySymons: The debug output you sent mostly just shows a sync process. Can you temporarily disable auto-sync in the Sync pane of the preferences and try again? We only need a couple minutes of output — which may be blank — while you're seeing hanging. (I'm also guessing this is the same as the problem reported in another thread where Zotero is using 100% CPU for some people.)
  • @dstillmann. Thanks for looking at it so quickly! Before reading your post, I did reproduce the hanging situation, albeit with sync still turned on. Can you see something useful in the last few minutes of log file 2?
  • Yes, after restarting Zotero normally, I am also getting 106% CPU usage!
  • With auto-sync enabled or disabled?
  • I tried restarting Zotero to do the test with sync off, but when starting normally, it was immediately unresponsive, so I could not do anything.
    I tried again starting through Terminal. Though slow, there was some response so I tried turning off automatic sync. However, by the time I did it, it was already syncing, using CPU and interfering with everything else, so I had to force quit it.
    Is there a command-line option for turning off sync?
  • edited March 12, 2019
    You might be able to just hit the stop button next to the sync icon in time.

    Failing that, you can close Zotero, open prefs.js from your Zotero profile directory in TextEdit and add this line:

    user_pref("extensions.zotero.sync.autoSync", false);

    Then save the file and reopen Zotero.

    It looks like you have thousands of attachments in your library that are missing files and for which files are also missing in your online library. Zotero is trying to download those, which is normal, but it's possible that's somehow causing high CPU in the latest version.

    If you're able to get to the settings, are you able to fix it by setting file syncing to sync files "as needed" (rather than "at sync time") but leaving auto-sync and file syncing enabled?
  • edited March 12, 2019
    I reverted to version 5.0.60 for Mac, as you suggested, and confirm that this version works normally. Thanks! I can work again. :-) Do I have to do anything to stop an automatic update to 5.0.61? (There does not seem to be an auto-update option).

    FYI, CPU usage is under 1% when idling. It went up to around 60% for a minute or so when I pressed the manual sync button.
  • Merging with the other thread, since I can reproduce this:

    Thanks for your help.
This discussion has been closed.