Zotero consuming >100% CPU Mac OS X

In the last week Zotero has become unresponsive when I attempt to use it. I opened Activity Monitor and discovered that Zotero is using >100% of CPU capacity. I have recently paid my annual fee for augmented storage, and I have been adding to my library at less than 5 items/week.

MacBook Air Early 2015, Mojave 10.14.3, CPU memory 8 GB. Zotero 5.0.61.
  • Update: After a period of some minutes (15?) Zotero settled down, consuming <10% of CPU, and is now responsive.
  • Zotero should consume approximately 0% of CPU when not being used.

    If you've been adding items primarily on another computer, this could've been background indexing of full-text content that was synced from the other computer, though that should stop if you actually start to interact with it.

    If you see this again, a Debug ID for a few minutes of the high CPU usage would be helpful.
  • Same for me. It seems it started after upgrading to 5.0.61 yesterday. Using 100.6% CPU (sometimes 120%), very slow response, in fact not working. Debug output D115909831 sent. Mac OSX Mojave 10.14.3, Otherwise great program, use it every day :-)
  • @ewn: That shows an ongoing sync. We'd want to see a Debug ID for when a sync wasn't running.
  • D622500348 The sync wheel was now not running
  • So in the 45 seconds since the sync ended, you were getting 100% CPU without interacting with it at all?

    Does this change if you close the tag selector in the bottom left?
  • Without any actions, after some time, CPU is now btw 0 and 12% , D999502157. I will restart with debug once again.
  • The same happens. D1076861925, 100% CPU and not able to use Zotero, spinning wheels all over.
  • edited 13 days ago
    That's again showing syncing. Can you temporarily disable auto-sync in the Sync pane of the preferences and then provide a Debug ID for a minute of high CPU? I'd also still want to know the answer to my question about closing the tag selector.
  • Done. D282597733
  • edited 13 days ago
    That's still showing syncing, and you should see the sync icon spinning to indicate that that's happening. Can you make sure auto-sync is disabled and then restart Zotero and try again? Make sure you're still seeing the high CPU usage during the time that the logging is running.
  • strange, "Sync automatically" was disabled, and no green arrow-wheel in the upper right corner was running. I will restart after unchecking all sync options in the Sync Preference pane.
  • Then CPU usage is btw 0.3-9% and Zotero seems to work normally
  • Can you get this to happen again by syncing manually with file sync disabled? How about with file sync enabled? (Turn logging on when you try each in case there's something worth submitting, but clear the output before each attempt.)
  • And now, after re-checking all the options in the sync preference pane, CPU drops to < 1 % when not in use, and Zotero can be used without spinning wheels during sync with 140 %CPU as well. So far, the restart with all sync options unchecked seemed to do the job. I hope it will last. Thank you.
  • Disabling auto-sync was just for clearer debugging, and it's much better to leave that on, so you should determine if this still happens with normal settings.
  • I also had this problem with Mojave 10.14.3 and Zotero 5.0.61.
    I fixed it by reverting to Zotero 5.0.60.
  • OK, thanks for the help — I'm able to reproduce this, so we don't need any further debugging. It seems to be triggered by file syncing. If you change your sync settings to download files "as needed" for now, this should go away. You can leave auto-sync and file syncing enabled. I'll post here once a fix is available.
  • OK, this is fixed in Zotero 5.0.62, available now. It was a regression in 5.0.61 that showed up if 1) file syncing was running, 2) your library had a large number of unsynced or missing files, and 3) you were in a view with many tags (and, judging by the reports here, maybe 4) you were on macOS). Thanks to @ewn and @AndySymons for helping us figure this out.

    If you downgraded to 5.0.60, you can update to 5.0.62, and if you changed your sync settings you can set them back however you prefer.
  • OK, thanks!

    Updated to 62 and things are doing much better. CPU use from > 100% to <5% after <1 min from launch.
  • Thanks for the quick resolution on all this! 5.0.62 has helped make this problem go away; much obliged

    (following up here bc the thread that was about similar problems was closed)
  • I confirm that Zotero 5.0.62 is working for me with Mac OSX Mojave 10.14.3 (the current version)
Sign In or Register to comment.