How to installl Markdown here in zotero?

and it is metioned that there is a fork of Markdown here on

However I still don't how to install it in zotero, there seems no xpi on that github site. How can I install a addon in zotero without a xpi?
  • Thank you for comment, adamsmith. But I still got trouble. According to the instruction, to create the xpi is just zipping proper files. So I did it, here is the link contains the xpi file that I have packed

    But When I drag this xpi to zotero addon windows, I got "The add-on "%S" could not be installed. It may be incompatible with this version of Zotero Standalone.". What is wrong?

    How to do it correctly? I am on windows, using zotero

    Thank you very much.
  • So I only need to zip exactly these four things? I did it again, here is what I packed

    However, I still got errors "The add-on "Markdown Here" could not be installed. It may be incompatible with this version of Zotero Standalone."
  • That's at least the right error message ;). I'd have to look more closely. It's possible that that version of MD Here is no longer compatible, but maybe you just need to update the install.rdf (as you'll have noted, the fork isn't actively maintained in any way.)
  • Thank you very much for your concern of this matter. This add-on is the only way I know that can deal with mathjax in zotero's notes. Hope it could become a standard feature in future version of zotero
  • Have you tried in Firefox if this works? I don't think you'd be able to convert the MD to MathJax, given that the notes aren't enabled for MJ.
  • Problem solved. I just found the official version on github works, we don't need the fork version.
  • But the problem is that the "Markdown here" add-on is not compatible with zotero's note environment. We should be carefully to make sure edit all things in text mode. If one accidentally make some edits in "Markdown mode", when converting to text mode, the "Markdown here" add-on will warn that:

    "The rendered Markdown appears to have been modifed.
    If you unrender it, your changes since rendering will be lost."

    To sum up, the experience is not as good as editing on stackexchange site. Really hope zotero could make markdown a standard feature in the near future.
  • Confirming that the Markdown Here plugin still works with Zotero 5.0.34. Integration is still a bit awkward (as noted above) but the core functionality works as advertised.
  • I've installed Markdown-Here in Zotero Standalone using the NON-forked github. It seems to be working fine with previously noted limitations.

    If anyone else comes across this thread, I've made the xpi file available that I installed:
  • edited December 24, 2018
    Thanks for posting the xpi - I wouldn't have been able to try this otherwise!

    If someone has this working, I don't quite understand how to "edit all things in text mode" - are you editing in a text editor, converting to html, and then copy/pasting the source code?

    Also, does the options window work for you? When I try to open it I get "It looks like you are running an older version of Thunderird. Open the Markdown Here Options via the message window Tools menu." Thanks for any info.
  • Thank you Kevin!
    realtime99, you can toggle between plain text and markdown with ctl-alt-m. At least that is the only way I could get it to work.
    I am not sure about the options window issue.
  • edited March 2, 2019
    @lunastev, thanks, that did work for me. Unfortunately, it seems to work only when editing the note in the Zotero window, and not when editing the note in a separate window.

    Re: options, I mean that when I go to Zotero | add-ons | Markdown Here and press the "options" button, I get an options window that opens and then gives me that message, so I can't set options there. Maybe @kevintaylor will want to investigate to see whether it's possible to set options when using the add-on in Zotero.
  • @kevintaylor Thank you! It works for me.
  • @kevintaylor Thanks for making the xpi, I'm having the same exact issues as @realtime99. Not being able to access the options of the plugin. I get the exact same message as @realtime99
  • @adamsmith & @dstillman this an indispensable feature that has been requested since 2014, 5 years later we still have nothing. Are we going to see this implemented any time soon? There are plenty of options to have this implemented org-mode files, mathjax + tinymce, or even simpler just as service which takes any wrapped text inside $ signs and forwards it to and retrieves back the results, I don't know, something, at least is better than nothing.
  • (I don't work for Zotero, please don't @ me unless you know for certain a question is related to projects I specifically do work on; and if you do, be mindful that I do this in my spare time and phrase/tone accordingly)
Sign In or Register to comment.