move database to another drive/device on linux


I'm Using Zotero 5.0.47 on Linux Mint 18.3

I want to move the zotero database to another device where I keep all my program data together in a central location that is encrypted and easy to backup.

How do I do that in Zotero?

Preferences has an option to set the database Folder, but it doesn't accept anything that is not a regular folder on my home drive. No other devices, no soft links. The "select a zotero data directory"-dialog has options to select the home drive or the desktop (which is in the home drive anyway), and "other locations", which only shows the current device.

So how do I set a database location that is on another device?

  • What exactly do you mean by "device" here -- you should be able to select any currently mounted drive as far as I'm aware.
  • Hi Adam, thanks for replying!
    "Device" seems to be the word that Linux Mint uses for anything that in Windows would be called a drive, eg a mounted partition, an internal or extarnal drive, a virtual drive,...

    I can't select any drive or partition, actually they're not even shown in the "select data directory" dialog. I made a soft link to a folder on another drive, the dialog shows the link, but I cannot select it. The only directories I'm allowed to use - or that are shown - are the folders in my home directory, or the folders of the Linux file system (etc, var, bin, usr,....) that I can select by going through "other locations". Interestingly, the directory "media", where other drives are mounted, is not shown, so I can't use this as a workaround either.

    So no, I don't even see mounted drives, so I cannot select them. I can make a link to another mounted drive, but Zotero does not accept the link as a destination for the database.
  • I am looking at my Ubuntu 16.04 usage which is dual booted with Windows 10.
    I have Zotero Standalone 5.0.47 on Ubuntu
    I have created a separate NTFS partition named SHARE and its general purpose is to share content between Ubuntu and Windows.

    Thus the SHARE partition is a “device” in your Linux context.

    If I launch Zotero Standalone and go to Zotero Preferences

    Select a Zotero data directory

    a windows pops up showing the localhost file system ..
    but at the bottom of menu there is also ..

    + Other Locations

    When I click on that link I see all the devices which can be mounted/unmounted.
    I can create a zotero data directory in the SHARE device at /dev/sda9 in my setup.

    This is just an example.

    So my question is .. in Linux Mint do you see the menu item
    + Other Locations
  • Tnx for your reply Dragonfly!

    Your setup is quite similar to mine (dual boot, shared folder)

    Yes, I do see the + Other Locations menu item

    However, when I click it, it *only* shows the Linux filesystem (home, bin, var, etc,...). Interestingly, it does *not* show the /media directory where other drives/devices would be mounted. So I cannot access mounted drives by going through the /media directory.

    The options i have in the dialog are:
    - recent
    - home
    - desktop
    - + other locations, which only leads me to the linux filesystem on the current partition. No other partitions, no other drives, no other devices. I did doublecheck that all those other locations are indeed mounted, and they are. They just don't show up in the "select data directory" dialog.
  • Are you seeing the /media directory when you try to select a folder in another application (e.g., Firefox)?
  • Yes indeed, I do. In all other applications "+ Other Locations" shows all mounted drives/devices and the file system includes the /media directory with its mounted devices.
  • As a test you might try running this command in terminal ..

    mount | grep ^/dev
  • edited June 23, 2018
    I am having exactly the same issue using Zotero 5.0.51 on Linux Mint 18.3. The file manager has correctly mounted all drives, and all are accessible from other programs (like Libre Office, Firefox). However, in Zotero, + Other Locations doesn't even show other linux partitions. This seems to be an error.
  • Another report of this:

    For the people experiencing this, have you only tried Zotero from the Mint package manager, or have you tried downloading the official Zotero Linux build? If the Mint package is based on Flatpak, it seems entirely possible that the default package permissions simply don't allow access to other devices.
  • edited July 17, 2018
    ********* SOLVED ************

    Your suggestion solved the problem. I downloaded and unzipped the folder: Zotero_linux-x86_64, placed it in /user/local, and ran it from the command line.

    Now the /media directory is visible and I can browse to my thumb drive.


  • Yeah, so I don't know the details of Flatpak, but it'd be good to report this to the package maintainer, since I imagine there's something they can adjust to give Zotero access to other volumes.
  • Understood. Thanks.
  • Just had the same problem (kubuntu 18.04).

    I have my hd split into 3 partitions (root, home, files).
    My Zotero folder is on /files.

    I installed the flatpak via discover and the files partition wasn't accesible.

    This is the package:

    There you can already find:
    [NOTE] If your Zotero folder is not located in the default location (~/Zotero) and is outside your home directory, please grant the permission to access that folder by the flatpak-override command. (Usage: "flatpak override --user --filesystem=/PATH/TO/ZOTEROFOLDER org.zotero.Zotero")

    After entering this via konsole the chosen path was available in Zotero.

  • I'm also having that issue, but don't think I installed zotero from a flatpak.
    I'm running Linux Mint 19.? with cinnamon.
    My Data Dir is on the hdd at /mnt/Data/eben/Zotero
    but my app (standalone) is on the ssd in the / fs.
    I do see the '+ other locations' but when I choose that then 'computer' (the only option) I see an incomplete list of file system directories. /mnt isn't there.
    Why not?

  • don't think I installed zotero from a flatpak
    How did you install it?

    It's easy enough to check — download the tarball from the download page, extract it, and run ./zotero from there, and see if the problem remains.
  • Well, I looked in Mint's software manager and it assumed I'd used flatpak. Apparently its the default now. So I ran the command suggested and lo and behold, once the app was restarted, /mnt appeared.

    flatpak override --user --filesystem=/mnt/Data//Zotero org.zotero.Zotero
Sign In or Register to comment.