LibreofficeWriter/Integration / Extension for version 6.0

I recently updatet to Libre Office 6.0. Since then zotero doesn't work in relation to Libreoffice Writer. I tried to download the Extension but couldn't find any release on
Is it possible, that there's no extension / Integration for Libreoffice 6.0 ??
Would be happy about answers, because I'm actually trying to finish my thesis... :(
  • You don't download the plugin separately. It's bundled with Zotero and installed automatically, and if necessary you can reinstall it from the Cite pane of the Zotero preferences.
  • I can't reinstall it from the preferences, because there is no occasion to. There must be any kind of button to download, or what should I look for?
  • I'm not sure what you mean. What do you see in Cite → Word Processors?
  • Could you submit a Report ID?
  • The Report ID is 1934400053
    1. I'm german, so what I see in Cite->Word Processors is translated:
    "use old cite-dialogue" and possibilty to sign or not. No possibility to reinstall something
    2. I use Linux (Opensuse Leap 42.3)
    actually I went through all the steps I found following the link about installation error. I re-downoaded the Add in, that worked. I tried the Manual Installation of the libreoffice Add-in an got the following error-Information:

    ( { { Message = "javaloader error - could not find class com/sun/star/comp/loader/JavaLoader", Context = ( @0 } }
  • edited May 16, 2018
    appVersion => 5.0.34, extensions => Zotero LibreOffice Integration (5.0.8.SA.5.0.34, extension, disabled)
    You have 2 problems:
    1. Running an outdated version of the Zotero client, so you should begin by updating to 5.0.47.
    2. The LibreOffice Integration extension is disabled. For the record, you do not need to install anything into the Zotero client to make it work. If you have installed a plugin for Zotero 4.0 since submitting this report ID, you will need to remove it under Tools -> Add-ons in Zotero and restart the client, which will restore the version bundled with the client. You will also need to ensure it is enabled in the Add-ons screen (which might require an additional restart).

    After you've done all this, you should go into Zotero Preferences -> Cite -> Word Processors and (re)install the plugin into LibreOffice, which should make it work, as long as your LibreOffice has a working Java installation. The version of Java bundled with OpenSuse LO was broken a few months ago, so that might cause you some additional headaches. I am not sure what the current situation is, but users have found workarounds.
  • thank you for your help. I installed the ne 5.0.47. but it didn't work: the same error: ( { { Message = "javaloader error - could not find class com/sun/star/comp/loader/JavaLoader", Context = ( @0 } }

    No I read about a solution in the first link (Java bundled...). But, honestly, I didn't understand... Can you tell me what to do? Or should I contact Ulrich Windl?
  • You will need to install LibreOffice from their official website (after removing the one from OpenSUSE repositories).
  • That's exactly what I did. I installed the new LO from their official site... Should I repeat it?
  • Did you remove the version you had installed from OpenSUSE repositories first? You will also need to remove the JRE that comes with OpenSUSE and install it from Java's website.
  • I'm not as good in using the PC to find out these informations. I asked in the linux-opensuse forum and found out, that the only JRE that is installed is: jre-1.8.0-openjdk/bin/java
    Is this wrong or right?
  • i fixed the problem in a simple way!! i use fedora i installed zotero by adding the repository flathub and install by:
    flatpak install flathub org.zotero.Zotero

    this will install zotero the thing is the add on is present in the zotero tab but when u go in libre office--->tools--->extension manager u can find it
    i went back to zotero and i saved the extension as save as .txt then add it manually in the cite pan from prefrence in zotero it will prompt you to install add on close everything and reopen ur good :)
Sign In or Register to comment.