Word 2016 plugin not working

I have been using Zotero now for a few weeks. Suddenly today the plugin seems not to work. It shows as before in Word, but when I click on any of the buttons (add/edit a citation, refresh, so on) nothing happens, just the title of my document grays out. When I click again, the title become white again, but the window to insert the citation doesn't appear.
I have uninstalled and reinstalled Zotero for desktop and the word plugin, but no changes.
I would appreciate any help,
  • In Word go to View -> Macros. Do you see Zotero Macros listed? What happens if you try to run them?
  • @adomasven , thank for your response. Yes, all the macros are listed, but nothing happens when I run them. Any other ideas?
    Thank you very much
  • In Word Options go to Trust Centre Settings. What are your macro preferences set to?
  • It is set: Disable all macros with notifications.
  • Can you restart Zotero and immediatelly produce a Debug ID?

    1. In the Help menu, go to Debug Output Logging and select Enable.
    2. In Word click Add/Edit Citation and wait a few seconds.
    3. Before doing anything else, return to Help → Debug Output Logging and click Submit Output, which will disable logging and submit the output to zotero.org. A window should pop up containing a Debug ID. Click “Copy to Clipboard” and paste the Debug ID into this forum thread.
  • Debug ID- D2128124840
    However, this time for good or bad, it worked. When I clicked "add citation" the window actually popped.
    Thank you very much for all your help!
  • I have exactly the same issue and have done all the diagnostics suggested above. I have run the debug diagnostic and got: D1433218839

    Any help would be hugely appreciated!
  • @michelle%20Fletcher you have to restart Zotero before producing the Debug ID. Could you submit another one?
  • Sorry. Yes: D575967763
  • [JavaScript Error: "Error(s) encountered during statement execution: database disk image is malformed [QUERY: SELECT rowid, fileName, metadataJSON, lastModifiedTime FROM translatorCache] [PARAMS: ] [ERROR: database disk image is malformed]" {file: "chrome://zotero/content/xpcom/db.js" line: 703}]
    Your database is corrupt. You can try the Zotero database repair tool and see if that helps.

    Note that you should not store your Zotero data directory on Dropbox or similar syncing services, which is very likely to lead to corruption. Corruption may also occur if you store your database on a network drive and access it from two different locations at once, without shutting down Zotero.
  • Ok. Thanks. It's stored on the hard drive of my computer, not on any network drive, so that is very strange. I'll back up the data and try the fix. I've got 8 years of data on here, so don't want to lose it.
  • Hi, I have this problem. My debug diagnosis is: D414843896. I'd really appreciate your help!
  • @SofiaLopez: Start a new thread and explain the specific problem you're facing.
Sign In or Register to comment.