Zotero 5.0 Integration w Mac MS Word 2016

I've read through numerous threads regarding the integration of Zotero with Mac MS word 2016, have tried all of the offered solutions and still have not been able to see the Zotero icon in the toolbar in MS word to be able to add references. I have tried the following:

1. Re-installed the extension for word via the "Zotero->preferences->cite..." pathway, followed by re-starting word
2. Verified that the plug-in is installed on Zotero
3. Verified that Word recognizes it via the "Tools->templates and add-ins.." pathway, where the "Zotero.dotm" global template is present and checked indicating it is loaded
- I do have an old version of EndNote Cite While you Write there as well - not sure if that may be interfering...
4. Confirmed via the "Word->preferences->file locations->Startup.." path that the ~/Library/Group Containers/UBF8T346G9/Office/User Content/Startup/Word/Zotero.dotm file is present under the "startup location in "File Locations"
5. Opened the developer tab in MS Word to evaluate Macros - which do open and show 8 Zotero macros to be run, including NewMacros.ZoteroAddEditBibliography, Zotero.ZoteroAddEditBibliography, ZoteroAddEditCitation, ZoteroEditCitation, ZoteroInsertCitation, ZoteroRefresh, ZoteroRemoveCodes and ZoteroSetDocPrefs. I tried to select all and run, but it would only allow me to run one at a time. I tried to run "ZoteroInsertCitation" and a red toolbar did appear, which allows me to insert citations into word, but I would rather not have to individually select the macros each time I need to insert, add, edit or change a citation or bibliography.

I have also installed the chrome and safari connectors which work well when Zotero is open, but I despite all the above, including multiple word resets, uninstall and reinstall of Zotero, multiple computer resets, I still cannot find a way to integrate it into MS word 2016.

Any help would be greatly appreciated. Thanks!
  • @adomasven will have better advice on getting the toolbar to appear, but as a workaround you can create keyboard shortcuts for the addEdit citation macro, which is the one you'll mostly use
  • @mkryan6 Could you try the instructions in this post and report if that has any effect?
  • @mkryan6 : Have you solved the problem of displaying the toolbar icons (instead of selecting the macros) ? We face the same problem with a student. Thanks for your help
  • Have you checked the Word version? We've seen a ton of problesm with Word version before 15.38 and add-ons.
  • @adamsith Thank you for your responsiveness (as always). It's definitely a version 15. (maybe 15.38, I do not remember anymore ; I will ask her to confirm it by sending her your answer).
    At least it works with macros !
  • All Word 2016 are version 15, but older versions were buggy (she should be on 15.40, but the relevant bugs were fixed somewhere around 15.38)
Sign In or Register to comment.