"this.and.single is undefined" error

Hey I'm getting the same issue described in a previous discussion: https://forums.zotero.org/discussion/31859/citeproc-js-cannot-continue-citations-in-document

I see the errors "this.and.single is undefined" and "this['et-al'].single is undefined" in Microsoft word whenever I try to add a citation, in any document. I have tried removing and reinstalling the plugin, or Add-in. Was this issue ever resolved?
  • edited September 30, 2017
    This was broken by Firefox 56, and it's fixed in Zotero You can upgrade to that, but at this point we'd recommend upgrading to Zotero 5.0, since Zotero 4.0 for Firefox won't work at all for much longer.
  • Thanks much. I downloaded 5.0 and it works fine!
  • How do i upgrade to i could not find any update option in the settings/online. I downloaded the addon from the downloadpage
  • Click "Looking for Zotero 4.0?" on https://www.zotero.org/download/#

    Though again, it's recommended to just go ahead and update to Zotero 5.0, as Zotero 4 won't work at all for much longer.
  • Hi there, I am encountering the same problem using Zotero I went to https://www.zotero.org/downland/# to update to, but the version there still shows

    I also tried to set Zotero to update automatically, but it did not work either.

    I will love to upgrade to Zotero 5, but this is for a work computer where admin rights are controlled, and I am still in the fairly long process of obtaining approval. Thanks very much!
  • (Just to confirm that the version on zotero.org/download indeed is -- cc @dstillman )
  • edited October 6, 2017
    For those in a pinch, you can install the "Propach Vanilla" plugin from
    all that does is switch the citation processor in Zotero to the most recent version. It's a Firefox add-on, so you should typically be able to install that on a work computer.

    This is no longer needed. Zotero is now available.
  • The download page has been updated.
  • (I assume this can be unstickied as well?)
Sign In or Register to comment.