Proxies restored in 5.0.5 but wiped in 5.0.11?

Proxies were lost upon upgrading to version 5, but were subsequently restored as was confirmed here:

But with the latest update 5.0.11, institutional proxy settings have disappeared again (for me at least). Is this a simple matter of restoring them again, or are will zotero need to be 'trained' in again. Also, is it possible to backup proxy settings separate from the daabase or other preferences to avoid this in future?
  • There's no reason that should have happened. They would have gone away if you cleared your browser cache and settings completely, but if you had Zotero running, the connector should restore them. You can force the connector get the proxies from Zotero client again by going to the connector preferences, changing the last part of URL from preferences.html to config.html and changing proxies.clientChecked to false by double-clicking the pref and then restarting your browser.

    If they disappear again, please provide a Report ID from the connector as soon as you notice it.
  • Ah it would have been because I cleared the cache :-(

    I followed your instructions and the proxies were not restored - is this because that method only works if you have not cleared the cache?
  • You should make sure Zotero is running when you restart the browser. This method will only restore proxies previously saved with Zotero 4.0 for Firefox, but not any new ones associated using the connector.

    We're working on changes that will prevent cache clearing from deleting the proxies.
  • Hmm tried it that way too and still no luck. I guess I'll just retrain zotero. Good to know you're working on a fix though, thanks for your help.
Sign In or Register to comment.