Error when inserting a citation in Word using Firefox integration

  • Yes - get the message in a new document.
    Did anybody else have the problem sorted or do we need to resort to a different product?
  • Which setup (Zotero version, Word, OS is this on?) I'd probably just try installing the Zotero beta which might fix this at this point and is very stable now.
  • I have uploaded Zotero 5 Beta and I now get the message:
    Zotero experienced an error updating your document.
    An unhandled exception occurred (getDocument:document.cpp)
    I am using Windows 8.1 and Word 2013.
  • Do you have the document(s) in OneDrive by any chance?
  • The other cause of this we have seen are different ownership of Word and Zotero. If one is owned by an admin account and the other by a regular user account, I believe this could cause this. You could try as a test running Zotero as admin and see if that works.
  • Either way, you should submit a Debug ID for attempting a citation insert in a new document, which will give us more detailed info about what's going on.
  • Same for me when I try to work from the Word plugin:

    Zotero experienced an error updating your document.

    An unhandled exception occured. [getDocument:document.cpp]'An unhandled exception occured. [getDocument:document.cpp]' when calling method: [zoteroIntegrationApplication::getDocument]

    Zotero standalone:
    Windows 7
    Word 2013

    Debug ID: D520809123.
  • @psabou if Zotero works fine in a new Word document, then it's a separate issue, most likely fixed using the troubleshooting broken documents steps. If you still cannot get it to work in your existing document, but it works fine in a new Word document, create a new thread.
  • Doesn't work in old documents nor in new ones.
  • Ok, yeah, that's most likely the admin issue. Try running Zotero as Administrator and see if that fixes it.
  • I thought I didn't have administrator priviledge on my machine: turns out I do! And it solved the problem!

  • I have tried everything and logged a debug. I get the message in a new or old document. GIVING UP!
  • (FWIW, the debug doesn't help if you don't post the debug ID here)
  • I followed the debug instructions online?
  • After uploading the output, Zotero will provide a Debug ID (e.g., “D12345678”) that you can post to the forums. There's no need to post the actual debug output.
  • I didn't note the number.
  • yeah, sorry, we do need the debug ID to be able to say more (you can obviously log the problem again and create a new one if you're still willing to troubleshoot this) -- there are thousands of debug IDs being created every day; devs need to be able to match them to an actual problem described here like yours.
  • I'm not a techie and this is just to time consuming to pursue - will find another product! Thanks anyway
  • This happened to me too. I use word 2016 and windows 10. I solved the problem in my files by unchecking the "read-only" option. Before opening the document in word and Zotero, right-click on the file, click on properties, on the general tab, uncheck the "read-only" attribute. I hope it helps!
Sign In or Register to comment.