Adding Zotero database to a synced folder.

So I store all of my work files in a folder that is synced with a server here at my work through the program Syncplicity. I have stored my Zotero database in this folder too so that it is backed up with everything else. The problem is Zotero doesn't seem to like havin the databse synced and keeps creating duplicates, so my folder fills up with zotero.02-Work.sqlite, zotero.03-Work.sqlite etc.

I am wondering what to do about this - I can configure Syncplicity to exclude .sqlite files but I would rather have it backed up. Is there a recommended way of working with sync clients? Maybe I should just move my library out of the folder and back up manually.
  • One-way sync shouldn't be a problem normally and given the file naming, I'm pretty sure it's actually Synplicity, not Zotero, that's creating the duplicate files. I'm using sync tools (i.e. rsync) for my local back-up without issues, so I'm not sure why Synplicity (which I don't know anything about beyond its basic functionality) has problems.
  • edited November 30, 2016
    Ok, thanks. Syncplicity is more like Dropbox than rsync, it syncs files between computers, but it works from a network share hosted at my work rather than in the cloud. So it is not just a one way sync. Maybe that is the problem. It only happens when zotero is open so Syncplicity must make a copy like Dropbox does if a file is in use.

    I think I might have to move it and back it up manually.
  • OK, so I moved my Zotero data folder out of my Syncplicity folder. I left my Zotfile PDF folder stored there.

    I changed the data directory location (Zotero 5 beta standalone) to point to the new location and restarted, all good. Then I did the same in the settings for the FF plugin. But now the plugin isn't working properly. If I close Zotero I can use the Save to Zotero button fine, but if Zotero is running the button doesn't do anything. I tried reinstalling the plugin, still not working.
  • I tried everything - refreshing firefox, reinstalling the plugin, the save to Zotero button is now broken :(
  • describe "broken" as specifically as possible. Does it still provide information when you hover over it? Does anything at all happen when you click it?
  • When I hover over it, it says Save to Zotero (Web Page) even if I am viewing a paper that I have access to. It doesn't detect that the PDF is accessible so the icon doesn't change to the full text icon like it normally does. If I click the button nothing happens - I don't get the usual notification window telling me it saved the article/page.
  • I also tried resetting the translators
  • And you're using the beta for both Firefox and Standalone, right? Could you provide the version numbers for both?
    Have you restarted the computer? (The error suggest some sort of communication issue between Standalone and Firefox and restarting may help, so this isn't entirely desperation).
  • Yes, I tried restarting the computer.

    Standalone version: 5.0-beta.r85+8c48b2f
    FF plugin version: 5.0-beta.r83+1b67ed0

    Should these be the same build? I don't know how to update the plugin - firefox reports no updates found in the extension manager.
  • Thanks for your quick help to Adam.
  • The other button in the plugin works - the Z button switches to the standalone version. Just the save to Zotero button and that works sometimes when standalone is closed, just never works when it is open...
  • @Dan%20Stillman will have to weigh in. I'm not even sure how to get useful debug from Firefox running in connector mode.

    One more thing to check is to see what happens when you paste into the address bar of Firefox while Standalone is running and press return. You should get "Endpoint does not support method".
  • Thanks, yes I get "Endpoint does not support method" when go to that address.
  • edited December 2, 2016
    This will become easier soon with the switch to a connector-mode-only extension for Firefox, but for now you'd have to generate real-time debug output in Firefox to troubleshoot connector mode. You can then email that to with a link to this thread (or paste it here, if it's not too big). We'd want to see debug output for loading of a page that you expect to work, as well as a save attempt that fails.
  • Thanks Dan. I've left work now but I'll try this over the weekend and send the log to you.
  • Hi Dan, I've sent the log to the email address. See the email with subject "Problem with FF connector mode"
  • Should be fixed in the latest build (r87). Thanks for reporting.
  • Great, thanks a lot! The betas have been so solid for me, it never occurred to me that it was a bug. Thanks again.
Sign In or Register to comment.