Word intergration with wine

  • Answer to Fort Thomas:
    - backup somewhere the .wine/drive_c/users/%user_name%/Application\ Data/Microsoft/Word/STARTUP/Zotero.dotm (%user_name% is your user name)
    - copy Zotero.dotm somewhere where you can edit it (e.g. in you home directory)
    - open the copy from Word menu
    - go to view --> macro --> view macros
    - clic modify on any selected Zotero macro to edit
    - remove at line 146 & " -ZoteroIntegrationDocument """ & name$ & """"
    - replace at lines 162-165 Mozilla Firefox\firefox.exe
    by Zotero Standalone\zotero.exe
    - save the macro edition
    - replace the old Zotero.dotm with the new in .wine/drive_c/users/%user_name%/Application\ Data/Microsoft/Word/STARTUP/

    Check starting word and zotero.exe.

    I haven't checked every functionality in detail, but insert citation and bibliograpĥy worked for me with xubuntu 16.04, wine 1.6.2, Word 2007 (under wine), Zotero Standalone (under wine)
  • Good morning everybody !

    I have installed with playonlinux firefox 49.0.1, the latest version of zotero addon in firefox : zotero, and finally zotero standalone.
    Then I paste the zotero.dot file (downloaded here : https://drive.google.com/file/d/0B-FGaNOW8dnudEpuZDdnNnBVUmc/edit as seen previously) here : /.PlayOnLinux/.wineprefix/Office2010/drive_c/users/%user_name%/Application\ Data/Microsoft/Word/STARTUP/

    Then I run firefox, zotero standalone and word 2010. And i have the toolbar zotero in word. Perfect !

    But when i clic on "insert a citation" in word. Nothing happen...

    Here the screen captures :


    I don't understand how i can do. I think i've done everything correct !

  • I followed fdeboiss' instruction. The resulted Zotero.dotm works with wine 2.0beta1, Word 2010 under Wine, and Zotero Standalone under Wine.

    I have created a GitHub repository, and uploaded Zotero.dotm there. For Zotero Standalone, see https://github.com/xianwenchen/zotero-word-for-wine-linux-integration/blob/master/standalone/
  • Hey everyone, 5 years since I commented on this post with Standalone during my thesis writing :)

    Anyone had luck with Zotero 5.0 and word integration? I somehow upgrade my database to 5.0.

    I installed office 2016 with crossover17beta and runs. I'll look around and hack a bit if I'm given some tips.
  • Hi. I have a problem with Z5 under Wine. I had it working fine previously, but attempting to upgrade to version 5 caused a crash and Zotero/Wine no longer works. I tried uninstalling & doing a fresh Z5 install, but this also crashed. I could probably start again and go back to version 4, but I was wondering if anyone had Z5 working OK under wine?
  • A couple data points :

    * Zotero 5 installs and works fine in Wine 2.0.3 as packaged in Debian. BTW, WinWord also does).

    * Out of the box, Word doesn't seem able to communicate with Zotero.

    * A cursory inspection of Zotero.dotm shows that the current code still tries to launch Firefox & al. as alternatives.

    Curiously, LibreOffice (Linux version) is perfectly able to communicate with Wine's installation of Zotero.

    The point seems to be that Word still "talks" to Zotero over stdin/stdout, whereas LibreOffice uses another method (socket ?)

    I'll try (not to soon...) to patch zotero.dotm to see if I can get Word to talk to Zotero.

    But couldn't we get a plugin allowing Word to talk to Linux's Zotero ? It should be possible (unless the method used for LibreOffice really can't be implemented with Word...).

  • LibreOffice communication on all platforms occurs via sockets, which is why it would work across the wine boundary. Zotero talks to Word via OLE automation and Word talks to Zotero using WM_COPYDATA messaging.

    There haven't been any major changes to the communication protocol from Zotero 4 to 5, so the same patch should work with the updated template.
  • I just tested that indeed, porting the same modifications to the current zotero.dotm as for the previous versions of Zotero does indeed work. I'll try to post a more precise guide later ((I'm a bit in a hurry now...).

    Since the Windows versin seems functional inder Wine and is able to communicate (I've checked communication with LibreOffice and Chrome/Chromium

    However, my previous suggestion still stands : if it is possible at all, using the same communication mechanism for Word and LiibreOffice would allow (occasional) users of Word under Wine to use their Linux installation.
  • The approach still works
    Spec: Ubuntu 18.04, Zotero 5.0.54 Standalone, Office 2010 Pro, Crossover 17.5.0
    PS: Install zotero and office in the same bottle (for cross over users)

    - backup somewhere the .cxoffice/%bottle%/drive_c/users/%user_name%/Application\ Data/Microsoft/Word/STARTUP/Zotero.dotm (%bottle% is the name of the bottle created for you by crossover and %user_name% is your user name ... crossover uses crossover as default as of this writing)
    - copy Zotero.dotm somewhere where you can edit it (e.g. in you home directory)
    - open the copy from Word menu
    - go to view --> macro --> view macros
    - click modify on any selected Zotero macro to edit
    - remove the following & " -ZoteroIntegrationDocument """ & name$ & """"
    - replace the following substring
    Mozilla Firefox\firefox.exe
    - save the macro edition
    - replace the old Zotero.dotm with the new in .cxoffice/%bottle%/drive_c/users/%user_name%/Application\ Data/Microsoft/Word/STARTUP
  • Hi all. I have tried to follow the suggestions above useing crossover 18, Office 2016 and Zotero Standalone 5.0.59, but after applying the changes I get the following error

    "Zotero experienced an error updating your document.
    documentName is null"

    Seems as though office 2016 need the file name? I tried leaving
    & " -ZoteroIntegrationDocument """ & name$ & """" in the macro, but that did not work. Any suggestions would be appreciated!
  • "Zotero experienced an error updating your document.
    documentName is null" I also have the same issue, it would be great if there was a solution.
  • I've been happily running Zotero in Wine for years now (crossover office 18, Office 2010). But from 5.0.59 I too get the "documentName is null error"
    I've had to downgrade Zotero to 5.0.58 and now everything works again.
  • Where do you get the 5.0.58 download? I just updated to 5.0.60 and it did not seem to solve the issue either
  • edited January 23, 2019
    Thanks, got it to work, (for those who didn't know, you can just install the lower zotero version directly into old bottle and it will downgrade! ) Thanks a ton!
  • I guess we should file a bug as something has clearly been broken between the two versions - or being "unsupported" do we just not count?
  • I think its worthwhile, I mean there is no reason why they can't maintain old implementation for us to use in newer releases.
  • edited January 24, 2019
    So what seems to have happened is that our fix for random Word crashes when using the Zotero extension that has been plaguing us for a while broke Wine integration as a side-effect. We'll see whether we can maintain both the fix and Wine compatibility and update here in the near future.
  • Wouldn't it be faster, easier and cheaper to create a Zotero for Word on Wine Plugin by either :
    * replacing the Worg plugin's wire protocol (i.e. the part of the plugin that "talks" to Zotero) by the one from LibreOffice plugin ; or
    * replacing the LibreOffice plugin's interface to LO by a convenient interface to Word ?

    One could even unify the wire protocols of Zotero among platforms, thus allowing either plugin to "talk to" either Zotero implementation. The LibreOffice wire protocol,, which, if I understand it correctly, "talks" to Zotero through an IP socket, is probably the best candidate for unification.

    One could even envision a situation where the plugin (or, better, multiple plugins) would "talk" to a remote machine used as a server, without having to consider the platforms involved...
  • TOn Linux (Manjaro) here, trying to get a Word 2016 installation (crossover rather than playonlinux) talk to zotero (linux standalone), which did of course not work. I have now used crossover to install zotero 5.0.58 in the same bottle as word 2016, but that doesn't work, either. Zotero standalone (windows version) does not even start. I am usually happy working with libreoffice and zotero on linux, but have now been forced to edit a book with tons of zotero references in word, so I am quite desparate to get the whole thing working.
  • An alternative here would be to convert the document citations to Bookmarks (from Fields), save as .doc, then edit in LibreOffice. If extensive edits on citations are expected you should probably convert to ReferenceMarks and save the file as .odt temporarily, since citations stored as Bookmarks are fairly brittle and much more susceptible to accidental corruption compares to ReferenceMarks.
  • First steps with linux Mint Cin, I am also trying to connect zotero to word (office 365 installed via crossover). I am convinced by the importance of opensource etc but I lack time and above all basis to properly participate and I wish to open many of my studies reports (with zotero references and word figures) originally made on MS Office... I have zotero and firefox running perfectly on linux. I also installed zotero standalone in my office 365 bottle. This Zstandalone runs independently from the other "linux zotero" and firefox. Following the "manual Word Processor Plugin installation" (copying the .dotm file to startup folder -see zotero website), I now can see zotero icons in words; unfortunately, they don't work... wouldn't it be possible to tell word to go and look in a certain place and link this certain to the linux zotero? Many thanks for your help!
  • Oh no, I upgraded my database and used it extensively with google docs.
    Now I can't downgrade to 5.0.5* anymore. I am running 5.0.80 and I can't get it to work in MS Word with crossover. Did anyone have better luck? I really hate endnote and it will be my only working option with MS word in Wine. I'm sharing the document with some people and I have no choice.
  • @forevertheuni you can sync your database with your zotero account, delete the sqlite (after backup) in your Zotero home folder, downgrade and sync it back.
  • Thank you Daxid! That's great to know!
  • I did it in another way. I exported the library in the new version, and Imported in my wine copy in the old version. Thank you nonetheless. I hope the plugin works again soon in wine. If there's anything I can do to help let me know.
  • @forevertheuni: Exporting your library and reimporting will break all links to items in existing word processor documents, and if you sync you'll end up with duplicates of all of your items.
  • Hi Everyone, I've followed the suggestions above. And installed the 5.0.58 version, adjusted the dotm file, and I'm running with newly installed word 365 through crossover.
    The zotero ribbon appears in word, and the standalone runs. But when I click on the add citation button, it says 'Compile error in hidden module: Zortero. This error commonly occurs when code is incompatible with the version, platform or architecture of this application'

    Any suggestions on what to do? Thanks!
  • Hi Everyone, thought I'd just bump the above post since I did post it on Christmas, and it was likely missed.

    Any advice re the :"'Compile error in hidden module: Zortero. This error commonly occurs when code is incompatible with the version, platform or architecture of this application'" ?
  • I had the same problem. Jay
Sign In or Register to comment.