ZotFile - Advanced PDF management for Zotero

  • So no "Debug Message" just saying "2"?

    Sorry for the back and forth but here is another one with additional messages:

    If everything works, there should be the message with the path and three messages with "1", "2", and "3". If only some of these messages appear, I can pin down the error.
  • Joscha,

    There were no messages aside from the one I reported when I tried Zotfile (; but when I tried the one you provided in your previous post, an additional message with "1" appeared. I hope this would be helpful.
  • Thanks. So shows the message with "1" but not "2", right? It's a little hard for me to say what produces the error. Which Zotero and FF version do you use? Or Zotero Standalone?
  • Yes, that's right. I am using Zotero Standalone (
  • Sorry but hopefully the last version:
    There are three important changes:

    1. I tried to fix the problem with the error window. Click on the window with "Unknown Error!" and see whether something informative gets copied to the clipboard. You should also be able to look up the error message through "Tools -> Report Errors" but DO NOT follow the steps. Just look at the list of errors for something that refers to zotfile. This would be the most useful thing.

    2. The windows now include "1" through "5" and it would be good to know which one you see.

    3. The first "Debug Message" should report a different path now. What does it show?
  • The total number of messages I see is 6: unknown error message+4 Debug messages+Zotfile renamed attachments message:

    1. a. This is what got copied to the clipboard:
    TypeError: this is undefined
    (resource://gre/modules/osfile/ospath_win.jsm, 238)

    b. I could not detect which error is relevant, so I copied the whole list:
    [JavaScript Error: "1458435479278 Toolkit.Telemetry ERROR TelemetryStorage::loadAbortedSessionPing - error removing ping: PingReadError JS Stack trace: PingReadError@TelemetryStorage.jsm:80:15 < TelemetryStorageImpl.loadPingFile<@TelemetryStorage.jsm:1440:13 {file: "resource://gre/modules/Log.jsm" line: 749}]
    [JavaScript Error: "this is undefined" {file: "resource://gre/modules/osfile/ospath_win.jsm" line: 238}]
    [JavaScript Error: "TypeError: str.split is not a function" {file: "chrome://zotero/content/xpcom/utilities.js" line: 527}]

    2. I see three debug messages with “1”, “2” and “3”.

    3. The other debug message is blank; no path is shown.
  • Okay, I hope it's fixed now. Might be a bug in OS.Path or rather how that is loaded in Standalone. Not sure though. Can you give this version I try and report back? There should be no debug messages. If you still run into a bug, use the clipboard or "Action->Report error" as before. Thanks.

  • It worked, no messages are shown. I experienced some issues with extracting annotations when I tried the "Send to Tablet" and "Get from Tablet" features for the first time, but I tried the process a couple more times just to be sure, and it worked like a charm (except maybe for the wrong page number which is also an issue in Zotfile 4.2.1.) Thank you so much.
  • edited March 22, 2016
    Hi, I am using zotero standalone and after the update to the version 4.2.3 I cant rename file anymore. This is the error:

    TypeError: this.normalize_path is not a function
    (chrome://zotfile/content/zotfile.js, 1555)

    Installing the version I have this error

    TypeError: this.normalize_path is not a function
    (chrome://zotfile/content/zotfile.js, 1562)

    I rolled back to the version 4.2.2 and the renaming feature looks fine

    Thank you
  • Thanks, my fault. Already fixed, I hope. 4.2.4 is under review and dev version on github should work now. Hope I didn't screw it up.
  • Hi ZotFile,

    When I rename or send any pdf to tablet, Zotfile would show an error that:

    TypeError: this.normalize_path is not a function
    (chrome://zotfile/content/zotfile.js, 1562)

    Zotero standalone
    Zotfile 4.2.3

    Thank you
  • I also can't use "Rename Attachments" option in ZotFile anymore.
    Just see this message:
    TypeError: this.normalize_path is not a function
    (chrome://zotfile/content/zotfile.js, 1562)
  • Hi I got the same problem as above. Could you please have a look at it?

    Windows 10 x64
    Firefox 45.0.1
    Zotfile 4.2.3

    TypeError: this.normalize_path is not a function
    (chrome://zotfile/content/zotfile.js, 1562)
  • Folks, please look four posts up, Joscha has already replied and pushed out a fix.
  • Yes, and I can confirm that, at least, the rename feature is back working. Thank you
  • Hi, Zotfile,

    Here, I can't extract highlights and annotations from PDF OCR file with default "pdf.js", then I changed to "Poppler tool", it works. It extracted highlights correctly, but with notes written in Chinese, just not display correctly, like: ��N:N�NH�N:N�NHb�N�lum;N��u1dW(N (note on p.6).
    Any suggestion?
  • Please upload the pdf somewhere... The problem with poppler and non-ascii is known but I don't think it's going to get fixed anytime soon if ever. Mostly pdf.js now.
  • Many thanks Josha. Here you can download it http://pan.baidu.com/s/1qXWaMHe Pass: nf8m. Once you get it, please let me know. I should delete it.
  • Hi Joscha!

    i cant get automatic attaching of files in zotfile to work.

    im using:
    Windows 7
    Firefox 45.0.1
    Zotfile 4.2.4

    i think i configured it properly:
    In General Settings - Source folder for attaching new files, i set it to a custom folder "c:\zotero\inbox" and checked the Watched for new files in source folder.

    im expecting that the pdfs/files i put/moved in "inbox" folder will show up in zotero's unfiled folder.

    is my expectation wrong?

  • IQQ, can you reduce the pdf to one relevant page? Unnecessary to deal with the 41MB file (and downloading is very slow).

    starstuff, no that is not how it works. You should get a popup "do you want to add the file in the source folder..." when there is a new file int he folder. The new file is only attached when you click on that message.
  • Thank you Joscha for the reply!

    I did not get any popup at all, could you add an option to skip the popup altogether and add all the files inside the source folder?

    and maybe delete the files in the source folder after transfer to prevent duplicates

    another option is to link the auto create links of the files instead

    would this case be possible, im trying to combine calibre and zotero using zotfile using calibre's copy to library.

    1. i have a central calibre library, lets call this "library"
    2. create a new calibre library for zotero use, lets call this "zotlib"
    3. books i require in "library", i will use "copy to library" to move books to "zotlib"
    4. i will set "zotlib" as the zotfile source folder and it will add the files inside the "zotlib" into zotero/ or maybe link it?

  • Sorry, only doing bug fixes right now but pull requests are welcome...
  • Hi,
    the version 4.2.5 is not extracting any annotations at all. No errors and not pop ups at the bottom corner. I am using a portable version of zotero. The 4.2.4 version is just fine. If it can help, I modified the parameter to obtain "yellow annotations" and so on...
    Thank you
  • PC, Windows 10, Zotero, Adobe Reader DC (15.010.20060).

    Report ID: 154808735

    As of 3/31 I can no longer extract highlights and annotations from pdfs into notes in Zotero Standalone. I right-click a file (or its parent citation), go to Manage Attachment -> Extract Annotations, and nothing happens. No message about extracting, either in terms of success or failure. No extracted citation note is created. At this point, 4 pdfs have been tested, all showed the same behavior. Have tried restarting Zotero and restarting the computer. The only thing that changed on my computer between 3/30 (when annotation extraction was working) and 3/31 is that I updated to the latest version of Java (77).

    Is anyone else having this problem? Is there a solution?
  • Same Setup, Same Problem! Till yesterday morning.. no solution yet. Help plz!
  • The bug appears to only affect version 4.2.5 of ZotFile. A temporary workaround to restore previous functionality is to remove the ZotFile extension, then install version 4.2.4 (which is still be served from the main website). After reinstall, disable auto update until a fix is available for version 4.2.5
  • Hello there,
    I'd like to report the same problem exposed by Breath nsvitek, Gracherkonsequent. The version 4.2.4 still does the extraction.
  • Should be fixed now. Version 4.2.6 is under review. You can already download it from here:

  • Thank you for the quick responses and solution!
This discussion has been closed.