Zotero Standalone Not Working on New Computer

I have been using for Zotero for over 2 years now and apart from occasional glitches I normally don't have many issues with it.

I recently got a new computer for my office and attempted to install Zotero Standalone and the Firefox plugin onto the computer. I tested this all out on Friday 13th November and was able to sync Zotero Standalone with my online library to get all of my references. I was also able to save new references to Standalone.

However yesterday it stopped working. When I tried to open Standalone it was coming up with an error about it not opening properly and just shutting Standalone down. The Firefox plugin would not let me save any references and when hovering over the Zotero icon in Firefox it said that Zotero Standalone could not open.

I tried uninstalling and reinstalling Zotero Standalone and this did not help. I also restarted the computer, which didn't help either. It eventually loaded Zotero Standalone but then while syncing the red exclamation point came up stating that it did not have permission to save the file to the directory. The Firefox plugin was still not allowing me to save references at this point and still said Zotero Standalone was not open correctly.

I do not want to change reference software as I like Zotero and find it easy to use. I need this issue fixed as I am trying to plan my PhD and so need to manage and store references.

Thanks for reading my query and I appreciate any suggestions that may fix it.
  • Did you move the Zotero data directory to a custom location (if you don't know you probably didn't)? If so, move it back.

    If not -- the problem would seem to be that Zotero doesn't have permission to save to its own data directory. Find that data directory (https://www.zotero.org/support/zotero_data -- note that you may have to show hidden files to be able to see the full path) and make sure you have read&write access with your regular user account.

    (You can easily google instructions for showing hidden files and setting folder permissions for your Windows version).

    There's also a small chance that security software is interfering, though I'd be surprised given your description.
  • I have just noticed that Zotero is saved in my account in the Network option, and not the C Drive. I did not choose this, as this is the default of my department computer. So would moving it to the C Drive help?

    I have done all of the above and my account is set as an Administrator with full permission to edit files.

    There may be strict security on this computer as Oxford University bought it and set it up for me. So this could maybe be causing the problem?
  • I have just installed the Zotero plugin for Chrome on my new computer and Zotero is working fine with that. It is saving and storing references with no problem.However the error message about not being able to save it to the directory continues. So maybe the issue is with Firefox?

    A few months ago, while I was desperately trying to write up my MRes thesis, I had a huge problem with Zotero and Firefox. No matter what I tried Firefox would not work with Zotero then it eventually started working. So maybe Firefox has a lot of problems with the plugin. Which is a shame as I prefer Firefox to Chrome.
  • I have moved Zotero to the C Drive and the error has gone away.

    Firefox plugin is still not working though, and keeps saying "There was an error starting Zotero".
  • in the Firefox, can you get to the Zotero preferences? If so, redirect the data folder locations (under Advanced --> Files and Folders) to the same you have for Zotero Standalone. See https://www.zotero.org/support/kb/sharing_data_directory for details
  • edited November 25, 2015
    I will try that today.

    Zotero Standalone is now not working again. Every time I open it I have to create a new profile.
  • Everytime I open either standalone or my Firefox browser windows is making me create a new profile!!!!!! This means it's constantly deleting my Firefox preferences and is driving me insane!!!
    I have no idea what is up with this computer!
  • same problem here. a user just reports that zotero used to work fine before last weekend - the last date she was using zotero was Nov 28th.
    Now she gets the "There was an error starting Zotero" - message everytime she tries to start zotero.

    the OS is Win 8.1. enterprise and she had both Zot FF and Zot SA installed on her computer. ne3ither of them worked any more. As our network is using roaming profiles I thought this could be the reasen for the problem, albeit this would not explain why it worked till nov 28th - but anyway,

    this is what we tried:

    - uninstalling Zot SA _without_ deleting the user data
    - reinstalling Zot SA

    => No effect - it wasn't possible to open the program

    - we located the zotero profile and saved it
    - we uninstalled Zot SA and deleted the user data
    - we reinstalled Zot SA
    - Zot SA could be opened and everything seemed to look fine
    - when we tried to save a book to the zotero library it didn't work. it said "Saving to the zotero library" in the bottom right corner of chrome, but the entry did _not_ appear in the zotero library

    when I checked the "zotero"-folder we had saved before, i found that it didn't contain any zotero-specific information. there were no folders called "storage", "styles", or "translators" etc., it looked like a normal firefox profile-folder.

    any suggestions what we coukd try next?

  • So there seem to be two questions:
    1. How do we get the fresh Zotero install to work?
    With this:
    when we tried to save a book to the zotero library it didn't work. it said "Saving to the zotero library" in the bottom right corner of chrome, but the entry did _not_ appear in the zotero library
    If this is trying to save from Firefox, I'd expect the data directory isn't shared anymore:
    and you're saving straight to the Firefox library. If this is another browser -- do you see the title of the book you're saving in the "Saving to Zotero" popup?

    2. How do we restore the old data?

    If this is on Firefox, the old data may simply be stored in Firefox, not in the Standalone profile, so check there. Otherwise, we'd have to take a closer look at the backed up Standalone folder.

    (FWIW, there was no Zotero update between November 28 and now, so something else interfered here).
  • Zotero standalone and the Firefox plugin seem to be working on my computer now.

    I had the IT people in my department take a look at it. They edited some settings and created a local profile for me rather than a roaming one. That seems to have fixed the issue.
  • edited December 11, 2015
    thank you for this hint. i will try to create a local profile, too.
    => creating a local profile did the trick. zotero is working.

    ..and while fixing the problem I found out that you can't export a zotero library to a network location?
  • sorry, not following that last question.
Sign In or Register to comment.