New Zotero word add-in causing spinning blue wheel in m.s. word

Every time I move the cursor location in MS word or I delete individual letters, a spinning blue wheel appears (the "busy indicator") in the location of the cursor.

Everything still works fine, but this is annoying. This problem seems to have coincided with the new "streamlined" version of the zotero word plug in. In fact, if I disable the Zotero word plug-in, then the problem disappears (but then I can't use zotero!).

Any suggestions would be greatly appreciated. I wonder if anyone else has experience this problem?
  • I am experiencing the same issue on my end since the 3.5.1 Word plugin update, in a Windows 10 64-bit environment, with Word 2016 32-bit (16.0.4229.1024). Unforunately no solutions so far, but disabling the plug-in does indeed make the problem disappear.
  • I am also having the same problem - Windows 8.1, Word 2013 32-bit. The blue circle appears very briefly every time the cursor location is changed, whether by mouse click or key press.

    This makes navigation in a Word document with the arrow keys frustratingly slow, as I have to wait for the cursor to 'catch up' in order to see my current location in the document.

    I found that disabling the latest Zotero add-in (under "Developer" -> "Add-Ins" -> "zotero.dotm") and enabling an earlier version ("") provides a workaround for the problem.

    Hope this helps.
  • I also had the same problem, and figured out that the source was the new zotero add-in. But i am unable to figure out how to uninstall the new one and install the old one. If I just try to install the old one (Zotero-WinWord-Plugin-3.1.20.xpi file), firefox just does not do anything. If I try to use pjc1's method (just extract the .dot file from within the .xpi and put it in the same location as the .dotm file), the .dot file shows up in the add-in list and can be enabled, but when I try to use the add-in, it says cannot communicate with zotero. Obviously I have to properly install the old version, but not able to figure out how. (This is all while we wait for a bug fix for the new one, I guess).
  • Addition: I guess I have figure out how to first cleanly uninstall v.3.5.1 also!
  • I also experienced the same boring problem.
    No need to go back to 3.1.20
    Just reinstall Word processor, then go there: C:\Users\[user_name]\AppData\Roaming\Microsoft\Word\STARTUP (authorize hidden folders in explorer to access this folder).

    Cancelling zotero.dotm make things go better, the wheel stops...

    If you can't see the extension of the file, order the files by name, it will be the second.
  • This should be fixed in Word for Windows Integration 3.5.2, available now.
  • Thanks, Simon, for the quick fix. The bug is gone. However, two questions:
    a) I usually customize things in Word so that Alt-1 is set to the Zotero-Add-Citation command. (and a few other similar keyboard shortcuts). But with the new Add-in, I am not able to set such a shortcut, because I am not able to find the Zotero commands in the "All Commands" section of "Customize Keyboard" option in Word 2013. Earlier, all zotero commands would show up in the "All Commands" list. Am I missing something here? Can you help?
    b) The option to 'Remove Add-in' does not become available when one goes to the Templates and Add-ins section in Word-Options. Any reason why?
  • a) they'd be listed under Macros. I'd have to go back and check, but I'd be pretty sure that they are still available for keyboard customization.
  • Thanks, Adam. yes, I found the commands under Macros, and was able to customize.
  • Hi,Zotero Support:

    I strongly suggest that you send a message to all your users (or your Word users, if you can identify them) about this bug and how to fix it.

    Otherwise, you have thousands of folks out there with a debilitating bug in Word and no idea how to repair it (since you don't have a system of automatic updates). I found it only because I am savvy with web searching for technical issues, and I got lucky. And it still took me over 30 minutes of searching, including following numerous blind alleys.

    Putting notice in a generic newsletter won't do the trick, since people often don't read those, and they won't even suspect that Zotero is causing their problem. You need an email with a very well-composed subject line. May I suggest...

    Zotero users -- is Word for Windows running slow -- this might be your problem.

    I realize that makes you look not so terrific. But you have a serious situation on your hands here, and you need to act in your users' interests. Need I mention Volkswagen?

    Regards. --David (loving Zotero, so far, having come from the M product)
  • Well, upon reflection I realize there probably aren't thousands of users with this problem -- just those with the particular version or versions with the bug. But if that's even a handful, you owe it to them to be proactive. I was tearing my hair out over the problem.

    Regards. --David
  • add-ons for Zotero and Firefox auto-update, so this will just fix itself for users either within 24hs or on updating their add-ons.
  • The bug is fixed on my end following the add-on auto-update. Thank you very much for this quick fix!
  • Fixed here as well. Many many thanks for the quick fix! Love Zotero!
Sign In or Register to comment.