Proxy not adding

I'm running Zotero on Firefox 35.0.1 on a Mac/Mavericks.
How do I add proxy's to zotero?
I used to have proxy info, but I (rashly) deleted it when I was trying to fix a problem with Scopus not working.

Now I cannot get the proxy info back.
I have Enable proxy direction, and Automatically recognize proxied resources ticked.

I tried deleting then re-installing the Zotero plugin.
i searched the forums.
I read the Zotero manual.
I killed a chicken and looked at its entrails.
Nothing worked (except my chicken is now dead as WELL as my proxy info).

Any ideas please?
I SHOULD have written down what my proxy's were before I deleted them: my chicken would be happier as well.
I'm not sure what they SHOULD look like, or where I find them to add manually.

  • if you're trying to access resources through your library, they should direct you through the proxy. Does that work?
    If so, can you post a URL with proxy included here?
  • Hi Adam, thanks for help.

    I'm not sure if this is the proxy, but the university URL is:

    Is that enough to figure out the proxy?
  • I used to get a yellow banner at the top of the web-page about enable or disable Zotero proxy (or maybe it said re-direct: I forget exact words). I don't seem to get that now.
  • Aha!!!!
    I think I solved it.
    I was messing with my Firefox top bar icons and accidentally hit "Home".
    Which opened a bunch of tabs I already had open.

    And THAT seemed to activate the auto proxy add: the yellow banner I mentioned that I wasn't seeing.
    And NOW when I look at Preferences it DOES have a proxy in for my library.

    Dunno why that worked.
    I had already restarted after deleting the Zotero plugin.
  • edited February 20, 2015
    No that's wrong, problem still there.
    I was able to start a new multi-user proxy and it seems to add to it, but Science Direct is not working properly.

    My problem now is say I open a ScienceDirect reference found by Google Scholar.
    I cannot import the reference and pdf attachment into Zotero.
    I can see that I have full access to it.
    I can open the pdf in another tab.
    When I right-click over the Zotero save icon, it gives me the options to Save to Zotero using Science Direct (I select that and it doesn't work: NOTHING gets saved).
    I try the other option to save to Zotero using DOI and it saves the metadata, but no attachment.
    It USED to save both.
    In fact, I could just left click on the Zotero icon in a Science Direct page and everything got saved.

    And I imported a backup FireFox profile (from my backup HDD), complete with Zotero, and I've been trying that; doesn't work either.

    This was BEFORE I deleted the proxys.
  • Aha!!!!
    OK, then it's an unrelated problem.

    Thanks! Dang, I was REALLY puzzled.

    How can I import proxy info from one Firefox profile to another?
    Just the proxy info.
    Is there a way?
  • Not possible at this point, sorry.
  • Science Direct is back, and my Zotero works well again.

    I'll manually add the proxy info from my backup copy to my working copy and see which one is giving me the problem.

    And thanks guys for your as usual prompt and excellent help.
Sign In or Register to comment.