GUI language

why it displays in language of country I stay, instead of asking or just offers in global English?
  • The language used for the UI _should_ be the one that is used by your OS (what operating system do you have?). You can try setting the UI language manually by following these instructions: (please let us know the value that was set before you change it).
  • The default value is true, apperently.

    I use windows 7 which version is in English (Global version), but as I stay at Korea (also I installed OS in Korea, but it's global version and I DONT know Korean), then I guess maybe the problem is Zotero started by mis-regconizing IP and displayed in Korean? In Location tab, in "Region and Language", Windows setting, Current location is set "US".

    After dumb-guessing clicks, I found solution, but I thought beacuse I have some kind of underlying knowledge in IT. I guess someone who has no idea about computer tweaks, then what can he does?
  • No, Zotero doesn't care about the IP (or where you are more generally). It's a language setting on your system.
  • Also, is this Zotero Standalone or Zotero in Firefox (I'm guessing Standalone, if no, which version of Firefox)? It's rather odd that this would happen randomly, since nothing has changed from Zotero or Firefox side for a couple weeks now. You're the second person to report this however, so we might be seeing more of this issue.
  • First, I dont know Korean, then I use English verion. Nothing is relative to Korean. You can see in my pic captured in "Region and Language" setting below:

    Second, I also had installed FF in my computer. First check was my FF, I found the setting was False (oh, how shame it is).
    Then I try to open every texts in Menu (which displays in korean) and try every buttons I can click. (I hope, at least, people would provide guidance by picture)

    (I downloaded Zetero in Chrome which is in English, too.)

    Could you explain what "language setting on your system"?
  • Sorry to forget mentioning the version, I use Zotero Standalone.
  • edited October 8, 2014
    Following your screenshot, go to Regional and Language Settings -> Administrative -> Change System Locale (requires administrator privileges). I bet that Korean will be selected there. Change it to English (will have to restart computer) and you shouldn't experience any other issues with language settings (you can then revert the "matchOS" setting in Zotero).

    I don't think it makes sense for Firefox/Zotero to be looking at this setting when determining display language. We'll see if we can take this to Mozilla for a proper fix.

    Edit: reported here
  • This has been noticed before:

    Given that Zotero is likely the largest affected product, I doubt this is going to be fixed on Mozilla's end unless someone from the Zotero community submits a patch.
  • yup. I'm going to give it a shot
  • edited October 9, 2014
    @aurimas: you are right.

    But this setting is just for non-unicode program. I set it Korean because I visit Korean websites which display in Korean characters.
    It's hard to live in such stupid characters like that. I found crazy sometimes.

    But anyway, thank you all.
  • One more thing, I also installed FF in my computer, but the value is False (for default). And FF, of course, displays in English.

    Then why did it affect only Zotero? I dont want to get answer. Just guess a solution.
  • Firefox for windows doesn't try to match your OS settings for display language. That's why you have to choose the language when you download it. Zotero, on the other hand, has the matchOS option enabled.

    We'll try to fix this. As I said above, I don't think the current behavior is right.
Sign In or Register to comment.