0x80004005 (NS_ERROR_FAILURE) [zoteroIntegrationApplication.getDocument]

I get this error when I try to insert a citation
Zotero Standalone 4.0.19, Word 2007, latest Word Integration (18 Apr 2014). Tried with doc and docx, same result

Error report: 705480502

Zotero WinWord Integration: getDocument() could not find document "C:\my\....\HierarchicalRelations.docx" in ROT

[JavaScript Error: "[Exception... "'Could not find a running Word instance. code: "0" function: "zoteroWinWordDocument::initFromActiveObject" location: "zoteroWinWordDocument.cpp"' when calling method: [zoteroWinWordIntegrationErrorHandler::throwError]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "JS frame :: chrome://zotero/content/xpcom/integration.js :: <TOP_LEVEL> :: line 239" data: no]" {file: "chrome://zotero/content/xpcom/integration.js" line: 239}]

[JavaScript Error: "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [zoteroIntegrationApplication.getDocument]" {file: "chrome://zotero/content/xpcom/integration.js" line: 239}]
  • Try installing the next Zotero version (which has come out since), see if that helps.
    Also, does this happen in a new document, too?
    Finally, make sure you're running Word and Zotero with the same user account (rather than, e.g., one as an administrator and one with a regular account).
  • It works with Zotero Standalone 4.20
  • Hi, I have the same problem with Zotero for Firefox
    It happens even in new document.
    I tried to reinstall Zotero and MS Word plugin, but the problem prevail.
    Thanks for any help.
  • I now got exactly the same mistake

    "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [zoteroIntegrationApplication.getDocument]"
    "result": 2147500037
    "name": "NS_ERROR_FAILURE"
    "filename": "chrome://zotero/content/xpcom/integration.js"

    The complete data are submitted with Debug ID D1677433498
  • I have the same error using Word 2010, Firefox 37.02 and the latest greatest zotero. I've tried uninstall and reinstalling zotero serveral time and even doing the same for word. I can use the stand alone product but would totally prefer to be based in my browser. Is there any update on the cause and a fix?
  • Sir kindly help me out...i m using zotero standalone and Windows office 2013 and get this error...
    Zotero integration error
    Zotero experienced an error updating your document.

    Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [zoteroIntegrationApplication.getDocument]
    kindly help..my wor is runinf in compatibility mode
  • same questions as above:
    1) Does this happen in a new document?
    2) Could you provide an error report ID?
  • yes it also happen in new document and error report id is 802067287
  • @Dan - can you see anything in there?
  • Zotero WinWord Integration: getDocument() could not find document "C:\Users\[...]\Desktop\[..].docx" in ROT

    [JavaScript Error: "uncaught exception: Could not find a running Word instance. code: "0" function: "zoteroWinWordDocument::initFromActiveObject" location: "zoteroWinWordDocument.cpp""]"
  • can you help me change compatibility mode of word?
  • i'm having same error - report id 2019533082, microsoft 2013 (365) with zotero v.
  • I encountered this problem a lot of times. In Win7 (windows 7) you need to run zotero as administrator:
    1. right click Zotero in the "Start menu" and click "Properties"
    2. In the "Compatibility" tab and check the box "Run .. as administrator"
    3. That's it!
  • that shouldn't be necessary and you shouldn't run software as administrator -- though this suggests that you my be running Word on a different account (Zotero and Word need to run on the same account in Windows), in which case you'd want to fix that.
Sign In or Register to comment.