Moving items from my library to a group library


I am sharing a group library with a colleague. When I collect an item from a website, it automatically saves to my library and, for some reason, cannot be dragged and dropped to the group library. And my colleague cannot see them. Can you help?


  • drag&drop should work. Can you manually create a new item in the group library? Of any type?
  • I can create a new item in the group library, but it seems like a lot of unnecessary work to retype all the citation information. It would be better if I could move the citations from my library directly to the group library, but there doesn't seem to be any way of doing that.
  • as I said - of course you should be able to drag & drop. This was just to see whether you had the general permission to add items to the group library.
    Create a new item in your library and the provide a debug ID for trying to drag it to your group library (and presumably failing)
  • I did everything that the link said to do, and I got a debug ID after enabling Debug Output Logging, but I don't understand how to get a debug ID specifically for the issue of dragging and dropping to a group library. Please excuse my lack of familiarity with the software. I'm very new to it.
  • you enable debug output, then you perform the (failing) drag&drop action, then you go back to the preferences and click "submit to Zotero Server"
  • Ok, I've done that and I have a specific debug ID for failed drag/drop. What should I expect to happen next? Should it just start to work suddenly or should I consider uninstalling and reinstalling Zotero?
  • when I say "provide" I'm asking you to post the debug ID here so that devs can take a look at what happens. As per step 4. of the instructions:
    "Zotero will provide a Debug ID that you can post to the forums"

    Re-installing Zotero is unlikely to help.
  • Sure, I didn't know if you were customer service or another user. The Debug ID is D1768967779
  • If you can't drag an item in, it's because either you don't have write access to the library or because a previously dragged copy of the item is already in the library (even in the trash).

    In this case, it looks like you don't have write access to the library. This is why adamsmith asked if you could create items in the library. You said you could, but did you actually try? Based on the current permissions, you wouldn't be able to. Your colleague needs to fix the editing permissions on the group from the website, and then you need to sync.
  • Hi Zotero admin,
    I am having the same issue as above. I created a group to privately share with my colleagues but I already have a collection in my library which I want to drag and drop. But it is not working.
    The Debug ID is D1507337253
    Would be glad if you could help. Thanks
  • you've made sure the two issues that Dan mentions don't apply?
    I.e. you can add new items to the group and none of the items in the collection has previously been included in the group?
  • Yes I can add new items to the group and no, the collection has not been previously included in the group
  • This is how it looks: I have my library open in the tab below and my group opened in Firefox. I try dragging the ‘collection’ from ‘my library’ (in Zotero tab below) to ‘group library’(in Zotero group). Nothing happens.
    So I opened preferences and ‘enable’d debug and performed the drag and drop function, submitted to Zotero server and got a debug ID D1507337253
  • I have my library open in the tab below and my group opened in Firefox
    Are you saying that you're looking at your group on If so, that's completely separate from the Zotero client. You can't drag to or from the website. You can only drag between libraries within the Zotero client.
  • Hi,

    Please tell me exactly what the group administrator needs to do to give me write access to our group library. Thank you.
  • - Go to the group settings page here on
    - click on "Library Settings"
    - Set "Library Editing" and "File Editing" to "Any Member"
  • Thanks for the help. It works now.
  • I can't create individual items in a group or drag items within Zotero standalone into the group, but I can create individual items on the website. At an earlier stage, the group was not set with "File Editing" to "Any Member" but it is now. Debug ID D809876412
  • EKSwitaj: Start a new thread.
  • Hi
    sorry but I didnt understand what to do eith the ID
    "Zotero will provide a Debug ID that you can post to the forums"???
    and the drag and drop didnt work to.
    I'm asking for help and thankyou
  • Start a new thread please and provide more info:
  • same problem... everyone has admin privileges but looking at the zotero client (add on for firefox), one cannot drag a file from the personal library to the group library. It works fine on the laptop of the original admin, but not on my desktop, even though i am listed as an admin. any suggestions or solutions yet? cheers,
  • you've synced successfully?
  • actually yes, i just solved it (my version of the problem anyway).

    Did so by changing the permissions so that “any group member” can edit the library – as opposed to only admins. So even though we were listed as admins, the system wasn’t allowing us to update... now that it allows regular users to update, i am able to.

    not sure if this will help the above posters or not! but good luck,
  • folks above either got their problem solved or were helped in another thread. My guess would be that the permissions hadn't synced when you tried dragging, but obviously not sure that was it. Anyway, glad it's working for you.
  • I am having the same problem. I created a group. Then I mistakenly added items to my library, when I should have added them to my GROUP library. How do I move them from library to my group library? I should have permission since I created both. Thanks.
  • what happens when you try to move them?
  • Nothing. They stay put, and are not added to the group library. But I am probably doing it all wrong. I've just started using this tool. Cool tool, by the way.
  • I'm having a similiar problem. I can't move items from my library to a Group that I created to share that library with a colleague. Here's my ID
This discussion has been closed.