Moving items from my library to a group library

  • and you can manually create an item in the group? And you're positive you're not dragging an attachment-type item?
  • I have done the same thing. How do you move items from your own library to a shared group?
  • The documentation is here:
    if that doesn't work, see my questions right above your post.
  • Hi...I'm completelt lost. I have been trying to transfer articles from my library to the group and nothing seems to be working. I've read all the above and thought that I'd eleminated all of the possible 'blocks' I am actually the owner of the group and assumed that I have full access to move items. Can you suggest anything else? I assumed dragging was from an item in my library to the group tag in the window on the left ...?
  • I figured was a question of syncing properly.
  • I am having problems with drag and drop items/collections from My Library to Group Library. Debug ID: D45619734. Thanks for your help.
  • Correct ID is D456319734.
  • what exactly happens when you try?
  • I've just had another attempt and it is now working fine. Thanks for following up so promptly.
  • I have tried all of the things mentioned in the forum. No luck. I am the owner of the group and cant drag items from my own library to group library. I can create a new item in the group library. When I drag an item from my personal library to the group, the screen flickers then brings up the file I am trying to drag in full screen on my home library. (as if I had just clicked on the item, instead of dragging it to a group.
  • That sound like you're trying this on the webpage. You can only transfer items between libraries in the software, i.e. Zotero Standalone or the FIrefox add-on.
  • I was having the same problem. This is how I solved it:
    I selected the items in my library, created an export file, then imported that file into the group library.
  • @asacristan: That's definitely not necessary. In the Zotero client, you can drag collections and items from any library to any other that you have editing rights to. You just can't currently drag a collection to another library if you've previously dragged the same collection to that library — in that case, you have to first delete the earlier version of the collection in the target library. (We'll be improving that in the future.)
  • edited April 15, 2018
    @dstillman: That's the point! Dragging was not working! So I did the export and import and that worked.
    I've been using Zotero for years and only today did I have problems with dragging to a group. But the import worked.
  • Right, but if that's not working, that's something to report, and we'll help you debug it. Exporting and importing isn't the solution.
  • I have created a Group Library to which I'm unable to (reliably) drag collections or individual items. Folders of more than 10 items won't copy across at all, sometimes batches of items will work, sometimes with attachments, sometimes without, sometimes not at all. I have a large number of items with attached pdfs (links to files sorted by Zotfile according to my renaming rules) in my Dropbox, to which I need to give my colleague access for a joint research project. I had understood this to be a key function of Zotero going in. Is there a sense of this functionality working in general? I'm trying to get this working in the Zotero Standalone program 5.0.52-beta.1+f3a62f5a6 on MacOS 10.13.3. I thought I would try to do it Online but can't even see how I would drag from My Library to the Group there...?

    Many thanks for your help
  • Links to Files don't work in groups at all, so maybe that's what you're seeing?
  • I seem to be having the same issues as mentioned above and wanted to get some clarification on why I might not be able to transfer items saved in my library to a group library that I have editing control over. From what I've gathered, am I correct to assume that I need the stand alone Zotero software in order to drag and drop (as opposed to in the chrome browser)? And if this is the case, if my machine is a chromebook, would I not be able to utilize the drag and drop function?

    Further, I am unable to figure out how to save directly to the group folder. I read that when the dialog box pops up I should be able to choose the destination but am unable to choose a library that it goes into. Thanks so much!
  • Yes, you will need the full Zotero software (aka standalone) for the drag-drop feature. And that is not available for Chromebook. FYI, the features at are a small subset of the standalone.
  • You can run Linux apps in Chromebooks/ChromeOS now. There are several threads here with details on this.
  • I have the same problem. My debug ID is D586828465.
  • @hsujenni: Please start a new thread and explain the exact problem you're facing and what the Debug ID is meant to show. (This thread dates to 2013 and includes all sorts of comments, so it's not a good place to try to debug an individual issue.)
This discussion has been closed.