zotero attachments are blank on pdf.js

when i try to open a zotero pdf attachment with pdf.js it shows a blank pdf.js interface.
otherwise pdf.js opens pdf files like it should.
everything is updated, tried to disable all other firefox addons - nothing helps.

  • have you tried opening that attachment with a different pdf viewer?
    (generally this works, so if it doesn't, something more specific is going on).
  • yes of course...weird
  • Maybe Dan has an idea, but in general Zotero just passes the PDF on to Firefox to open, so I don't see how opening this from Zotero vs. the web would make any difference.
    You're using FF 19 presumably?
  • fresh install of firefox 19 (new profile).
    installed zotero addon and pdf viewer.
    when i drag pdf in- everything is fine, but when double clicking on an zotero pdf attachment - i get the pdf.js blank-grey interface.
    the same zotero attachment works with pdf-xchange viewer addon in the browser.

    you know what..it's not worth it, this pdf.js has too many problems.
    thanks for your time, sorry if i wasted it.
  • I reported several similar issues to pdf.js in the early days of the pdf.js-- they had some issues loading things from Zotero then, and they were fixed. You may want to go to their issue tracker and explain the situation, as it sounds like it might be a fix on their end.
  • edited February 26, 2013
    Same problem Firefox 19, On clicking a PDF attachment from zotero opens blank grey. Firefox can show other PDF using pdf.js. Zotero's PDF attachment is okay, opens with external viewer. System Mac OSX 10.8.2.

    Error report ID 402770691
    Following error message is generated, in case it helps :
    [JavaScript Error: "this.docShell is null" {file: "chrome://global/content/bindings/browser.xml" line: 323}]
  • This happens with pdf.js version 0.7.236 and the current development version. As a remedy, install 0.7.1 from https://addons.mozilla.org/en-US/firefox/addon/pdfjs/versions/, and PDF viewing as well as saving will work again.
  • Same on two Mac machines, 10.6.8 and 10.7.5, both using latest pdf.js nightly (0.7.313). Can confirm that going back to pdf.js 0.7.1 fixes it. Unfortunately, the latest pdf.js stable (0.7.236) does not.

    Not Zotero's fault probably, but we all depend on Zotero and pdf.js getting along.
  • I've submitted a fix for the issue to the pdf.js developers. It works, but I'm not sure it's the right fix.
  • edited April 30, 2013
    I just saw that simonster's pull request on this issue has been merged and closed. That should make pdf.js work for zotero again.


    But with latest github version of pdf.js (0.8.105) and Zotero 4.0.6, Firefox does not even attempt to open any pdf files from Zotero. Any help?
  • edited April 30, 2013
    This works for me. Make sure you have "Open PDFs and other files within Firefox when possible" checked in the Zotero preferences.
  • I do have that checked. I do wonder if I have to do something about the mime types in Firefox, but since I changed nothing lately, that should not be a problem. (Currently it is "Always ask", but I guess pdf.js overrides that.)
  • You could try trashing mimeTypes.rdf in the Firefox profile (or, better yet, moving it out of the way) and restarting.
  • Trashing it did the job. There is no longer a content type for Adobe PDF document, which works for pdf.js. (There does not appear to be a way to remove entries from the Firefox preference Content tab)

  • @enzokan / others - trashing mimeTypes.rdf didn't solve the problem for me - i'm still getting empty screen when looking up pdf's through firefox/zotero (it kind of loads the loading bar and then black/grey browser window).

    did you do more ?

    I'm under:

    firefox 21.0
    osx 10.8.6
    zotero 4.0.8

    the direct pdf.js seems to work(tm) just fine:

  • Get the developmental version of pdf.js, currently at 0.8.227 (which will daily update).

  • thx adamsmith / enozkan - that solved the problem
  • Solved my problem too. Thanks for the hint.
Sign In or Register to comment.