Cannot view PDF attachment in Firefox


I'm using Zotero for Firefox 4.0.8 (site translator up to date) with Firefox 21.0 (up to date). However, I recently found that I cannot open the PDF attachment of an item in Firefox by double clicking the item entry or by selecting 'View PDF' from the context menu.

What happens after I do either of the above is: the dark grey PDF view window shows up. A progress bar quickly flashes and then disappears. No pdf file is loaded. The address bar reads something like 'zotero://attachment/147/'.

However, I can still view these PDF files either by choosing 'Open in External Viewer' to open it in Adobe Reader or by directly dragging the PDF entry to the firefox window. In the latter case, the address bar shows the fullpath of the file. e.g.: 'file:///C:/Users/MyAccount/AppData/Roaming/Zotero/Zotero/Profiles/9id3rmmi.default/zotero/storage/42FBGWV6/227.pdf'. Or alternatively, I can go to the original webpage to open the pdf file online.

I did use CCleaner to clean the registry/cookies/temporary internet files around the time the problem started to occur. But I don't quite remember which happened first.

Any help would be highly appreciated.

Best Regards
  • edited November 2, 2013
    This is a bug in pdf.js. It's fixed in the latest version, which you can get from the "Development Version" link here.

    This is fixed in the latest version of Firefox, so installing a separate version of pdf.js is no longer necessary. See below for details— D.S.
  • edited June 30, 2013
    Here's a more direct link to the paragraph that lists the download links:

    Edit: link updated. Thanks adamsmith
  • Problem was solved after pdf.js was updated to 'development'. Gratitude to both of the answers :)
  • Had the same problem, thanks a lot for the valuable tips! :)
  • Thanks for the hint, the development version worked for me, too!

    However, after restarting firefox, I ran into this issue again. Deactivating and then reactivating the PDF.js extension worked for me. So it looks like firefox uses the bundled, internal version of PDF.js by default, and only installing/activating the dev version overrides this.

    Is there a way to disable the internal, bundled version, so firefox always uses the installed dev version?
  • edited June 19, 2013
    development version works!

    Thanks very much!
  • Thanks! Had the same problem, glad I checked out the forums.
  • the link to the download section of the pdf.js has changed since Aurimas's post above, it's now
  • edited July 18, 2013
    EDIT: never mind, I didn't realize it was a Firefox thing

    Is this fix going to make it into 4.0.9 stable? I have a user base that I do not feel comfortable moving to dev tree.
  • the fix is a Firefox fix, not a Zotero fix, so it has nothing to do with the 4.0.9 release.
    The development version linked to only applies to pdf.js, nothing else.
    I don't think we know when this is going to make it into regular Firefox.
  • Hurray. Thanks for advice on this page. Downloaded development version following link above and sorted problem within seconds!!
    So relieved
  • Developer vesion of pdf.js works fine.

    Thank you all!
  • All of you are fantastic! I am working on my Ph.D. and was going crazy trying to figure out this issue. I found this forum conversation and all has been resolved. I can go back to my readings. Thank you, thank you!!!
  • This was fixed in Firefox 24, so the development version of pdf.js should no longer be necessary. Make sure you're running Firefox 24 or later (25 is now the latest version) and uninstall pdf.js from the Firefox add-ons window. (The built-in version doesn't show up in the add-ons window. You can see whether Firefox is set to use it for PDFs ("Preview in Firefox") in the Applications pane of the Firefox preferences.)
  • Hi,

    whenever I try to open a pdf from Zotero, it opens a blank tab and asks me how it should open it. It used to open the pdf in a new tab without asking, but now it always pops up this window. However, when I'm not using Zotero (like a pdf link on the web), it works fine: it opens it in a new tab without asking anything.

    Any ideas what's wrong here?

    I'm using Firefox 26.0, Zotero, Mac OS X 10.8; rv:26.0 and I have the option Open PDFs within Firefox checked.

  • Hi Dan,

    I tried that, but it doesn't work. The file didn't exist, so I went ahead and created one as described, but nothing changed, even after restarting Firefox, or the machine. Anyway, I have unchecked the 'Open PDFs within Firefox' Zotero option: now at least it opens the pdfs directly in Preview without popping up the application panel and does not pollute the browser with the annoying empty tabs.

    So that works for me, although I still don't understand if Zotero has nothing to do with how pdfs are handled, why a pdf on the web opens fine in the browser and a pdf from the Zotero library prompts this question about the application.
  • Which file didn't exist? Deleting mimeTypes.rdf was the thing you were supposed to do, and that's not something you could've created by yourself, so I'm not sure what you're referring to. The bottom section is for Linux and is completely irrelevant for OS X.
  • Dan Stillman/
    Thank you so much. I was having the same problem as kolorado, and by deleting mimeTypes.rdf I solved my problem so easily. Thanks!
Sign In or Register to comment.