Insert Citation Error with Word 2013 Preview

Hi, zotero reports an error when I am using word 2013. I would be more than grateful if it can be fixed.

C:\Program Files (x86)\Zotero Standalone\zotero.exe
Zotero experienced an error updating your document.

[zoteroWinWordIntegration Exception... "The range cannot be deleted." code: "0" function: "zoteroWinWordField::SetText" location: ".\zoteroWinWordField.cpp"]

  • edited July 31, 2012
    I also face the same problem but during refresh of an existing document of word 2010. also the bibliography doesnt appear in a field format. spent a lot of time trying to check my document, finally realized that it works fine with word 2010.

    please do resolve this issue.

  • Echoing the sentiments of RDX, I would also be very grateful if Zotero was compatible with Word 2013. I am preparing to install Office 2013, and I was wondering how that would affect Zotero functionality. Thanks Zotero team for anything you can do to address this.

  • I looked into this and it seems to be caused by a bug in Word 2013 (or at least an undocumented change in behavior vs. all previous versions of Word back to Word 2000). The Range.InsertFile method is supposed to insert a file into a range, and in Word 2000-2010, it does. In Word 2013, it inserts the file immediately to the left of the range. Hopefully, Microsoft will fix this in the near future. Otherwise, we will implement a workaround.
  • A month on and no fix from Microsoft. Error still persists in the preview of Office 2013 I downloaded yesterday. I submitted a bug report from the "frowny face" icon in Word 2013 -- I hope others have done the same.
  • i don't know if it's of any help...
    but Zotero standalone works just great with word 2013.
  • It works fine as long as you don't insert a bibliography or any citations with formatting or non-ASCII characters. Then it will either give you an error or replicate the citations/bibliography multiple times on refresh.
  • I have just upgraded Word 2013 to version 15.0.4128.1025 (I believe this is the RTM version) and the problem seems to be still there. I also encourage everyone to send feedback to MS via the 'frowny face' icon.
  • I have the same problem as everybody else. Really no cure?

    Zotero experienced an error updating your dokument

    [ZoteroWinWordIntegration Exception…»The range cannot be deleted» code:»0» function «zoteroWinWordField::SetText» location:».\zoteroWinWordField.cpp»]
  • As some citations work fine and others don't, I wonder if anyone has any clues about what makes a difference? I have tried different types of styles, I have tied to reduce information like number of authors, tried to delete summaries or notes to see if the reference would be accepted, etc. But no such changes makes Zotero insert the citation.

    I have also had this problem in Word 2010, by the way.
  • As for when this happens, see Simon above
    It works fine as long as you don't insert a bibliography or any citations with formatting or non-ASCII characters. Then it will either give you an error or replicate the citations/bibliography multiple times on refresh.
  • Hm. For instance, I cannot insert this citation into my word 2013 document - what is wrong with it?

    Hjertaker, I, and B. S Tranøy 2010 Opportunistisk Keynesianisme. Om Bankstere Og Økonomisk Politikk. In Markedets Fremtid: Kapitalismen i Krise? O. J Madsen and S. A Øyen, eds. Trondheim: Cappelen Akademisk Forlag.

    I mean, this one is plain and simple, and to my eyes just like the ones that Zotero do insert into my document. Out of, say 10-15 today, two proved impossible.
  • Just to be clear - this is a bug in Word and there is nothing "wrong" with your citation. As Simon notes, if this isn't fixed with the final release, Zotero will implement a workaround.

    But the reason that citation doesn't insert properly is the Ø, which is a non-ascii character.
  • I don't have any formatting or non-asci in my citation and still get the error. In fact, if I open the document on a separate system that has Word 2010 and Zotero I still get the error. Here is my citation.

    J. Hudson Taylor, Men of faith : Hudson Taylor (Minneapolis, MN: Bethany House, 1986), 143.

    At this point, I am going to have to manually format every citation in my paper. Really a big bummer...Any updates?
  • provide an error report ID after triggering the error.
    See if you can reproduce the error with the same citation in a new, empty, document. If you cannot, something else is going on.
  • 1592013484 or 565626475

    I opened a new word doc and still occurs. I am Word 2013 on the new document.

    If this is a know WOrd 2013 bug, what can i do as a work around?
  • Office 2013 won't be released until next year. We will have a workaround for this by then, but the current solution is to use Office 2010.
  • > I have just upgraded Word 2013 to version 15.0.4128.1025
    > (I believe this is the RTM version) and the problem seems to be still there.

    I can confirm that the underlying bug/behavior change with Range.InsertFile affects the RTM version of Word 2013. It affects Mendeley Desktop as well.

    I sent details of the problem to MS via the in-app feedback tool with the consumer preview version but have not heard back from Microsoft.

    My understand is that the final release is due for January, although as the RTM version came early, it is possible that general release might be a little earlier than expected.
  • OK, just bumped into this issue and a web search brought me here. As our company is a Microsoft Partner I did get my Office 2013 four days ago from a partner subscription program. It is not labeled as a preview or anything else than the final product. Version is 15.0.4420.1017 MSO. As you suspect - the issue is still there, so good luck with producing a workaround.
  • I support this -- please, provide some workaround. Our department moved onto 2013 and now I fail to use zotero.
  • Pleae make a fix for this. I don't want to go back to using EndNote.
  • I wouldn't be so sure that Endnote X6 works with Word 2013 either - it's not listed as compatible and people report problems...
  • I am having the same error in word 2013 and the citations provided with the zotero like vancouver works just fine. when i tried to isntall the american medical association style of citation however, it gave me the above said message. i am a doctor and not a there a work around for this?
  • Hello,
    I use Office 2013 RTM version (final version from MS) not the preview and I have the same problem
    I changed the setting from Fields to Bookmarks and it updates the references.
    But is there some cons in this choice?

    Can you update zotero to be compatible with word 2013?
  • edited January 17, 2013
    I've added a workaround for this bug to the WinWord Integration Trunk XPI. Firefox users can install it and let us know if it works. (To stop receiving further experimental builds of the Word for Windows plugin, you will need to manually install the next official release, which will probably be soon.)
  • That trunk version worked perfectly for me :D

    (running Word 2013 Preview)

  • I've tried this trunk version and it doesn't resolve my issue where the references are numbered as follows:

    [1] ..
    [3] ..
    [3] ..
    [4] ..

    How can I troubleshoot this thanks.
  • edited January 24, 2013
    edit: nevermind my first attempt at this, I get it now:

    @hpr - different issue, please start a new thread and provide more details, including if you can replicate the issue with a different citation style and in a fresh document.
  • edited January 26, 2013
    Logre insertar zotero en word 2013. Lo que hice fue actualizar el word 2010 (con el plugin de zotero incluído) al word 2013. Funciona muy bien.
  • Zotero Word for Windows Integration 3.1.10, which includes the trunk fixes, is now available. Those using the trunk should manually install this version from Zotero Standalone users will need to wait a little longer.
  • Installed Office 2013 (64-bit) yesterday and encountered the same problems. Reinstalled Zotero (clean install), moved from Standalone to Firefox extension, added the newly released Word Integration 3.1.10, but to no avail. Any thoughts on how to proceed? This is causing me much headache and I am not keen on moving back to Office 2010.
This discussion has been closed.