Word plugin shifts to "Final: show markup" even if track changes disabled

In a document with comments, but without track changes enabled, where the comments are hidden by setting the display to "Final", adding or editing a citation results in the display mode being changed to "Final: show markup", resulting in all comments being shown.

Whatever the reason (I think it may have to do with the track changes awareness of plugin), I think the Word plugin should leave display settings intact when there is no reason to change them.
  • Are you sure you have Word for Windows Integration 3.1.7? If so, what version of Word do you have?
  • edited June 12, 2012
    Nope, that was 3.1.5... and Word 2010 14.0.5128.5000 (32-bit)

    This surprises me:
    * is there no auto-updating of this plugin with Zotero?
    * is there no way to quickly lookup version number of Word plugin in either Word (set doc prefs menu?) or Zotero (Preferences > Cite pane)?
  • it should auto-update, yes (FF or Standalone?).
    You can see the version numbers under tools-->add-ons
  • edited June 12, 2012
    Updated, solves problem.

    The plugin hadn't been auto-updating (Firefox 10.0.1, office pc). I'll suggest the version number display in another thread, because integration with Zotero is close enough for the user to expect to find this within Zotero or the plugin itself somewhere.
  • My guess would be that FF was/is the problem - you shouldn't be able to use 10.0.1 - the current ESR version is 10.0.5, the regular version 13 and FF should auto update itself (by default without asking).
  • edited June 12, 2012
    Yeah, that's why I mentioned "office pc"... this is my work PC which doesn't autoupdate and I can't update myself.
  • Right - but since Zotero uses FF's update mechanisms, if those are (foolishly...) disabled, it won't update.
  • edited June 12, 2012
    For the benefit of others, I did discover a Firefox setting to enable the auto-updating at least addons. I will recommend our technical support to at least switch on that one.

    Firefox Options > Advanced > Update > "Automatically update" checkboxes > Addons.

    Still wouldn't hurt though to display Word plugin version number and update message in various other places.
  • what's odd about that is that this option is enabled by default starting with FF 10 - so someone would have had to purposefully turn it off on your machine.
  • Hi folks,
    I have the same problem (change of markup mode display), with several versions of word, but a current Zotero Plugin (3.5.4.). It occurs on several computers, with Zotero add-on and standalone.
    Any other idea than updating?
    Thanks, Peter
  • Should go away with Zotero 4.0.29, due out soon. Let us know if it doesn't.
  • It works now with the latest update, thanks.
Sign In or Register to comment.