ISI web of Knowledge problems

  • Thank you very much - found the directory.
  • ajlyon -

    how are you coming with the fix? I taught a Zotero class tonight and two science folks who primarily use WoS basically used the "this is a dealbreaker for me" language when it was proven that WoS wasn't working.
  • I'm a physicist and work with engineers so WoS and WoK are pretty important to us too. I'm thinking to recommend Zotero to my colleagues but I'd like to know if this will get fixed first.
  • Please go to Web of Knowledge.js and save the file to the translators directory of your Zotero data directory (

    This version saves individual items reliably, and can save a single selected item from search results. If you select more than one item from the search results window, you'll just get multiple copies of the first item. More investigation should lead to a fix for that as well.
  • Thanks for the suggestion. I just tried your fix above and I'm still getting the same error:

    "Could Not Save Item. An error occurred while saving this item. Check Known Translator Issues for more information."

    Is there anything else I might be missing?

    I did double check that the file was copied correctly. I tried closing and reopening Firefox with no change. (I even tried rebooting.)

    Zotero 2.1.10
    Firefox 8.0
    Win 7 Home Premium

    Any and all help is appreciated!
  • probably helpful if you could give ajlyon an idea of what you're looking at - I don't think WoS has stable URLs, but if you could provide e.g. a database and specific article that isn't working that'd be helpful.

    Also, you could re-trigger that error and click on report error. To facilitate things, instead of sending the error report, you can just look for the error that contains "ISI Web of Knowledge.js" and post it here. If that doesn't make sense, just send the error report and post the ID here (pasting the message directly just saves one step).
  • Here is the requested information from my failed attempt to use ISI WoK

    Search engine: ISI Web of Knowledge, Web of Science Database.

    Report ID: 73753606

    Text of error report that has "ISI Web of Knowledge.js":

    [JavaScript Error: "TypeError: line.replace is not a function" {file: "file:///C:/Users/Berven/AppData/Roaming/Mozilla/Firefox/Profiles/8xskbfmd.default/zotero/translators/ISI%20Web%20of%20Knowledge.js" line: 0}]

    Link from which citation download was attempted:

    Reference to be downloaded:
    Does the movement matter? Determinants of the latency of temporally urgent motor reactions
    Author(s): Lakhani, B (Lakhani, Bimal)1,2; Van Ooteghem, K (Van Ooteghem, Karen)3; Miyasike-daSilva, V (Miyasike-daSilva, Veronica)3; Akram, S (Akram, Sakineh)3; Mansfield, A (Mansfield, Avril)2,3; McIlroy, WE (McIlroy, William E.)1,2,3
    Source: BRAIN RESEARCH Volume: 1416 Pages: 35-43 DOI: 10.1016/j.brainres.2011.08.013 Published: OCT 6 2011

    Thanks again for all the help!
  • Try installing again-- I had made a small mistake packaging. The version posted now (I just updated, so download from the URL above again) should work for searches in "All Databases". I'll go back now and see what I can do to make "Web of Science" searches work too.
  • Install now-- I now have WoS working as well. Until I work out the issue with multiple item saves, I've instituted a limit on the Select Items system, so that only the first item selected in the select items dialog will be saved.

    This still needs some more testing, but I think we're just about ready to go.
  • I just ran a test using the new file and things seem to be working.

    From Web of Knowledge using either Web of Science or All Databases, I was able to execute single item saves and also multiple item saves with only the first selected item being saved.

    Thanks so much for the help!
  • Great, I'll push this out then -- much better than nothing.
  • Pushed. Clients should receive the new translator within 24 hours. Select "Update translators" from the Zotero prefs to receive it immediately.
  • Hi
    Thanks for this - very useful.
    I am still only able to execute single item saves from WoS - is this the same for everyone? I have updated translators. Do I need to reinstall?
  • I think only single items is still the status quo.
  • Yes, there are unresolved issues that make multiple item saves fail, so this is limited to one item per save at present. Sorry about that.
  • What is the latest status on WoS translator? I started using Zotero last year and initially I wasn't able to save items using the "document icon" in the address bar then suddenly I was able. Today when I used WoS the icon was gone from the address bar again. Not sure when that began to happen.

    I am running Zotero v3.0.3 plugin under Firefox 11. I have a ISI Web of Knowledge.js translator dated 3/23/12 in the translator folder.
  • Oops. False alarm. After I realized the document icon was also missing from Google Scholar, I rebooted my machine and got it back in WoS as well. I take it multiple item save is still a no go.
  • Hello,

    I want to save the whole list of items via the folder icon, it seems to work (I get no error message) but only the 1st item of the list is saved... :-(

    Any ideas ?

    I'm running Zotero 3.0.8 on FF 16
  • that's a known issue, currently nothing easy you can do:
    but Zotero will import ISI's export format IIRC, so that might be a way to import large chunks of items.
  • the ISI translator has now been fixed for multiples courtesy of Aurimas and should also perform more reliably in general.
Sign In or Register to comment.