Zotero crashing when saving from Connector

This discussion was created from comments split from: Zotero Connector error with PubMed.
  • I'm having a similar issue with Zotero Connector (firefox on a Macbook fully updated to Monterey)- the same error message started a couple weeks ago, but I was still able to use Zotero normally by dragging & dropping a downloaded PDF.

    Happened on PubMed and ScienceDirect, and most of the time it would still make a Parent item for the PDF I was trying to add via Zotero Connector, just not automatically download the PDF. That worked up until last night.

    This morning Zotero started crashing every time I try to use Zotero connector on firefox in any way. Problem report says "Zotero quit unexpectedly"

    Things I've tried:
    - Made sure Montery was fully updated & restarted computer
    - Cleared Firefox data, checked to make sure it's fully updated & restarted it
    - Downloaded most recent Zotero Connector & re-installed
  • Retrieving PDF metadata started crashing Zotero now, so I found this post:


    No longer crashing after turning off these add ons:
    Storage Scanner, Zotero AutoIndex, and Zotero Citations Counts Manager
Sign In or Register to comment.