Incorrect margins when dragging reference to Word 2007 from Zotero 1.0

If I open a brand new Word 2007 document, with the current style set to the default of "Normal", and with one inch margins on top, bottom and both sides, any reference I drag from Zotero 1.0 and drop into Word overrides the Word margins and sets the left margin to 0.5 inch. I noticed this with the APA and developmental APA 6 export modules, but I get the same thing with others as well. What must I do to drop a bunch of references onto Word and have them automatically end up with a left margin of 1.0 inch, and a hanging indentation so that there's another 0.5 inch indentation on the second and later lines of every reference?
    has the general issue.

    This may be a first clue of where to start:

    I just figured it out. Under 'Format' in Word 2003, and then 'Font', there is a button on the bottom of the window called 'Default'. If prior to clicking that default button you select the font and the size you want all text to appear, and then click the 'Default' button, it will ask if you want to change the default font and font size to what you've selected. Click 'yes' and it will make it standard for all text, including Zotero citations and bibliography.

    but a good more general discussion that also includes indents and margins for word would still be helpful - also because I'd like to include it in the documentation. I'm on linux so I'm limited to Ooo.
    should help for Word 2007
  • I've updated this
    hope it helps
  • adamsmith, I don't understand what point you're trying to make with the microsoft URL. Reading the doc, it doesn't seem to bear on the problem of the malfunctioning margins.

    Perhaps somebody who has a Windows machine and Word 2007 can verify whether this is just me or whether there is indeed a problem that wants solving. Anybody?
  • as part of adjusting the "Normal" style you can adjust margins and indents. That's what you should do.
    You say yourself that Zotero also overwrites your formatting.
    That's one and the same issue.
  • Yes, I know how to adjust the margins and indents of the "Normal" style. When I do that and then drag a Zotero reference into Word and drop it onto a "Normal" paragraph, it still puts the left margin at 0.5 inch with an additional 0.5 inch hanging indent. I think you really do need to get a look at how this works in Word. I quite sympathize with your preference for using Linux and OO.o -- I am a Linux user at the office. But I also teach for the University of Phoenix. A colleague and I are trying to soften the blow of APA 6 for both students and faculty at the Houston Campus, and Zotero certainly does that -- especially with your new APA6 export module. But I don't particularly want to have to tell everybody that Zotero does everything except put the text where it needs to be put, so that they'll have to adjust it manually afterwards. So if you know anybody who has Word 2007 on a Windoze box, please try this out and see whether it's just me or whether it's really an issue at the interface between Zotero and Word.
  • (Just to be clear, adamsmith doesn't "need to" do anything—he's a member of the community volunteering his time to help you. But someone else might take a look.)
  • Sorry, Dan, I didn't mean to imply that he has an obligation to me or to anybody else -- only that, because he seems genuinely interested in helping to figure out what's wrong, he -- or somebody -- will need to look at a Windows machine to be able to diagnose it. Looking at Linux boxes is certainly a preferable pursuit, but the students and faculty I am trying to help don't know how to spell "Linux", let alone use it. I must figure out how to do this in Windows, and I will very much appreciate any assistance that anybody can give.

    I apologize for the misunderstanding.
  • Not a problem. Just wanted to manage expectations.
  • OK - I'll have a look next time I get to a Windows machine (although if anyone else gets there first - for me it will take some time...try to avoid those...) - I still think this has to do with the way the Word Defaults in the "Normal" style are set up, but maybe I'm wrong.

    Before, could you try out two things for me, though:
    If you use the Word plugin, cite a bunch of items and then create an APA bibliography - do you get the same effect?
    If, instead of dragging, you use the "Create Bibliography" function (select items in Zotero and right-click), copy to the clipboard, and then paste into Word - same effect?
  • Well, now I know why nobody has reported this bug yet. I'm so new here, I had not yet discovered the Word plugin. All I knew about was drag and drop. The Word plugin works just fine. I imagine very few serious users ever do the drag and drop thing, so it's no wonder it hasn't been reported before. Trust me to do something the stupid way.

    To answer the rest of your question: When I use "Create Bibliography" and let Zotero create the bibliography in a new Word document, it comes out right. But when I have it send its data to the clipboard and then past that, it has the same error as before: Incorrect left margin at 0.5 inch, with hanging indentation of another 0.5 inch.
  • OK, so whatever it is, it's less crucial than we thought, which is good.
    I'll have a look at the drag&drop feature when I get a chance - if the word plugin does this right I'm a lot less convinced that this is due to Word default specifications.
  • Just a note: I'm using the Word 2008 for Mac and I'm having this same problem when I create a bibliography directly from within zotero. I want to create a bibliography based on everything in one of my folders; I select all the documents, control-click for "create bibliography," choose "copy to clipboard," and then paste into a Word document. It's overriding my margins (to .5 inches on the left instead of 1) and also bringing in the text in 10-point instead of 12-point Times. I tried changing my "Normal" template but it didn't help.

    When I create a bibliography within a document based on the citations I've inserted, that DOES work fine, so I think the problem is not with the Word plugin.
  • edited April 29, 2010
    Hello, I also have the same problem with margins both with dragging and right-clicking method.

    In addition to the margin problem, when I "drag" bib info into a single-spaced paragraph, the pasted portion comes out as a double-spaced paragraph.

    Also, font comes out differently: dragged portions usually comes in Times Roman, but the rest of my document uses a different font.

    Every time I do this "pasting" of the bibliographic information, I have to 1. fix margins, 2. change to single-space, 3. change font.

    I would really appreciate any help going about these issues.

    I tried to search the forum for a forum but this was the only thread I could find. I'm not a technical person so excuse me if my language is not up to par. I hope I conveyed what I wanted to say.

    I use Microsoft Word 2007 and the zotero in Firefox, both the latest version on a PC.
  • what exactly are you pasting? Bibliography entries?
    Which citation style?
  • I meant "dragging" --

    Thanks for the quick response.

    I'm using APA 6th .. and I'm pasting bibliographic entries, yes. From the middle column in zotero.
  • I have set Estrangelo Odessa as my default font in MS Word 2007.
  • I don't have Word 2007 here, so I can't fully replicate this, but as a start - make sure you have the different font and spacing set in the style you're using - for me, Zotero uses the respective style of the paragraph it's pasting into.
    see e.g. here for word styles:
  • edited April 29, 2010
    This doesn't work. Thanks, though. I hope someone can find solution for this because it's a very pesky problem.
  • I have also experienced this problem on Word 2008 for Mac.
  • would people be willing to do some testing?
    i.e. see if changing the normal style in Word makes a difference,
    see if this happens all the time or depends on the style
    see if drag&drop vs. create bib & paste makes a difference
    see if you only go from single to double space, or also the reverse

    etc. - the more clearly this can be replicated the easier it can potentially be fixed.
  • Before discovering this post, I had opened a new discussion related with this one :

    I work with Windows Vista, Word 97, use a french version of Zotero.

    To create a bibliography, I have the following choices :
    - create a RTF file
    - create an HTML
    - copy to the clipboard
    - print

    As I explained in my previous post, RTF files look perfect for alignment, but don't take in account some other functions.

    From my tests, I would say that the problem occurs with all indented styles, whatever the Word settings are.

    Copy to the clipboard or create HTML, when pasting into Word, give the same ugly result.

    I modified the Word paragraph default as follow :

    left margin: 0
    first line indent: +1.25cm
    before paragraph: 0
    after paragraph: 10 pt
    space-line: multiple 1.15

    I opened a new file, wrote some text which used this default settings, pasted the bibliography after the text

    The bibliography's paragraph settings are completely different than the text's ones:

    left margin: -1.27 cm
    first line indent : -1.27 cm
    before paragraph: 13.2 pt
    after paragraph: 0
    space-line: at least 13.2 pt

    Certainly related to that too, I noticed a problem inserting "display=block", (reported in the post :

    In this case, the block paragraph settings are

    left margin: 0 cm
    first line indent : +1.27 cm
    before paragraph: 0 pt
    after paragraph: 0
    space-line: at least 13.2 pt

    In this case too, if selecting create RTF file, the block parts are well aligned :

    Angebault Christophe. « L'exception d'Alceste, ou comment le classicisme a pu servir
    ------à la modernité » [En ligne]. Dix-septième siècle, 2004, vol. 2/2004, n° 223, p.
    ------URL : < >
    ------DOI : < 10.3917/dss.042.0183 > [consulté le 27 août 2009]

    It seems that Zotero and Word have some communication problems
  • edited August 31, 2011
    I'm having the same problem as everyone else on this forum - Adam have you figured anything out?? Let me know if I can help you work this out. I'm using Word 2007. I realize that the word plugin can help especially in creating a bib. but when I want to drag/drop single bibliography entries as I often need to do with colleagues or students I always have to readjust the margins. I have tried to adjust the "normal" word font and paragraph settings but after I do this and drag/drop it always reverts back to the initial settings.
  • Just some more feedback...

    I too have this problem with Word 2010 on Windows 7 64bit, dragging into either Word or an email using Outlook. It's especially problematic in 'draft' view (which I normally use) as the text goes off screen to the left. In 'print' view it is better as it goes into the margin area, but it can still be seen there with a decent margin size.

    Yet, dragging into Googledocs is better (it shifts a very little to the right, but that is better than to the left as in Word).

    I use the drag feature when doing preliminary work, e.g. making lists of books to consult, etc, as I drag from Zotero into the body of a document, but not into footnotes at that stage. While the plugin for proper citations as footnotes works fine, it would be great to have the drag feature working in Word without the margin problem, as well as for emails.
  • Has there been any progress with this glitsch? I have the same problem when copy-pasting bibliography items into Word 2011 for Mac using Chicago styles. The paste ignores the paragraph and document default settings (yes, I have checked these in the Normal dot, ect.), pasting at 0.5 rather than 1 inch and at 10 pt rather than 12 pt Times Roman.

    I was hoping that the recent updates, especially the new 3.0 would rectify this.

  • This glitch persists in 3.0.1 FF, with Word 2011 on a Mac.

    I still have the glitch as described above with Chicago styles when copy/pasting: outdented by 0.5 inch and 10 pt rather than 12. Paste is single-spaced.

    If I switch to MLA, I also have outdented by 0.5 inch and 10 pt rather than 12 but paste is double-spaced throughout. And it also changes the font from Times New Roman to Times, tout court.

    In APA, same as MLA, except font remains Times New Roman.

    In AMA, the margin is correct and entries are single-spaced, but font also shifted to 10 pt Times, tout court, and the turn-overs are not indented but flush at the margin.

    What gives with these margin and font problems? Any chance they'll be fixed?
  • Sorry to necro this thread, but I'm new to Zotero (standalone version 4.0.9) and find that the problem persists with Word 2013: if I drag a citation into a Word document or try quick copy, it overrides the values for default margins and hanging indents. I tried following the advice to change the default template in Word but this has no effect.

    I've also found that this issue does not occur with all output styles. I thought perhaps it could be fixed by edited the output styles but I couldn't find any corresponding values in them.

    Any suggestions, I hope?
  • which styles does it occur with?
  • APA, Chicago, Elsevier Harvard, Modern Humanities Research Association, and MLA. I haven't tried styles not included with the standalone client.
  • right, so those are all the indented styles, same as above.

    See if setting
    to true in the hidden preferences of Zotero
    makes a difference.
Sign In or Register to comment.